Teamviewer 11 and Debian Server 8.3,

Hello,
I am having an issue the EXACT same as this one below in an old post.
http://linuxforums.org.uk/index.php?topic=12154.msg98724#msg98724

However although I am having the exact same issue NOTHING tried from LF or any other site has worked on the install whether it’s i386 with upgrades or even 64. I get the EXACT same error as was shown in the post on this one near the bottom. However it’s with Version 11, when I attempt to run "sudo apt-get install -f " it removes Teamviewer completely. As I said I have done everything exactly as was posted, as well as following ALL of Teamviewers specs… And I get Notta still… If anyone has any idea WHAT may help I would sincerely appreciate it.

TY in Advance,

Same error as hers below BUT Version 11
jenny@dt2:~/teamviewer-installer$ sudo dpkg -i teamviewer_linux.deb
Selecting previously unselected package teamviewer9.
(Reading database … 231255 files and directories currently installed.)
Preparing to unpack teamviewer_linux.deb …
Unpacking teamviewer9 (9.0.32150) …
dpkg: dependency problems prevent configuration of teamviewer9:
teamviewer9 depends on libc6 (>= 2.4).
teamviewer9 depends on libgcc1.
teamviewer9 depends on libasound2.
teamviewer9 depends on libfreetype6.
teamviewer9 depends on zlib1g.
teamviewer9 depends on libsm6.
teamviewer9 depends on libxdamage1.
teamviewer9 depends on libxext6.
teamviewer9 depends on libxfixes3.
teamviewer9 depends on libxrandr2.
teamviewer9 depends on libxrender1.
teamviewer9 depends on libxtst6.

dpkg: error processing package teamviewer9 (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
teamviewer9
jenny@dt2:~/teamviewer-installer$

Have you tried the instructions here:
http://forums.debian.net/viewtopic.php?f=17&t=114683#p541870