Thunderbird

Dear Forum,
Having had wonderful help from the Forum when installing Ubuntu, I would be grateful for help with a long-standing problem with Thunderbird.
When using it on XP it was fine until I upgraded it and suddenly I could send but not receive Emails. Now using Ubuntu, I have tried but can’t get on with Evolution so installed Thunderbird in the hope that it would be compatible with Ubuntu.
Sadly not - the same error message occurs: Sending of password did not succeed. Mail server pop.mail.yahoo.com responded: Incorrect username or password.
I have checked all the settings, of course, to no avail.
This is beginning to look like a BT/Yahoo problem, but I would be grateful for advice from anyone with similar experience.
Many thanks.
Keith

As your email account ends @btinternet.com I’m going to guess you are using the wrong mail servers.

Are you a BT Yahoo! customer ?

If so I’m pretty sure your mail servers should be -

Incoming Mail (POP3) Server = mail.btinternet.com
Port = 110

Outgoing Mail (SMTP) Server = mail.btinternet.com
Port = 25

User Name = Your FULL email address (including the @btinternet.com part)
Password = Your BT Yahoo! password

And make sure SMTP authentication is enabled.

See here:
http://bt.custhelp.com/app/answers/detail/a_id/6876
and this thread about someone who had the same problem when using the *.mail.yahoo.com mail servers:
http://forums.techguy.org/all-other-software/1002361-solved-thunderbird-yahoo-password-rejected.html

This should step you through it:
http://help11.creativevirtual.com/btpoc/bot.htm?isJSEnabled=1&uid=1315841090894&entry=Email%20Setup
Select Windows, then Thunderbird… settings are the same for the Linux versions of Thunderbird

Mark,
Thanks for your assistance once again.
The default incoming server name was “pop.mail.btinternet.com” I deleted the pop bit but there is nowhere else to specify the type.
Similarly: outgoing server was “smtp.mail,btinternet.com” and I deleted the smtp without being able to specify it elsewhere.
Adding the “btinternet.com” to the username had the effect of adding it also the the default (bt/Yahoo) junk folder address! i.e. “my_username@btinternet.com@btinternet.com” which makes it look as though the suffix is assumed (and it wasn’t needed when Thunderbird worked in XP).
the Authentication box does not list SMTP so I opted for the default “normal password”.
…and despite hacking all the variables, It still doesn’t work.
Using the Evolution parameters (which works OK) don’t work either.

Keith

Have you tried the stepthrough link I’ve just added above ?

If so, see your PM’s


[EDIT]

Here’s some settings that appeared to work for someone else -

Incoming Server
Server type - POP
User name - your user name on btinternet
Server name - mail.btinternet.com
Port - 110
Connection security - None - (both STARTTLS and SSL/TLS failed to
connect)
Authentication method - Password transmitted insecurely - (does not
accept encryption)

Outgoing Server
Description - anything
Server name - mail.btinternet.com
Port - 465
Connection security - SSL/TLS
Authentication method - normal password
User name - your e-mail address

Set up all of the other options appropriately. Don’t forget to re-
enter your correct e-mail address in the main account settings screen.

From here:
http://groups.google.com/group/thunderbird-webmail-extension/browse_thread/thread/a7984982c238092d?pli=1

You might also want to try that with port = 25 for SMTP (as the BT website suggests)

They’re pretty much the same as my first response, but with the authentication methods added, and the SMTP port changed.


This is a BT Yahoo! (ISP) account, and not just Yahoo webmail isn’t it ?

Thanks to Mark, Thunderbird is now working with BTinterent.com on Ubuntu. I list below the settings I am using:

Thunderbird Account Settings

Main Page
Account name: your.name@btinternet.com
Your name: Your Name
Email address: your.name@btinternet.com

Incoming Server Settings
Server type: POP Mail Server
Server name: mail.btinternet.com
Port: 110
User name: your.name
Connection security: None
Authentication method: Password transmitted insecurely

Outgoing Server Settings
Server name: mail.btinternet.com
Port: 465
Connection security: SSL/TLS
Authentication method: Normal password
Username: your.name

Note: Setting the outgoing port to 465 produces a warning but just accept it.

Thanks for those Keith… it’s nice of BT Yahoo! to publish the SMTP port as 25 (rather than 465), I’m sure they’ll confuse a LOT of people with that ::slight_smile:

…and whilst we’re on the subject of Thunderbird… I have two niggles that someone might have solved already but I haven’t found on the forum:

  1. How do I make Thunderbird the default client? I have set the preferences for T/B to check upon startup if it is the default Email client.
  2. More tricky. When receiving spam/scams/phishing I always forward the headers to the mail-abuse address of the first listed ISP and also to Email@ActionFraud.org.uk, but unlike Outlook Express, I can’t select and copy the whole header list, only individual lines, and even then without the title of the line.
    Any ideas?

Many thanks, as usual.
Keith

To set Thunderbird as a the default mail program, search the application lens (on the launcher bar) for Preferred Applications

You can set the Mail Reader in there.

Can’t really help with the second issue… I don’t use Thunderbird anymore, but if I stumble upon anything I’ll post it :slight_smile:

Meanwhile, maybe some else that does use Thunderbird can help ?

Clicking on the Lens/Applications symbol does not list “Preferred Applications”.

In the Ubuntu Software Centre: if I click on the Thunderbird icon there is a list of options including “support for Gnome in Mozilla Thunderbird”. Ticking this option has no effect and the tick has gone when I return to the list later.

Clicking “system/preferences/Email settings” results in an error: “Could not launch Email settings. Failed to execute child process ‘Evolution Settings’ (no such file)” which is because I had un-installed Evolution. Bad move?

Clicking Start/System settings lists lots of things that can be configured but there is no response to clicking “Email settings”, although clicking other icons does indeed provide “Preferred Applications” choice.

I am presuming that the envelope icon (top right of screen) launches the default email client.
By the way: what client do you prefer?

Click on the application lens icon on the launcher… in the search box at the top, enter preferred applications … an icon for the Preferred Applications should then be displayed in the main window;)

As a matter of fact… you’ll only have to enter pref and the icon will be listed :slight_smile:

If you’re still having problems finding it… open a terminal and run:

gnome-default-applications-properties

[EDIT]

Actually from what I hear… uninstalling Evolution in Ubuntu isn’t a clever idea, as it’s very integrated into the desktop… but I have no experience of this myself.

When 11.10 comes out… Thunderbird will be replacing Evolution as the default email application anyway :slight_smile:

Definitely no search box! But the terminal method worked OK → and Thunderbird was the only Email client listed.
My initial query was simply to be able to start up Thunderbird by clicking the envelope icon, but as you indicate that Evolution is very integrated into Ubuntu, that could explain it all. And selecting T/B from the applications is no real hardship. Roll on V11.10.

Thanks as usual for your help. … and I have more questions on other topics later!

Keith

Are you saying that when you click the Application Lens icon on the Unity launcher bar

Unity Launcher - Application Lens

http://linuxforums.org.uk/MGalleryItem.php?id=1489

That there is NO search box at the top (see the red arrow in this pic) ?

Unity Application Lens

http://linuxforums.org.uk/MGalleryItem.php?id=1490

That’s right - absolutely nothing like yours! —>
I tried this:
img/home/keith/Desktop/Link to screenshot.jpg/img with square brackets around the “img” and “/img”
but there is no image when I upload the post. Any ideas?

Perhaps it’s relevant that I have to run Ubuntu “without effects” to avoid display problems.

Isn’t Keith running Ubuntu Classic by default? I’m pretty sure I read that somewhere round here once… Hmm…

I think that’s correct - all I remember doing (at Mark’s suggestion) was to select “Without Effects” at the bottom of the screen before logging in and it has done that automatically ever since.
Still trying to upload an image. Might need some help with that too, if I keep failing!

My apologies… if you’re running the “Classic” desktop, you’ll find Preferred Applications in the System>Preferences>Preferred Applications menu item.

Of course!! Just failed to see it, that’s all! :-[

OK, now I think know what you were trying to achieve, here’s how to add Thunderbird to the little envelope icon (indicator applet) by your clock if you want…

gksudo gedit /usr/share/indicators/messages/applications/thunderbird

When gedit opens a blank file, add a sinlge line that reads:

/usr/share/applications/thunderbird.desktop

SAVE the file, and close gedit

Now log out and log back in again (or reboot), and now you’ll find Mozilla Thunderbird Mail/News in the indicator applet’s mail menu.

Source:


Once you’ve done that… this may interest you: