Toshiba Equium L40-17M -touchpad erratic/resetting

Hello Folks,
I thought I’d 'cured ’ this last week but it turns out I hadn’t after all . . . .

I installed LM13 cinnamon on a friends laptop as detailed in the title, created 3 accounts and the problem seems to persist in all accounts.

What happens is the touchpad almost becomes locked or so erratic the pointer flies across the screen or goes so slow you have to swipe the touchpad constantly to get it to move, sometimes a reboot or reload of the desktop seemed to cure it, other times not. I searched the model and symptoms last week and Initially I’d adjusted the touchpad settings to get around it and it seemed to work, now I’m told it’s gone back to how it was: - I was hoping someone with experience of this problem might be able to shed some light on it for me?

Thank you

Dave

Hmm … suddenly gone weird again … possibly an update, have you checked in

/var/log/apt/history.log

to see if any updates occurred just prior to it going mad again?

Hi thanks for the reply, I don’t think an update is the culprit and I’ve given it back to the owner now and he wouldn’t be able to navigate the folders. I’ve been mooching around and some common themes are occurring . . . . the power supply and battery for one, people reporting the ‘cure’ when they’re plugged out (but his battery is iffy to start with) and also someone mentioned the problem going when the display size was changed, never thought of that angle, I’m replaying some messages to him by text for now, he’s fairly local but I’ll get him to troubleshoot for now til we narrow it down. I’m not convinced it’s a ‘linux problem’ judging by the amount of vista problems reported on the toshiba forums lol . . . . . .

have you checked in

/var/log/apt/history.log

As a matter of interest… what should he see there if anything, related to this ??

As a matter of interest...... what should he see there if anything, related to this ??

a log of installed/uninstalled apps including updates.

If you’re looking for a particular … I don’t know, I just wondered what had been updated just prior to the problem reoccurring.


Can’t he just disable the touchpad and use a mouse whilst troubleshooting ?

Well it was a clean install, I’d updated everything system-wide before i took it round to him, so hundreds of updates, however the problem didn’t surface until I was on one desktop at one point customising it a bit for him/his family and then the lag/judder started - I searched a bit, fiddled with the touchpad settings and this seemed to do the trick so i replicated it it on all 3 accounts. He doesn’t own a mouse, I’ve asked already! :expressionless:

What type of touchpad ? … SynPS/2 Synaptics TouchPad ?

What’s the output from:

xinput -list

and

lsmod | grep psmouse

?

[EDIT]

If the second command returns “psmouse” … tell him to try this (will only last a single boot, but if it helps we can make it permanent).

Also make him aware that his touchpad will stop working after the first command, but will start again after the second command.

Open a terminal and run:

sudo modprobe -r psmouse

then

sudo modprobe psmouse proto=exps

test the touchpad for a while.

If that doesn’t work, try:

sudo modprobe -r psmouse

then

sudo modprobe psmouse proto=imps

test the touchpad for a while.

Thank you mark,

I may end up going round to do this for him lol . . . . I’ll have to suss him out first on how brave he is with a terminal . . . . . leave it with me, I’ll come back to you :wink:

Like I said, those will only work until he reboots then will need reapplying, but if either of them solves the problem it can easily be applied permanently.

I’ll post how in a sec when I have time.

[EDIT]

OK, let’s say the “sudo modprobe psmouse proto=exps” solves the problem.

To make that permanent (so it will survive a reboot), run:

sudo gedit /etc/modprobe.d/psmouse.conf

When a BLANK file opens, add a single line that reads

options psmouse proto=exps

SAVE the file, and reboot to test.


OR

Let’s say the “sudo modprobe psmouse proto=imps” solves the problem.

To make that permanent (so it will survive a reboot), run:

sudo gedit /etc/modprobe.d/psmouse.conf

When a BLANK file opens, add a single line that reads

options psmouse proto=imps

SAVE the file, and reboot to test.

Thank you for the concise reply :slight_smile:

I’ll let you know how I got on . . . . . I may make a point of calling on him sunday if he’s still having trouble.

Good luck :slight_smile:

OK so I have this laptop back now after a very frustrating hour trying to move a cursor round a screen, I tel no lies when i say it took 3 reboots to get in and out of the terminal and copy/paste commands . . . . my brain hurts - the state of play:

"If the second command returns “psmouse” … tell him to try this (will only last a single boot, but if it helps we can make it permanent).
Also make him aware that his touchpad will stop working after the first command, but will start again after the second command.
Open a terminal and run:
Code: [Select]

sudo modprobe -r psmouse

then
Code: [Select]
sudo modprobe psmouse proto=exps
test the touchpad for a while.

If that doesn’t work, try:
Code: [Select]
sudo modprobe -r psmouse

then
Code: [Select]
sudo modprobe psmouse proto=imps
test the touchpad for a while."

This: sudo modprobe psmouse proto=imps - appeared to make a difference, for a while, at first it slowed down the erratic movements to something like controllable but then it went to the dogs again and became unresponsive/extremely slow. Out of curiosity because I had it on me, I booted from a ‘Tails’ USB to see if that made a difference, the cursor wouldn’t even move, which is bizarre in itself as the mint USB boot originally seemed flawless, maybe it’s 'cos it’s debian?

Annoyingly. . . . . having just gone out to the shed and dug out a USB mouse, it appears not only that the mouse works fine, so does the touchpad… plug it out, and it works fine, for a minute, then lags like mad again, desktop becomes unresponsive, can’t ctrl/alt/backspace to restart the desktop, got to reboot.

Upon reboot with the mouse in, nothing, until i used another usb port where it came back to life . . . . . maybe I need to leave this on for a bit and fiddle about with the usb mouse in to see if it’s usable like that, in which case, I’ll give him the mouse, but it would be good to ‘fix’ the touchpad if the above give any more clues that help towards a fix? I’m kind of hoping this is a software issue rather than hardware…

So what’s the output from:

xinput -list

??

also … plug the mouse in, so the touchpad also works, then run:

dmesg > ~/Desktop/dmesg.txt

you’ll then find a file called dmesg.txt on your desktop … can you post the contents to pastebin

then post a link to your pastebin back here.

Thank you, not long back in, left the laptop on, mouse still in, touchpad is acting normal with the mouse plugged in still …

output of :

xinput -list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)	id=10	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Asus Laptop extra buttons               	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]

Cheers

Dave

Does plugging ANY USB device into that USB port calm down the touchpad ?

You have a TON of USB errors on a device attached at usb5-1 … and these appear to stop when you plug the mouse in

[ 90.232087] usb 5-1: new low-speed USB device number 63 using uhci_hcd [ 90.356078] usb 5-1: device descriptor read/64, error -71 [ 90.580082] usb 5-1: device descriptor read/64, error -71 [ 90.796088] usb 5-1: new low-speed USB device number 64 using uhci_hcd [ 91.204058] usb 5-1: device not accepting address 64, error -71 [ 91.316087] usb 5-1: new low-speed USB device number 65 using uhci_hcd [ 91.724078] usb 5-1: device not accepting address 65, error -71 [ 91.724102] hub 5-0:1.0: unable to enumerate USB device on port 1 [ 111.956054] usb 6-1: new low-speed USB device number 2 using uhci_hcd [ 112.158367] input: Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) as /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/input/input11

Hi Mark, yes it does appear if i unplug the mouse and plug in a USB stick, the touchpad becomes more usable, although still a bit random, i.e it can randomly select a line or more of text just glancing the page, clicking or hovering on the title bar at the top can have the effect of resizing the window to max and back and raising a window from the taskbar can be random and it an close unexpectedly without a right click menu, all that said, it’s better than it was lol !

I did notice the other day the usb port on the side seems a bit iffy, so i’ve been plugging the mouse into one of 2 ports on the rear so maybe the one showing faults is indeed faulty? It does respond to a USB stick though and opens as normal, but I noticed the light on the mouse wasn’t coming on but would on the rear ports.
Any thoughts on that ? I don’t know if the touchpad an be cured as such, and if not he’ll just have to use it with a mouse plugged in, I have it in now and it seems pretty much OK.

Are there any BIOS settings to do with USB ?

Hi Mark,

Yes, Legacy USB support is enabled, that’s the only reference to anything USB I can find in the bios…

I’ve left the laptop on all evening with the mouse in, was fine when I just checked ten minutes ago but after rebooting it’s a bit jittery on the TP but again the mouse is fine… odd . . . . . ::slight_smile:

Try turning off “tap to click”

As someone mentioned here:
http://forums.linuxmint.com/viewtopic.php?f=47&t=129344&sid=2ce3fa3a42f7b5594234882fdf8c15a8&start=40

Hi Mark,

I had ‘enable mouse clicks with touchpad’ disabled already, I assume that’s the same thing/different lingo, I’ve tried turning off edge scrolling and adjusting the pointer speed, all make no difference. I read through that thread from start to finish and it’s kinda good to know I’m not alone with this insomuch as at least I can possibly discount it being a hardware problem and more of a software problem. I’m wondering if it may make a difference to try some of the other synaptics software I saw in package manager, I toyed with the idea of adding another DE but I logged out of cinnamon and logged back in with the gnome desktop and gnome/no effects, and no change, so maybe for the sake of trying, I’ll have a look in package manager and see what software options there are. Just giving up and buying his daughter a mouse so she can get on facebook seems like a cop out at the moment . . . . . . .

Just found this video on youtube, it does exactly what this laptop does, my mates gone through about 4 chargers for this laptop apparently, it appears that is where the problem is stemming from . . . . but if anyone knows different please chip in :wink:

TOUCHPAD REPAIR