transparency with Compton

Hi guys

I’m trying to get transparency on conky themes in Peppermint 3 I have Compton installed but as you can see from the screenshots there is an annoying shadow spoiling the effect, the first screenshot is set to pseudo transparent which is almost transparent but with the annoying border shadow, when set to fully transparent it’s worse as you can see from the first screenshot.

According to Conky Manager to get rid of the border shadow I need to configure my window manager but as hard as I look I can’t find anything setting I can adjust.

Any help would be much appreciated

Graeme

Why not add the xfwm4 window manager to Peppermint 3 (like PM4 has) ?

http://linuxforums.org.uk/index.php?topic=10436.0

Thanks for that Mark

I followed your instructions but I still hve the annoying border shadows I.ve been through all the settings in xfwm4 manager and tweaks But I just can’t shift it

Graeme

is it the drop shadow you’re trying to get rid of ?

if so it’s probably part of the conky theme itself … so would need disabling in the .conkyrc

is it the drop shadow you're trying to get rid of ?

Yes I think that’s what they are

According to Conky Manager they can be removed by making changes to the Window Manager

if you’ve tried turning drop shadows off in xfwm4 … and they’re still there.

gimme a link to where you got the conky script you’re using.

if you've tried turning drop shadows off in xfwm4 .. and they're still there.

I’ve been through all the settings in xfwm4 window manager settings & window manager tweaks and I see no reference to drop shadows

if you've tried turning drop shadows off in xfwm4 .. and they're still there.

The script is a Conky Manager theme called Tux it’s just a simple analogue clock, I don’t think I should have to tamper with the script because the same script gives me full transparency on my desktop PC running Peppermint 4

Many thanks

Graeme

Is this an autostart issue, where conky is starting before the desktop is properly loaded ?

Where’s it getting autostarted from ?

Is this an autostart issue, where conky is starting before the desktop is properly loaded ?

No I don’t think that’s the issue because even if I disable the script then enable it again it’s just the same long after the desktop is loaded

Where's it getting autostarted from ?

I don’t really know I just ticked a checkbox within Conky Manager “Run Conky at System Startup” and it autostarts no problem

Ahh … but saying “no problem” doesn’t make it so Cptn :wink:

run:

sudo updatedb

then post the output from:

locate themes/Tux
graeme@Linux-Laptop1 ~ $ locate themes/Tux
/home/graeme/conky-manager/themes/Tux
/home/graeme/conky-manager/themes/Tux/config
/home/graeme/conky-manager/themes/Tux/preview.png
/home/graeme/conky-manager/themes/Tux/config/conkyrc
graeme@Linux-Laptop1 ~ $ 

What is the contents of /home/graeme/conky-manager/themes/Tux/config/conkyrc ?
I used to play about with conky some time ago and did have similar artefacts at some point.
Sometimes a delayed start for conky helps as it is taking the image of the underlying desktop as a background (not truly transparent).

Hi SeZo

double_buffer yes
no_buffers yes
text_buffer_size 2048
imlib_cache_size 0
 
# -- Window specifications -- #
 
own_window_class Conky
own_window yes
own_window_type normal
own_window_argb_value 0
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
border_inner_margin 0
border_outer_margin 0
minimum_size 300 300
maximum_width 300
alignment top_right
gap_x 0
gap_y 0
 
# -- Graphics settings -- #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
 
# -- Text settings -- #
use_xft yes
xftfont ConkySymbols:size=134
xftalpha 0.3
uppercase no 
default_color 373b3c
 
# -- Lua Load -- #
lua_load ~/.conky/.crings_ns.lua
lua_draw_hook_pre clock_rings
lua_load ~/.conky/.marks_ns.lua
lua_draw_hook_post main

own_window_argb_visual no
own_window_colour 000000
TEXT
${voffset 3}${offset 162}${color 18181A}${font ConkySymbols:size=18}a
${voffset 0}${offset 142}${color 18181A}${font Linux-title:size=14}  Linux${font}${color}
${voffset -301}${color black}${offset 85}a

Sorry to have raised your hope, but it appears that I have misplaced my conky related notes… :-[
All I seem to remember that I have played about with various own_window entries.

You could try changing the following lines (just comment out the original lines with #):
own_window_type normal
to:
own_window_type dock

own_window_argb_value 0
to
own_window_argb_value 100

own_window_argb_visual no
to:
own_window_argb_visual yes

own_window_colour 000000
to
#own_window_colour 000000

Does it still show shadows if you kill it:

sudo killall conky

then restart it from the command line:

conky -c /home/graeme/conky-manager/themes/Tux/config/conkyrc

?

Ok I stopped and restarted as per Marks instructions and it made no difference, I then followed SeZos instructions as much as I could as 2 of the entries he asked me to change were not listed in my config file, but it worked nonetheless except it moved it’s location from the right to the left but I was able to get it back where I wanted by altering the coordinates in Conky Manager options, I don’t know what linechange did it but it’s now transparent

Thank you both for your help

Graeme