trouble installing virtualbox (Solved)

Hi,
I have almost completed an install of virtualbox. When I get to this it throws an error as follows

don@ldwatson ~ $ sudo apt install build-essential linux-headers-generic dkms virtualbox-4.3
Reading package lists… Done
Building dependency tree
Reading state information… Done
build-essential is already the newest version (12.1ubuntu2).
build-essential set to manually installed.
dkms is already the newest version (2.2.0.3-2ubuntu11.5).
linux-headers-generic is already the newest version (4.4.0.116.122).
linux-headers-generic set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
virtualbox-4.3 : Depends: libvpx1 (>= 1.0.0) but it is not installable
Recommends: libsdl-ttf2.0-0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
don@ldwatson ~ $

How can I sort this out ??

Don W

Where the heck are you getting virtualbox-4.3 from ?

That’s a VERY old version of virtaulbox and isn’t even in the default repositories for 16.04 (and therefore Peppermint 7/8) … so you must have added a PPA that contains it ???

Anyway, first remove it:

sudo apt-get remove --purge virtualbox-4.3

then follow these instructions to install the latest version ( currently 5.2.8 )

Run:

sudo pluma /etc/apt/sources.list

add these 2 NEW LINES at the bottom (DO NOT add them twice):-

## Virtualbox repo
deb http://download.virtualbox.org/virtualbox/debian xenial contrib

SAVE the file and close the text editor

Back in the terminal run:

wget -q http://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -

enter your password when asked, and hit enter to continue … then run:

wget -q http://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

then

sudo apt-get update

then

sudo apt-get install virtualbox-5.2

then visit this page
https://www.virtualbox.org/wiki/Downloads
and download the file VirtualBox 5.2.x Oracle VM VirtualBox Extension Pack by clicking the blue wrting that says All supported platforms.

Once downloaded, double-click the Oracle_VM_VirtualBox_Extension_Pack-5.2.x-xxxxxx.vbox-extpack to install it.

All done.

You’ll now find it in the menu at

Menu > System Tools > Oracle VM Virtualbox

Thanks Mark,
I will scurry off and remedy my misdeeds. :-[ I believe I picked the programme from the Software Manager pack (it may have been Synaptic as I tried both), however I will put your suggestions into practice.

Don W
EDIT OK Mark,
I have carried out those suggestions but it looks as if I have screwed up the system. I get these error messages :

1 The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

‘/sbin/vboxconfig’

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn’t match the version of the user.

2 Failed to open a session for the virtual machine win 7.

The virtual machine ‘win 7’ has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

I have been trying to get one Windows programme running for a month now. I have done everything with this computer and will need to re-evaluate if it is worth it. If I can’t get VirtualBox to run Win 7 I will consider installing win 7 as a dual boot with Pep 7.

Thanks for your help it is very much appreciated.
Don W

Well virtualbox-4.3 isn’t even in the default repos, so you must have added a PPA that contains it otherwise it couldn’t have even attempted to install … no problem, we should be able to fix this.

see if running:

sudo apt-get remove --purge virtualbox-dkms

then

sudo dpkg-reconfigure virtualbox-5.2

fixes the problem … BTW, answer YES to adding the vboxuser group when prompted

If that doesn’t fix the issue…

What’s the output from:

lsmod | grep vbox

and

modinfo vboxdrv

and

dpkg -l | grep virtualbox

and

for APT in `find /etc/apt/ -name \*.list`; do grep -o "^deb http://ppa.launchpad.net/[a-z0-9\-]\+/[a-z0-9\-]\+" $APT | while read ENTRY ; do USER=`echo $ENTRY | cut -d/ -f4` PPA=`echo $ENTRY | cut -d/ -f5` ; echo ppa:$USER/$PPA ; done ; done

Thanks for that Mark.
I entered the first 2 commands and it looks as if all’s well.
The programme is working fine so I will try it out for a while before marking this solved.

take care
Don W
EDIT Thanks Mark,
I have conceded defeat. :cry: I have almost lost the will to live. :frowning:
After my brief success, when I shut down the Win 7 in VirtualBox it downloaded 10 updates before closing.
When I restarted Win 7 I had to wait while it installed 74,417 updates before I could access Win 7.
When I finally got in I tried the program I want but I can’t connect to the USB port that I need to control the Arduino mother board.
So I shut down again but now it says there are 88 up dates before closing down.
I feel my life slipping away here with nothing to show for it so I am going to step back for a while.
I can run the programme without a problem on my grandsons Win 10 computer so I will leave it at that I think. The only problem with that machine (Acer Aspire 5732Z) is that one USB port is damaged and unusable so the other USB port is used for the Arduino software stuff and I have to use the touchpad (something I hate but will need to get used to). The programme is running a cheap chinese Laser Engraver and it works very well for coasters etc.
Having had some success with this I was going to invest in a 3d printer to model interesting things.
I will need to research what the is required by the way of software to use it and if it aint Linux its OUT.

I am back after having my tea and feel a bit better, I am going up country to Glen Doll and Glen Clova in Angus for a week starting next Monday 2nd and hope to come back with a fresh mind on what I want/need.
Thanks again for your help and I will probably mark this as solved.
Don W
PS The updates are now at 82 of 88. ::slight_smile: sheesh

Great news Don, and as always you’re welcome :slight_smile:

Hi Mark,
I have returned, refreshed, and with a different frame of mind. A week without telephone contact and only having to make the choice between sauna then hot tub or hot tub then sauna has stirred me up. The snow, at worst, was only a couple of inches and I am now ready for the tidy up job I have in mind.

I have 2 laptops and a tablet and I would like to return them all to single use machines, ie I want a single OS on each machine.
The Samsung tablet with Win 7 I have just cleaned, defragged and it is now ready for use. I can install Blender on this machine and save the files to a mini SD Card that can be used in the 3d Printer. Using this tablet with a 17"monitor I can see good detail and this will solve one problem.

The other laptop is an Acer Aspire and has Win 10 and Pep 8 on in a dual boot, I will start another thread when I want to tidy this up if that is all right ??

The last machine is this one and I want this back to Pep 7 without the virtual box and a lot of software files that I won’t be using on this computer.
If I use this will it get rid of Virtual box ?

sudo apt-get remove --purge virtualbox-dkms

When I have cleaned up this machine I will mark it Solved and start another thread about deleting Pep 8 on the Win 10 machine if that is ok ??

take care
Don W

Dunno, what’s the output from:

dpkg -l | grep virtualbox

?

Hi Mark,
I get this
don@ldwatson ~ $ dpkg -l | grep virtualbox
rc virtualbox 5.1.34-dfsg-0ubuntu1.16.04.2 amd64 x86 virtualization solution - base binaries
ii virtualbox-5.2 5.2.8-121009~Ubuntu~xenial amd64 Oracle VM VirtualBox
rc virtualbox-qt 5.1.34-dfsg-0ubuntu1.16.04.2 amd64 x86 virtualization solution - Qt based user interface
don@ldwatson ~ $
Thanks again
Don W

To remove everything:

sudo apt-get remove --purge virtualbox virtualbox-5.2 virtualbox-qt

Thanks Mark,
Carried out those commands and all is well.

Don W