Trying to install Puppy Linux

I’m trying to install puppylinux 5.7 on an old PC (2005)
I followed the instructions after installing puppy on a USB stick and booting from that, I ran gparted and partitioned it how I wanted.
I noticed I could not give it mount points such as ‘/’ and ‘/home’ - There was no choice…
I rebooted with an ubuntu live cd to see if a different gparted gave me the option as I have been given the option to select mount points while formatting at other times (but can’t remember which utility I used), but I still didn’t get the option.

In the end, I gave up so I formatted the whole Hd as one partition with a little swap at the end.
I then tried again with puppy and installed. I then rebooted and… Nothing…

It booted to Grub Rescue
…I guess it was because no grub was written to the Hd on install of puppy!
I even tried to repair it with ‘Boot Repair Utility’ and that didn’t get me anywhere.

How can I successfully install puppy?

I have tried installing Ubuntu/Kubuntu and Lubuntu (all 32bit versions as I didn’t realise it was a 64bit CPU). On trying to install U & L the screen display is all messy where it garbles the screen with strips of messy graphics. But after installing K, with no problem with screen display, all of the attempts to install the 3 'buntu’s, the PC virtually grinds to a halt.

Spec on the PC;
CPU
AMD Sempron 2800+
64bit Opteron
1600Mhz

GFX
nVidia GeForce 6100
Gallium 0.4 on NVE4

80Gb Hd

CD/DVD Drive
Floppy Drive

I have installed Puppy in a VM before, but it’s not recommended procedure as it’s designed as a live distro with persistancy. This means that it won’t do a regular install, it’ll copy the live USB onto the hard drive, then create a persistance file to save modifications. On boot, it’ll run through the same procedure that the live USB does, probing all the components and exploding the compressed image into RAM - in short, it’s not efficient and will be almost as slow as running it from a USB stick.

Although Puppy is very lightweight, 2005 surprisingly isn’t that long ago in terms of Linux, you shouldn’t have a problem running Peppermint on that machine. You haven’t posted how much RAM you have - if it’s less than 2Gb (likely), I’d stick with a 32 bit OS.

Sorry, I thought I had, it’s a strange 715Gb.
Funnily enough, I’ve downloaded ALL the Peppermint versions from 1 up to 5, both 32 & 64bit as I was going to try it.

715 “gigabytes” of RAM :o

If we’re talking megabytes (and I’m assuming we are) … Try Peppermint 3 (only 3 and 5 are still receiving updates, and 3 is the lighter of the two).

That graphics card will be out of propriatory support, so you’ll have to use the nouveau drivers (not a problem, I’m not sure what they’re like on P3 vs P5)

Mark - does P3 have backports for that kind of stuff?

It would seem so:

but I’m “assuming” here … I haven’t a 12.04/PM3 install in front of me

Cool, it was more a question of whether backports were enabled by default on P3, but it’s good to know that the version is the same between current (Trusty) and the Precise backports :slight_smile:

Ahh I see … can’t say for sure if the “updates” repo is enable by default … can’t remember for sure, but if I had to guess I think “updates” is, but “Proposed” isn’t … and it’s the same version in both.

So I’d guess that package will be availabe out of the box … but it is a guess.

Still easy nuff to enable/install it if it isn’t :wink:

[EDIT]

In fact according to this:
https://help.ubuntu.com/community/UbuntuBackports#Using_Backports
there’s no need to manually enable backports since 11.10 … which is enabled by default.
(I seriously doubt if Peppermint would have changed that)

shrug
Mint do now (at least, I’m pretty sure they do - they are quite conservative with things like this and the kernel updates)

AFAIK (and I’m 99.9% sure this is the case) Peppermint stick with Ubuntu defaults … then just add the Peppermint repo which has priority over the default Ubuntu repos.

As that package isn’t in the peppermint repo … it’s going to do whatever Ubuntu does.

[EDIT]

I’ve never understood Mints policy on updates … sticking with the Ubuntu defaults makes much more sense to me … kernel updates may fix issues you’re having but can’t break anything (just boot the previous kernel) ???

It’s also “possible” that an update that Mint do allow but requires an updated package they do not allow will sneak through and break something … the very situation they’re trying to avoid.

shrug again
The main reason I went back to Ubuntu/Mint was the “just works” aspect of updating. Click update, and full trust it works.
If I cared enought to worry about updates, I’d still be running Arch (I used Arch as a pseudo-Gentoo though, long story for another day maybe…) :slight_smile: