Tumblerd preventing dismount in Truecrypt [solved]

This is weird. I’ve just been accessing an encrypted drive, and now I want to unmount it.

However, Truecrypt says “the target is busy”. If I try to unmount it in the File Manager I get “Volume is busy” and apparently /usr/lib/x86_64-linux-gnu/tumblr-1/tumblerd is the culprit.

The thing is, I wasn’t using Tumblr. In fact I never do.

Truecrypt isn’t offering to force a dismount, although the file manager does, but I’m worried about losing access to the encrypted drive, so I don’t want to risk that.

Any suggestions gratefully received.


OK. I got fed up and shut down the PC.

On restart I was able to access the encrypted drive…

Marking this solved now.

I have a VeraCrypt encrypted container on my Windows C-drive. I only boot to Linux now, but am still able to open the encrypted container. Sometimes all the folders and files in that container get locked when I do something, though I have not been able to establish what. I used to shut down then boot up again.

So I right-click on the container and click unmount, then click on another directory (e.g. Documents, and when once again I click on that encrypted volume all locks are gone as if by magic. In other words, the container did not really unmount. It might be worth your while trying this because it avoids have to close down and boot up.