Tutorial - Installing PeppermintOS Two on an Acer Aspire One AOA110L ZG5

Hi Mark, I thought you’d like to know that my problem turned out to be the stick. Goodness knows why, as it works in all other respects.
Thanks for your assistance and best wishes for the New Year.
Rgds, Joe

Thanks for the update, have you now got PeppermintOS installed ? … if so, what do you think of it so far ?

Hi Mark

tried to re-install peppermint two from my stick, but came to a problem
pressed f12
the options that came up were :- persistent mode
live mode
install
file integrity check
memory test

i tried the top3 all came up with the peppermint screen with the install peppermint logo
when i clicked on logo it came up with 3 options :- install peppermint alongside peppermint two
replace peppermint two with peppermint
something else (which was about partitioning etc)

nothing about just installing peppermint two or re-installing
any help on how to proceed would be appreciated
thanks

keith

Are you sure your LiveUSB is using PeppermintOS (Two) ? and not PeppermintOS (One) ?

If you ARE sure it’s PeppermintOS (Two) … If you want to clear the SSD (or hard drive), and start again … try the install > replace peppermint two with peppermint options.

Just as a matter of interest , Why do you want/need to reinstall ?

confirming the live usb stick is the same one i used for installing peppermint two on my aa1.
after being on linpus lite i think i went a bit demob happy, trying so many things and while i havn’t broken the system a couple of things dont seem right, so i thought a fresh install and now i know what i’m doing i can get the system that i want

Ahh … Okey Dokey :slight_smile:

If the above option doesn’t work, you could always boot to the LiveUSB and use gparted to delete all the partitions on the SSD … then reboot to the LiveUSB again and install Peppermint.

Effectively this will leave you with a blank SSD without any partitions … so the Peppermint installer will ONLY offer to install peppermint, then create the partitions for you.

But try install > replace peppermint two with peppermint first.


Though it may be just as easy to “fix” your issues (if you say what they are) as reinstall … but your call :wink:

done
did as you suggested and it installed peppermint two
it confused me because at no time had i had peppermint on the stick only peppermint two.
easy peasy (thanks to you)
i’ll go and do the rest of the install.

have a good night and a happy new year

thanks

keith

hi mark
after having some issues with my aspire one it seems to have given up on me and leaves me a media test cable fail message followed by the pxe rom one the same as on caths.
i tried if in error to create a pendrive of peppermint to boot from usb but all i am getting is
SYSLINUX 4.05 EDD 2011-12-09 Copyright 94-2011 peter anvin et al
any ideas where i have gone wrong or where to go from here.

Which LiveUSB creator application are you using ?

Did you see the EDIT section in the first posting -

[b][EDIT][/b]

I’ve been told that some people are having problems using the new version (1.8.7.3) of Universal USB Installer to write the PeppermintOS ISO image to their USB sticks … so here are links to some other versions/applications that should work in Windows.

Universal USB Installer 1.8.6.9 (from my dropbox)
http://dl.dropbox.com/u/11876059/Universal-USB-Installer-1.8.6.9.exe

Linux Live USB Creator (worked for banko <thanks banko :)> and also provides persistence)

[s]Unetbootin (doesn’t provide persistence, but can still be used for installation, and non-persistent test driving)
http://unetbootin.sourceforge.net/[/s]

[END EDIT]

Ignore the last one that I’ve struck through … it won’t have persistence which you’ll need if you are going to run it permanently from USB stick.

Your other option would be to buy a new SSD and install it … there is a thread about doing that somewhere on this forum.

hi mark i have tried both options now and have failed it just says syslinux 4.04 now
thanks for ya help by the way keep up the good work on this ste it makes interesting reading if not totally understanding it all.
think i may have a go at the ssd depending on the price i can get one for.
by the way peppermint would start up on my windows machine in virtual box off the usb could i have still done something wrong for it not too load on my acer

What happens if when you get to the “SYSLINUX” message you hit the tab key ?

If you come back tomorrow, I’ll see if I can create a LiveUSB stick in Windows that does the same thing, and work out a fix.

I actually created my LiveUSB in Ubuntu’s “Startup Disk Creator” and it worked flawlessly.

But other people seem to be having similar problems when using Windows to crreate the LiveUSB, both on this forum and other places, such as:

I’ll work out what the differences are and hopefully I’ll be able to come up with a fix.

thank you your time and effort on here is much appreciated.

First … this isn’t a Sandisk U3 USB stick is it ?

Can you answer my previous question … What happens if you hit the TAB key when you see the “SYSLINUX 4.05” message ?

[EDIT]

Can you try something for me … When you get to the “SYSLINUX 4.05” screen, type:
help
and hit enter … when the help is displayed … hit enter again … does it boot ?

[EDIT 2]

You could try formatting the USB stick in Windows, and make sure it’s formatted as FAT or FAT32 … then try again.

[EDIT 3]

Weird … I can’t seem to make a LiveUSB that DOESN’T work … when your LiveUSB gets to the -
SYSLINUX 4.05 EDD 2011-12-09 Copyright 94-2011 peter anvin et al
line, is anything else displayed, such as
Boot:
and does this line repeat itself after a few seconds ?

does hitting the Tab key display anything ?

Some people have suggested that formatting the stick in Windows as FAT(16) helps … try a FULL format, ie. when formatting in Windows, take the tick out of the “Quick Format” box.

You wouldn’t happen to have a PC running Ubuntu would you ? … as every page I’ve read that discusses this issue says creating the LiveUSB in Ubuntu works every time ???

Have you tried a different USB stick ?

Just as a matter of interest … what happens if you browse onto the USB stick, then enter the syslinux directory, and rename the syslinux.cfg file to syslinux.cfg-old … then rename the isolinux.cfg file to syslinux.cfg … then try the LiveUSB in the AA1 ?
(this and one extra file seems to be the only difference between a Peppermint LiveUSB created in Windows and one created in Ubuntu)
if you want to try the extra file that gets installed by Ubuntu … let me know and I’ll upload it to my dropbox, but I don’t think it’s necessary.

BTW, if any of these work, can you post which one worked … so others can benefit


I’m beginning to wonder if this has anything to do with the BIOS update I installed on my AA1 prior to attempting anything from a LiveUSB … that said, most people having this issue seem to be able to boot a LiveUSB after experimenting with other USB sticks and/or LiveUSB creators.

hi mark when the page comes up how long should i wait for something to happen. i have tried hitting tab nothing happens nor does it repeat the line. also it does not allow me to type anything on that page the usb i was using was a maxell and a kingston. its probably me too be honest i have trie the virtual box load but it stops and gives me an error message.

Hello Marc,

Brilliant tutorial. I just have one issue you might be able to help me with.
For some reason the wifi on my aspire one is not activating.
Is their a driver I can install, I’ve tried updating software but to no avail.

Any pointers would be appreciated

Pit

Hi,

The following worked on my Acer Aspire One A110:
sudo gedit /etc/modprobe.d/blacklist.conf
add the following line:
blacklist acer_wmi
save and power off (not reboot)

This might not work on Peppermint but it worked with Crunchbang (openbox)

Sorry, i get the answer command not found :frowning:

Hello,

I went on another site and did the following:
sudo NetworkManager

find out the pid, then

sudo kill (pid)
sudo NetworkManager

For some reason it works now :slight_smile:

If anybody knows i’m interested
<Pit

Hi Mark,

I have switched the OS on my AAO150 from Linpus Lite to Peppermint Two recently, following your guide. Everything has worked perfectly and I want to thank you for the time and effort you have put into this. Much appreciated. I would probably not have endeavoured on this without your help.

The only minor issue I can see is a “Mountall: can’t connect to plymouth” message during bootup, however there appear to be no related problems once logged in.

Btw. do you have an idea where Firefox is installed on this OS? Could not find anything at /opt/firefox.

Hi,

firefox is in mozilla folder, remember to tick show hidden files in the view option of file manager.