Ububtu Studio 10.04 won't finish booting

Hello, I’m a newbie.

I have a problem with Ubuntu Studio 10.04 not booting.

hdd 0 = 200gb - Windows xp installed and working
hdd 1 = 200gb - Ubuntu Studio 10.04 (not booting)

Ubuntu Studio 10.04 worked perfectly before trying to install Konqueror.

During the installation I got a “No Disk Space” error and froze up.

It will boot up as far as the initial splash screen - then it freezes.

There are 2 other kernels available and they both freeze up as well, on boot.

I booted to the Live CD and it looks like the volume label that Ubuntu
is installed on got renamed.

All other devices have normal names except that drive, which is named
“e>^m^j” (no quotes)

Ctrl+Alt+Del - reboots
Esc - Does nothing
Ctrl+D - Does Nothing

Any ideas?

Thanks in advance.

Sounds like the file system has become corrupted somehow… try booting from a LiveCD, then open a terminal and enter:

sudo fdisk -l

In the output, look for the Linux drive (Device) marked as sda or sdb etc.
(if you are right about it being hdd 1 (second hard drive), then the Linux drive will probably be sdb, but check anyway)

Reboot from the LiveCD again… just to make sure no partitions are mounted.

Open a terminal and enter:

sudo fsck [b]/dev/sdX[/b]
(and hit enter)

Obvoiusly you need to change the /dev/sdX to whatever got listed as the Linux drive in the first command.
(/dev/sda or /dev/sdb)

BE AWARE - If you get a WARNING that the partition is mounted, DO NOT run fsck… exit, reboot to the LiveCD and try again.

And what in the heck made you want to load Konqueror (a KDE file manager/browser) in Ubuntu ?

Thanks for getting to me so fast.

I did what you said, but didn’t apply any changes yet, here’s what iI have so far-

First I did this-
ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/sda1: LABEL=“New Volume” UUID=“34F8C7A7F8C76628” TYPE=“ntfs”
/dev/sdb1: LABEL=“e>^M^J” UUID=“2A6C-08F3” TYPE=“vfat”
ubuntu@ubuntu:~$ sudo fsck /dev/sdb1
fsck from util-linux-ng 2.17.2
dosfsck 3.0.7, 24 Dec 2009, FAT32, LFN
There are differences between boot sector and its backup

Then I ran $ sudo fsck /dev/sdb1 and got the following results-

  1. Copy original to backup
  2. Copy backup to original
  3. No action
    ? 2 (I selected this)
    /Recycled
    Duplicate directory entry.
    First Size 0 bytes, date 20:32:10 Nov 05 2010
    Second Size 0 bytes, date 15:12:38 Apr 21 2009
  4. Drop first
  5. Drop second
  6. Rename first
  7. Rename second
  8. Auto-rename first
  9. Auto-rename second
    ? (No Selection here, I wasn’t sure)

Am I heading in the right direction?

Thanks again

Erm, how did you install Ubuntu… from within windows (ie. using the WUBI installer) ?

Yes, I used the wubi installer initially. Then I burned a disk later.

Strictly a newbie here, and not at all that good.

The second hard drive that Ubuntu is installed onto has an old
windows xp installation on it that went corrupt.

I am just using the second hd for data storage and am in the process of cleaning it up.

I deciced to try linux on that drive.

Ubuntu installed with wubi and worked immediatly, I liked it and was actually using it more
than my windows system.

That explains why the second HDD is formatted as vfat.

Can you boot to windows ?

if so, can you boot to windows, and then see if there is a C:\Ubuntu folder, and let me know.

It seems that the second hard drive is formatted as a windows partition… if you installed using WUBI, there will be NO Linux partitions, WUBI installs Ubuntu to a folder on the Windows drive… so running fsck isn’t going to work, and would probably be a bad idea.

Either tell Windows to run a disk check, or let me know where the Ubuntu folder is in windows.

There is no C:\Ubuntu

BUT

There is a F:\Ubuntu folder (the second hdd)

Thanks again for your help, much appreciated !

is the F:\ drive full ?

No, the F:\ drive is not full, it has about 27gb free space

First, have you run a Windows disk check on drive F: ??? … run a surface test on it too, to check for bad sectors… then run a defrag on it.

after doing that (and if no bad sectors are found)…

Can you boot to the Ubuntu LiveCD, select “Try Ubuntu”, and when you’re at the desktop, go to Applications>Accessories>Terminal

in the terminal enter:

sudo fdisk -l

(thats SUDO FDISK -L in lower case… it MUST be in lower case)
hit enter, and enter your password.

and post back the results (all of it)

Update

DONE…Cleaned up old files - (39gb Free Space)
DONE…Windows disk check on drive F - (no errors)

5 hrs left…Defrag

When defrag is done, I’ll post results of fdisk -l (Glad you told me that was a small L, I’ve been using a (one) 1)

Thanks

Thanks for your patience, here are the results of fdisk -l after a cleaning, windows chkdsk, and defrag

To run a command as administrator (user “root”), use “sudo ”.
See “man sudo_root” for details.

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x13928d6c

Device Boot Start End Blocks Id System
/dev/sda1 * 1 24321 195358401 7 HPFS/NTFS

Disk /dev/sdb: 203.9 GB, 203928109056 bytes
255 heads, 63 sectors/track, 24792 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000000d0

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 24792 199141708+ c W95 FAT32 (LBA)
ubuntu@ubuntu:~$

OK… if it still isn’t working, I’m afraid it’s gone, and you’ll need to delete and reinstall it.

If it had been loaded properly (ie. not through WUBI) it would have been fixable from a LiveCD, but WUBI installs Ubuntu as a virtual disk on a Windows file system, which AFAIK isn’t readable from a LiveCD, so there is no way of fixing its file system.

I CAN tell you how to remove Ubuntu if you want ?

Then you can start again.