Ubuntu 10.10 netbook on usb.


I have just installed Ubuntu 10.10 netbook on to my USB. I have put 2gb of persistence on the 4gb stick. Everything is fine other than using a password. It says that ‘ubuntu’ is the password by default but when I put this in it says it’s incorrect. If I use a blank then it works, I put my password in, then it crashes and asks to send a report. Any ideas?



Ubuntu LiveCD’s or LiveUSB’s have the following user account set by default:

Username: ubuntu

It shouldn’t normally ask for a password though, and certainly won’t have a user account in your name.

I don’t suppose there would be anything stopping you from creating another account, and making it an administrator… then deleting the “ubuntu” account, or just changing it’s password for security purposes.

Bit stumped by the “crashing” part though… I would have expected it to just say “wrong password”.

I have actually put 10.04 on usb. The only problem is installing a password. If I put a password on (startup), when I reboot it wont accept it and I have to reinstall. Any suggestions?

4gb with 2gb persistence.

I’ve never tried this on a LiveUSB… but can see no reason why this wouldn’t work.

a) Create another User account

b) Make them an administrator

c) Test the account can log on and use it’s password for sudo

d) Log on to the new account, and delete the original “ubuntu” account.

est the account can log on and use it's password for sudo

Sorry, how do I test it?

Even though I have created a new Administrator account it does not boot up with password, just straight into Ubuntu. The password I have created with the new account is not recognized when I switch users.

…and here is another problem. When I boot from My Toshiba Equium I get a proper Uk Keyboard but when I boot from My Samsung NC10 net book I get something different. When I press an ‘L’ I get a’3’. I have to use the ‘Func’ key to input properly.

Read next post first.

You could try this… got to System>Preferences>Keyboard, when the “Keyboard preferences” opens, select the “Layouts” tab, Have a look at what is listed as the Keyboard layout: (probably Evdev-managed keyboard) make a note of this, click that button… in the top panel, select “generic”, in the bottom panel select “Generic 105-key (intl) PC”, click “OK”, click “Apply System-Wide…”, click “Close”.

now test the keyboard on both systems. (might require a reboot)

Also whilst there, check the layout is set to United Kingdom.

After scouring the interweb, it seems that all you have to do to fix the issue, is to turn off the num-lock :slight_smile:

Ahhh! Many thanks. :slight_smile:

If it always starts with num lock ON, you might want to check this isn’t enabled:

Or see if there is a BIOS setting to startup without num lock ON.

OK will do.