Ubuntu 10.10 ...

Beta is now available … anyone tried it yet?

I 'm going to give it a whirl tonight on the dual-core AMD Turion based laptop, as the 10.04 load average is off the scale… to the extent that flash video is very sluggish… I want too see if it’s improved in Maverick’s 2.6.35 kernel, if not I’m going to go back to 9.10 or Mint 8.

I’ll let you know tomorrow how I get on :slight_smile:

Apparently the problem is fixed in 2.6.35, with a couple of patches … not sure if the Maverick’s kernel has the patches, but will be interested to hear … :slight_smile:

OK, well as far as the fglrx drivers are concerned Maverick beta flatly refuses to load them.

dpkg stated:
was missing, so version was being stated as " ", and not 2.6.35-19-generic

So I created a
file, and included the line:
#define UTS_RELEASE “2.6.35-19-generic”

Still didn’t build/install, dpkg now said it was installed but it couldn’t be configured… the make.log states:

DKMS make.log for fglrx-8.723.1 for kernel 2.6.35-19-generic (x86_64) Sun Sep 5 01:57:18 BST 2010 AMD kernel module generator version 2.1 doing Makefile based build for kernel 2.6.x and higher rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers make -C /lib/modules/2.6.35-19-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.723.1/build/2.6.x modules make[1]: Entering directory `/usr/src/linux-headers-2.6.35-19-generic' CC [M] /var/lib/dkms/fglrx/8.723.1/build/2.6.x/firegl_public.o /var/lib/dkms/fglrx/8.723.1/build/2.6.x/firegl_public.c:31: fatal error: linux/autoconf.h: No such file or directory compilation terminated. make[2]: *** [/var/lib/dkms/fglrx/8.723.1/build/2.6.x/firegl_public.o] Error 1 make[1]: *** [_module_/var/lib/dkms/fglrx/8.723.1/build/2.6.x] Error 2 make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-19-generic' make: *** [kmod_build] Error 2 build failed with return value 2

rebooted…screwed graphics… booted recovery mode and removed fglrx, and it booted fine.

I have no doubt I could have fixed autoconf.h etc., but I thought I’d check the load average first… the whole point of the exercise -
(taken after 15mins at idle)
[smg id=792 type=“preview”]

So I figured… NO MAJOR IMPROVEMENT OVER LUCID… I’ve been wanting to try Peppermint ICE, so I’ve given up and I’m going to give that a go… just too much messing about to troubleshoot fglrx/fglrx-amdcccle and find/apply the kernel patches to correct the load average, just on the off-chance that it would improve the graphics performance, which was still way to slow when running flash video.

BTW, just after taking the screenshot of top, the load average rose to 1.42 and pretty much stayed there… still at idle.
(yes I gave it time to recover from taking the screenshot)

Here’s a piece of info for you… Peppermint ICE, based on Mint 9 (Unbuntu 10.04) LXDE desktop, kernel 2.6.32-23-generic, left at idle for 3 mins load average = 0.04 (running from a LiveCD)
Flash wasn’t improved much though :frowning:
I’m beginning to think it’s something to do with CPU throttling on the (mobile) AMD Turion X2, because the Pentium dual-core box is a LOT faster at flash video, and that’s with an older less powerful graphics chip and less RAM.

[2nd EDIT]
Yup, that’s what it was… the CPU was being throttled to 500mhz per core… I’ve added the CPU frequency scaling applet, and I can now select the full 2ghz on a per core basis if and when I need to :slight_smile:

Mmm, I guess that’s a “no”, it’s still broken … :frowning:

Just to put it into context, with 10.04 my load average is 1+ when doing nothing … this is what my machine look like atm on 9.10;

[smg type=full caption=“Automatic frequency scaling, 4x800Mhz” id=812]

[smg type=preview caption=“Load average of 0.01, 4 screens, lots of apps open” id=802]

[smg type=preview caption=“ONE of the 4 screens, each gkrell is doing 4 updates per second” id=822]

This isn’t a particularly ‘special’ machine, and it’s the load average I see on all my 9.10 machines … just as a bit of context, here’s a shot from “php-1” which is a Xeon machine, relatively slow compared to my workstation, but running about 30 websites with 90 fast-cgi instances.

[smg type=preview caption=“PHP1 Load Average” id=832]

If you don’t think it’s doing much, check out the results of ‘ifconfig’;

eth0 Link encap:Ethernet HWaddr 00:16:c5:5d:c1:bb inet6 addr: fe80::215:c5ff:fe5d:c1ba/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1043807369 errors:0 dropped:0 overruns:0 frame:0 TX packets:548454288 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1082050499635 (1.0 TB) TX bytes:155578059076 (155.5 GB)

Incidentally, the Gkrellm’s screenshot is mapping lots of machines, only ONE is running 10.04. The machine is relatively idle, can you spot it?

Yup, looks like not only is Lucid going to stay on the front page for some time yet, but you may have to make room for Maverick too.

Any ideas how to turn automatic frequency scaling off… so it boots in “Performance” mode, but still gives me the option to choose “OnDemand” etc.?

I may have found the answer to my booting in “Performance” mode problem, but the Mrs is up now so I can’t test it till tonight (She’ll be on Facebook till then :wink: )… I’ll post back when I’m sure it works.

Also, any thoughts on why 2.6.32-23 running LXDE (Peppermint ICE) wasn’t loaded anywhere near as much?.. maybe not the kernel after all?

I tend to just use this script;

#!/bin/bash if [ $1 ] ; then for i in 0 1 2 3 do echo $1 > /sys/devices/system/cpu/cpu$i/cpufreq/scaling_governor done fi cat /proc/cpuinfo|grep MHz

And call it “performance” and stick it in /usr/local/bin.
Then insert the following into /etc/rc.local

performance performance

There’s probably a better method, and you’ll need to adjust it for your # cores, but it works for me …


Thanks for that… if the other method doesn’t work, I’ll adjust/use that :slight_smile:

I had read that you could edit some setting in gconf, but this turned out to be wrong… but I have found an easy way to boot in “Performance” mode, and still be able to select whatever CPU frequency mode I want from the “CPU Frequency Scaling Monitor” GNOME panel applet.

First backup /etc/init.d/ondemand

sudo cp /etc/init.d/ondemand /etc/init.d/ondemand.bak

Then edit /etc/init.d/ondemand

sudo gedit /etc/init.d/ondemand

and change the line:
echo -n ondemand > $CPUFREQ
echo -n performance > $CPUFREQ

Save and reboot… It should now boot in “Performance” mode, but all the other modes still work.

You can test all the modes still work by selecting them one at a time, then in a terminal:

cat /proc/cpuinfo

and see what
CPU Mhz :
states your CPU frequency is for all your cores :wink:

this only works if you have the CPU Frequency Scaling Monitor GNOME panel applet loaded.

Ok, I now have 10.10 running on an older single-core x86 box, generally very nice and the kernel load average issue is nowhere near as pronounced … but I think it’s still there. From what I read it is more of a problem on multi-core CPU’s which is probably why it’s sort of been escaping ‘unnoticed’ to an extent …

10.10 installer is getting pretty slick … one day they’ll include LVM/DM in the desktop install without messing around … some people do actually want to run software RAID on their workstations as well as their servers … :wink:

Looked pretty pronounced to me (maybe not quite as bad), but maybe the fact that the CPU was being throttled was playing a large part… I’ll take another look and get back to you.

Not sure I like the way the Ubuntu Software Centre now handles .deb files rather than gdebi, but I’ll give it a chance… I suppose as long as it works properly it makes sense (although I wouldn’t have the first clue as to how to use it from the command line now)… problem was it didn’t want to install Chrome at first, but did eventually… after installing gdebi, then uninstalling it again because it didn’t work, then re-associating .deb files with the Software Center, but I’ll give it the benefit of the doubt, still a beta after all.

Mmm, Chrome is available via the software centre … I just typed “chrome” into the search box, the clicked on the install button … :slight_smile:

Heh… maybe that’s what confused it… maybe I had a later version, but if that’s the case it’s still a problem that wouldn’t have arisen if gdebi handled .deb files.