Ubuntu 11 not working

Just got my broadband installed. Updated my 10.10 then when it went to restart my computer it froze. Then I tried to restart it now it just goes to the purple Ubuntu screen and no further. I went to my boot screen to try load that way but I don’t know my login name. Any help?

i managed toload an older version of ubuntu off my f8 boot screen, currently downloading ubuntu 11.10 see if i can install it and hope it works this time :S

Was your username “myuser” as this posting seems to suggest:

Otherwise you’ll have to log on in “single user” or “recovery mode” … drop to a root shell … then search /home to get an idea of your username.

or use a LiveCD to do the same.

I know what this problem is.

When you upgrade from a Ubuntu to another, during the installation process, the installation makes you a user without a password, to stop you having to type anything in and let it run smoothly, etc, so you can be lazy and sit back.

What happens though is, if you need to log into a root shell that user is still there, and because you don’t know both the username and password, it thinks that the username and password you created are wrong.

I think the only way to fix this was by loading the LiveCD and doing some commands which I can’t remember what they are.

I’m not sure what’s going on now. I managed to boot it up and burn a CD but resetting with the CD inside does nothing. Still stuck. On this purple screen. Any ideas I don’t mind starting again but I don’t know how to format a hard drive.

Are you booting to the CD? Depending on your machine you will either have to go into the BIOS (F2 or DEL most of the time) and change the Boot order or you might have a one time boot from menu (F8 or F11 - again it depends on your particular machine).

Yea I figured that bit out. F8 boot from CD but still froze. I managed to find my username and password but now I’m stuck on a terminal screen and not sure what to do. I did go to something that said fix broken packages. Then after I went to boot normally. Now on the terminal screen is up.

I reset but nothings changed. Only loads up to a purple screen then nothing.

You said you entered the username and password before it brought up the terminal screen. Is it a graphical user login?

It could be that the DE isn’t being loaded automatically on startup.

I’m confused with the purple screen though, is that the only thing you see when you boot up or do you see Ubuntu loading and then the purple screen?

Just the screen. No loading. Loading comes up when I turn it off by the power button. Strange. Even load up CD is purple but it does have two white icons at the bottom. I can get it to boot up in a older version of Ubuntu but I dunno what to do after that? Should I try update it again?

The CD I burnt has errors on it. Just left it in for 10 mins.

I have loaded a older version and updating it to 11.10 see how this goes. Let you know in a couple hours. Thanks for the help so far. X

Covering all possible options, it could be that the ISO you burnt to the CD is corrupt. It might be worth downloading a new one.

Wait to see what happens with what you’re doing first though.

Thanks for the help so far. X

Erm…cheers for the kiss! :-\ Or is that your ‘mark’…? :smiley:

a kiss no idea why I did that. Spreading some love. More then likely cos I’m typing this on my phone bad habit lol.

I’ll let you off with that one. I know how easy it is, and then you realise just as you press send to your best mate!! NNOOooo! The laughter can be heard for miles.

Do you know how to (temporarily) remove “quiet splash” from the kernel boot line is GRUB ? … that may give us a clue to what’s happening when it locks up.

is it just the hard drive installation that locks up, or the LiveCD too ?

Do you know what graphics card you have ?

Do you have a LiveCD of the earlier version that WILL boot ?


Erm...cheers for the kiss! :-\ Or is that your 'mark'..? :D

Heh … I wouldn’t do something like that … honest, promise :wink:

@ Fulla

I had a similar experience couple of yrs back with Ubuntu when the upgrade did not finish completely
(various config files did not get rewritten to suit the new DE)
Solved it by (with Live CD) re-naming my user folder in /home
then on re-boot and after successful log in, the user folder was re-created automatically.

All I had to do after that is to copy the rest of the ‘important’ content
back from the re-named user folder.

This might not work on today’s incarnation of Ubuntu but it might be worth to try.

Something tells me … if he’s not getting as far as the login screen … that’s it’s not user config files, as those should only be loaded after choosing a user :wink:

Or are you getting that far ?

Call it a hunch, but I have a feeling it’s graphics driver related.

I managed to find my username and password but now I'm stuck on a terminal screen and not sure what to do

That would suggest that he managed to log in and then was dropped back to the terminal

I agree, it is more than likely graphics related.
The question is how deep the problem is, system wide or confined to just the user

That’s what I picked up on, but again is it a graphical or a terminal login? As that might hint at wether the DE is being started.

@Fulla is GRUB even showing at startup or is it just the PSOD (Purple Screen Of Death)?

My understanding was that he’d dropped to a shell because he couldn’t get to a GUI login screen … but as it’s slightly ambiguous, maybe a bit of clarification is in order :slight_smile: … over to you Fulla :slight_smile:

Just realizing here, I had this problem back last year. I remember me and Mark fixed it, only I can’t remember what I named the thread.

I know that we disabled the “quite_splash” to see what was happening, and then after that we ran:

 fdisk -l

(I think, it was an fdisk command though!)

Then we did something else that I can’t remember… :confused:

This might be totally unrelated but recently I tried to upgrade from Mint Julia (on my daughters laptop) to Katya (full install).
Booting from the Live CD ended up in a coloured blank screen.
Tried several different(newer) distros with the same result. But distros from the same era worked well.
Given up then as she was going back to uni.
Later on I found that this change was due to do with the on-board Intel GMA (cannot remember the exact model) and how it is handled now.
If Fulla has this graphics on his machine then this might explain the source of the problem and the reason 10.10 works but not the newer version.