Ubuntu booting into teletype mode

I have recently upgraded several machines (not all mine!) to V12.04 and have encountered a number of problems; some minor, some not so. To take them one at a time, here’s the first one:
Laptop Dell Latitude D505. At first it occasionally booted into “tty” mode at which I new not how to proceed so exited using “sudo shutdown -P now” and rebooted. This worked fine for a bit but today it happened twice in a row. One piece of evidence might be that soon after a successful boot a message is displayed informing me that an internal error has occurred. I can post some screen-shots of the details if relevant.
As I need to give the laptop to a friend in need, it’s a problem that ought to be resolved. Any ideas?

Yup, the error would be handy.

When you end up in the console … what happens if you login and run:

startx

or

sudo service lightdm start

I just tried rebooting to try your suggestions but, of course: it booted normally! ::slight_smile:
I shall try again during the day (when it’s too hot to continue my DIY) and report when I have all the info.
'Bye for now.

Well, the laptop booted up normally this morning but did show the usual “internal Error” message.
As I was unable to cut & paste the text I have had to take eight screen-shots which look almost intelligible.
The allowed, four screen-shots per post are appended here, with the last four in a separate post.

and here are the last four…

Hi Keith

There’s a bug report about this problem here Bug #1094218 “lsb_release crashed with IOError in getstatusoutpu...” : Bugs : lsb package : Ubuntu

I don’t fully understand these things but it looks to me like it might have something to do with Team Viewer

Do you have Team Viewer installed ?

Hi Emegra.
Yes, I do indeed have Teamviewer 8 installed, and it’s not the only problem I believe it has caused!
I was performing remote assistance recently when the remote PC became gradually unresponsive - even to the remote user. When she rebooted, applications could be started but were not controllable; for example menus could not be opened. The PC is useless and is coming to me tomorrow to see what I can do - probably a complete re-install.
If others have experience of using Teamviewer in Ubuntu, I would be interested to hear their views.

The error report itself is not causing problems so I can live with it until I find an alternative to Teamviewer.
My thanks to you & Mark.

I’ve used Team Viewer quite a bit and i find it rock solid, but it appears to causing problems in your case, How can you tell it’s not related to your boot problem

It possibly has nothing to do with it but if it were me I’d be inclined to uninstall Team Viewer temporarily to see if it solves the boot problem, it’s not difficult to re-install and set up again

Reading Emegra’s linked bug report suggests it’s a problem with lsb_release, not teamviewer.

What’s the output from:

dpkg -l | grep lsb

Emegra: I’ve always had minor problems with Teamviewer even before the boot problem, which is very recent. But I can’t be sure, of course.
Mark: dpkg -l | grep lsb output:
ii lsb-base 4.0-0ubuntu20.2 Linux Standard Base 4.0 init script functionality
ii lsb-release 4.0-0ubuntu20.2 Linux Standard Base version reporting utility

I've always had minor problems with Teamviewer even before the boot problem, which is very recent. But I can't be sure, of course.

Well I would follow Marks advice before mine, hope you get it sorted :slight_smile:

Thank you, Emegra.

OK, try this…

See here for how to enable the “Proposed” repository:

once you’ve enabled the proposed repo, DO NOT run a system update … just open a terminal and run:

sudo apt-get update

then

sudo apt-get install lsb-release

When that’s finished, check you have the new version with:

dpkg -l | grep lsb

Expected version = 4.0-0ubuntu20.3

Now disable the “proposed” repo again, then run:

sudo apt-get update

Now, can you also post the output from:

dpkg -l | grep lsb

here.

Che3ck if you still get that error.

dpkg -l | grep lsb:
keith@keith-Latitude-D505:~$ dpkg -l | grep lsb
ii lsb-base 4.0-0ubuntu20.3 Linux Standard Base 4.0 init script functionality
ii lsb-release 4.0-0ubuntu20.3 Linux Standard Base version reporting utility

It might be a day or so before the error appears, but I shall keep the Forum informed of progress.
Thank you, Mark.

No problem :slight_smile:

Make SURE you disable the “Proposed” repo … or when you run an update it will probably pull in a few “fixes” you don’t want :wink:

I did indeed disable it! But thanks for the reminder.
By the way: just what is “lsb” and what is it for?

LSB = Linux Standard Base
http://www.linuxfoundation.org/collaborate/workgroups/lsb

lsb_release = an application that can be queried by another application to distinguish which version of Linux it’s being run on, and configure itself accordingly.

Apparently Teamviewer 8 was querying lsb_release in a way that was showing up a minor bug, causing the error.


Wanna see it in action:

lsb_release -dr

or

lsb_release -a

That was boring eh ::slight_smile:

Thank you for the explanation and the interesting link - I can see the purpose of it now.
From what you say, it seems that the error report is not really an error, at least not one of any significance.

The old TTY mode hasn’t shown itself yet but I’ll report events here.

My thanks as usual, Mark.

Aren’t intermittent errors fun (sarcasm) :wink:

Oh, my life has been one long intermittent error.

To continue the saga: my laptop has behaved impeccably since being threatened by Forum Action but the PC I am resurrecting for my friend (whose PC I broke via Teamviewer) is now displaying the “Internal error” message since I installed Teamviewer on it. So that seems to confirm the diagnosis. Which is encouraging, in a way.
Watch this space for the next thrilling instalment.