Ubuntu / Chrome / Flash

Just as a matter of interest; Ubuntu / Google seem to have screwed up the current implementation of Flash … as a result I’ve had to switch back to Firefox …

Chrome or Chromium ? … just wondering, as Chromium uses the system wide flashplayer, whereas Chrome uses its own bult in flashplayer.

Ok, effects ALL browsers to a degree … now have a solution;

a. Goto YouTube and play a video
b. Right click on video window
c. Go to settings, then untick “Enable hardware acceleration”
d. Save/Exit

This seems to solve all problems … and there were many.
It seems (!) Chrome now complains if there is a flash security bug outstanding and refuses to load flash content until you update.
Once you update - you find they’ve added hardware acceleration which is badly broken, at least for some people.
In particular, I use 64-bit and Nvidia.

Yeh, BkS has mentioned this fix before … sommat to do with videos appearing black and white (to an extent) ?

http://linuxforums.org.uk/index.php?topic=10142.0

Mmm, methinks this is new, if it was just a black/white issue it wouldn’t have bothered me too much … but failure to display my system monitoring pages was a bit critical … also, trying certain flash pages tended to lock up the entire browser (!) , although interestingly YouTube seemed unaffected.

Hmm … very odd, can’t say I’ve noticed any problems myself … yet … but then I’m running Firefox.

I am very new to Linux and apologies if I am in the wrong post.

I am using Debian.

I need to install Firefox and remove [i]ceweasel and the install Adobe Flash player. The flash player in Debian is no good for Iplayer.

As I am new I would really appreciate very basic instructions.

I have download Flas player into my Downloads file and cant get any further.

Sorry if I am going over old ground.

Thanks[/i]

Are you running 32bit or 64bit Debian ? … if unsure, open a terminal and run:

uname -a

and post the output.

and just as a matter of interest, what is the output from:

ls -a ~/.mozilla

if that command fails … what’s the output from:

ls -a ~/

Are you bothered about the shift from Iceweasel to Firefox if we can get flash working in Iceweasel ?

If Iceweasel with aa working flashplayer will do, STOP NOW, and post the output from above.


If you DEFINITELY want Firefox, carry on with these commands (we’ll move on to flashplayer later):

wget http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/14.0.1/linux-i686/en-GB/firefox-14.0.1.tar.bz2
sudo tar -jxvf firefox-14.0.1.tar.bz2 --directory /opt
sudo mkdir /opt/firefox/plugins

then

sudo chown username:username -R /opt/firefox

Be sure to change username:username for YOUR username … so for me it would read “sudo chown mark:mark -R /opt/firefox”

then run:

sudo ln -fs /opt/firefox/firefox /usr/bin/firefox
sudo ln -s /usr/lib/mozilla/plugins/* /opt/firefox/plugins

Now if you run:

firefox

Does firefox start ?

I am running 32 Bit .

Will try the suggestions I have received .

Since my first post I loaded Chromium from the Debian Software Centre.

There is a problem with it as Flash default is set to OFF.

In trying to update the security panel there is no way to select any option as Iceweasel/Debain says the fields are undefined.

root@debian:/home/debian2# ls -a ~/
. .aptitude .bashrc .dbus .gconfd .local .synaptic
… .bash_history .config .gconf .gnupg .profile
root@debian:/home/debian2#

If I can get Flash running on Iceweasel I don’t mind at all.

Thanks

Since my first post I loaded Chromium from the Debian Software Centre.
Instead of Chromium try Google Chrome. Adobe Flash Player is directly integrated with it and enabled by default. http://support.google.com/chrome/bin/answer.py?hl=en&answer=95346 This might not solve your problem, but worth a try.

If you still have trouble then the problem might be somewhere else.
Are you connecting via proxi?

Thanks I will try that.

I have downloaded Chrome into my Download files.

What do I do next please ?

I am avery basic user so instructions on how to copy and or unzip the file , it is a .deb file.

Sorry to be a nuisance.

/home/debian2/Downloads/google-chrome-stable_current_i386.deb

I tried this but it said file not found.

Doesn’t double clicking it start gdebi (or another .deb installer) and offer to install it ?

if not, run these commands:

cd /home/debian2/Downloads

then

dpkg -i google-chrome-stable_current_i386.deb

Tried that…actually managed to install it but Chrome becomes Chromium and requires Flash to be installed.

Can someone perhpas give me the list of commands I need to install adobe flash .

I have downloaded Flash into my downloads both as an .RPM and TAR.GZ file.

Not bothered either way as long as I can install.

Would really appreciate help.

Thank you

Get rid of the RPM … that’s for redhat based distros … and send the FULL name of the .tar.gz version.

I find it strange that Chrome is changing into Chromium
Are you sure you actually run Google Chrome?
Did you try to run it from the Terminal?

google-chrome

If that does not start Chrome then I doubt it is actually installed.
If on the other hand you want to enable Adobe Flash for Cromium and Iceweasel
then see if the plugin is installed:

dpkg -l \* | grep flashplugin-nonfree

If that returns none then take a look at your sources list:

sudo gedit /etc/apt/sources.list

Look for a line similar to this (assuming you are on squeeze):
deb Index of /debian/ squeeze main
Make it look like this (notice the bold bits):
deb Index of /debian/ squeeze main contrib non-free

Save and exit

Then update:

sudo apt-get update

Once that is complete install flash player:

sudo apt-get install flashplugin-nonfree

Try Chromium or Iceweasel
If you still have problem then see if gnash is installed

dpkg -l \* | grep gnash

If it is then uninstall it:

sudo apt-get purge gnash browser-plugin-gnash

Wow.

Thank you ever so much.

Success at last after a few bad keystrokes.# Now Working with Icesweasel which is great , tested with BBC Iplayer and great. Have removed Chromium as it is like a lump of lead compared to Iceweasel.

Once again many many thanks for your help.