Ubuntu freezes on startup


I have a problem starting ubuntu 9.1. I turn on the pc, it starts up as normal, the ubuntu logo appears then dissapears and the screen goes blank and freezes without reaching the login screen.

Any help would be much appreciated.


Ok, what happens if you do “Ctrl+Alt+Del” and wait 30 secs, does it reboot?

And does “Ctrl+Alt+1” do anything?

When it boots, before / during Ubuntu logo phase, will hitting ESC do anything for you?

Do you still have an Ubuntu install CD handy?

Thanks for your reply,

I’ve tried hitting control+alt+1, control+alt+F1. Nothing happens
Hitting control+alt+delete just restarts and it freezes after the logo
Hitting ESC during the blank screen gives me the option of entering commands
I no longer have the Ubuntu install CD.

Hitting control+alt+delete just restarts and it freezes after the logo

This means it’s not starting your GUI.

Hitting ESC during the blank screen gives me the option of entering commands

Ok, this is useful, what prompt does it give you / what commands can you enter?

I no longer have the Ubuntu install CD.

You should try to re-acquire one of these.

has this happened immediately after installation (never booted to desktop) or has the system worked before, but it has just done this?

Thanks again,

after hitting escape it comes out with a few lines:

mount mounting: /dev/disc/by-uuid/2a4f7484-8db4-42fa-9eed-d6e8ca761bb7 on /root failed: Invalid argument
mount mounting: /sys on /root/sys failed: No such file or directory
mount mounting: /dev on /root/dev failed: No such file…
mount mounting: /sys on /root/sys failed: No…
mount mounting: /proc on /root/proc failed: No…
Target filesystem doesn’t have /sbin/init.
No init found. Try passing init= bootarg.

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

(initramfs) help

Built in commands:

. : [ alias break cd chdir command continue echo eval exec exit
export false getopts hash help let local printf pwd read readonly
return set shift source test times trap true type ulimit umask
unalias unset wait [ [[ ash awk basename cat chmod chroot chvt
clear cmp cp cut deallocvt df du dumpkmap echo egrep env expr
false fbset fdflush fgrep find grep gunzip gzip hostname ifconfig
ip kill ln loadfont loadkmap ls mkdir mkfifo mknod mkswap mktemp
more mount mv openvt pidof printf ps pwd readlink reset rm rmdir
sed setkeycodes sh sleep sort stat stty sync tail tee test touch
tr true tty umount uname uniq wc wget yes zcat


The system worked perfectly before, this happened all of a sudden

try this…
hold the Shift key whilst booting… you should get to the GRUB boot list screen
If there is an earlier kernel listed, try booting from that.

If this doesn’t work it looks like either the file system is screwed or there is a problem with GRUB, either way you’re going to need a LiveCD, or LiveUSB stick.

Suggestions from the command prompt;

It looks a bit like either your “fstab” has been corrupted and is trying to mount the wrong root filesystem, or the UUID of your filesystem has changed. (or the disk has become damaged in some way)

Can you try;

fdisk -l

And see if you can identify your “root” filesystem. Hopefully it will have “Linux” in the ‘System’ column and be the largest of the available “Linux” partitions. Once identified (for example; /dev/sda1) can you do;

mkdir -p /mnt/root
mount /dev/sda1 /mnt/root    # replace sda1 with your device!
chroot /mnt/root

And see if this looks like your root filesystem … ?

If this works / looks good so far, continue with;

vi /etc/fstab

You will have a line that says something like; UUID= / ext … insert a ‘#’ at the beginning of this line.
Now add a new line that says;

/dev/sda1 / ext<n> errors=remount-ro 0 1

(replace sda1 with your device and with whatever was used on the line you commented out [3 or 4])

Now do “update-initramfs” (** ok, initially I mixed up my threads here :slight_smile: ** )

  • this should write your changes to /etc/fstab into the boot process … now do;
umount /mnt/root

so if you do CTRL+ALT+DEL at this point, hopefully … (!)

Have the same prob. it does boot after awhile but it takes a very long time. But with me no keys work at all. It didnt even boot from the cd which is 9.10. it installed 10.04 without even asking. It didnt create a partition or anything but i got duel boot. Only prob is nothing on 10.04 works. i posted the prob in the before i swap topic because the instrutions on how to install it r in there. I double checked the ubuntu site to see how to install it. none of the boxes they said that will come up did. It looks like it installed from the 10.04 download on my HDD rather than the cd which is 9.10.

If your system didn’t boot from the 9.10 LiveCD, it is either another bad burn (get some better CDR’s), or you didn’t set the system to boot from CD first.

To boot from the LiveCD, you will have to set the CD drive as the first boot device in the BIOS, or hit the “Boot device select” key as the system boots (usually F8 or F11) and select the CD as the device to boot… keep an eye out for a message telling you which key to press as you turn the PC on.

The Wubi installer can’t have run itself, although if you insert the LiveCD whilst running Windows it will autostart (but you will still have to select “Install”)… from what I gather wubi should be “run as administrator” in Vista or Win7, but we don’t advise using Wubi at all, as Ubuntu will then be installed to a folder inside Windows which undermines Linux security and can leave the Linux install open to interference from windows Viruses/Malware.


As far as I know Wubi defaults to download the latest ISO and install that, unless specifically pointed at an already downloaded ISO image.

Wubi was the prob. But im having boot up probs as well. its getting stuck at the setup and boot menu bit. Its not responding to any keyboard inputs. But i hit Del and after half an hr i got into BIOS and changed the boot order and ran 9.10 from cd. It took another half hr to get in to 9.10 but when i did get in everything worked fine. But untill i sort out the bootup prob i wont install it cause think i might have to do a factory reset. Even when i do eventually get into windows everything is taking ages to respond. I had major probs when i used chrome beta 6. had virus warnings coming in faster than kaspersky could handle. so that might be the prob. But the probs didnt start till i installed Wubi 2 days later. Its when i did the restart to finish installing Wubi when the bootup prob started. So not sure if its a delayed chrome prob or Wubi. Ive got rid of both but the prob is still there and getting worse. I ran the start up repair but that didnt find any probs neither has any of the diagnostic tools ive run. All the hardware seems to be working ok as well. According to MS its ubuntu that caused the prob cause its full of viruses lol. typical respons they always blame everyone else cause they cant be bothered to help sort out their OS probs. Think the best way to tech MS how to treat ppl is to stop using MS products. Hit them in the pocket then maybe they will listen.

If it’s taking that long to get past the POST screen and let you into the BIOS, it sounds like either a hardware problem, a BIOS setting problem, or your hard drive isn’t being auto-detected properly by the BIOS.

Try removing the hard drive, and check it will let you into the BIOS instantly… if it does, then try reconnecting the hard drive, enter the BIOS and detect the hard drive manually (ie. not set to auto-detect).

Generally a factory reset on the BIOS isn’t going to cause you any problems (and it could well solve the problem) … it might hit your performance a little if you don’t know how to re-tweak it, but 9 times out of 10 you won’t know the difference.