UBUNTU is so confusing???

O.k. so i got a virus on my PC, I couldn’t get rid of it so i decided i would re-install my OS.
But i could not find the disk to my windows XP home edition, so i decided i would give a linux based one a try instead.
I settled for UBUNTU 10.10 but i have had several problems since: -

  1. I cannot get my 3connect (internet dongle software) to run. It says something about not been able to find the autorun or something, I clicked on the autorun.exe but still cant get it to work. (however im using the dongle now, just not with the intended software which is kinda cool but I cant check my internet usage etc…
  2. I cannot check my googlemail?? google works fine but when i go to try and check my emails it comes up with an error and says to try later. (which i did, still doesn’t work though.) im using Firefox which came with UBUNTU.
  3. Games I download, I cannot get them to install ???
  1. Try installing the the usb-modeswitch package from within your package manager, or by opening a terminal (Applications>Accessories>Terminal) and entering:
sudo apt-get install usb-modeswitch

then follow these instructions:
http://linuxforums.org.uk/linux-tips-tricks/setting-up-a-3g-dongle-from-the-ubuntu-network-manager/msg22872/#msg22872

  1. If you have a working internet connection, this is nothing to do with Linux, it is a problem at Googles end and would be the same in Windows.

  2. I take it you mean “Windows” games… Linux does NOT run Windows software, some Windows software can be made to work in WINE though.

Stop downloading software from the internet, that’s a bad Windows habit… get your software through the Ubuntu Software Centre (Applications>Ubuntu Software Centre) or through your Synaptic package manager (System>Administration>Synaptic Package Manager)

If they ARE Windows games, and you ARE trying to install them through WINE, let me know what the games are, and how you are trying to install them.

Hello Thank you for replying.

“1) Try installing the the usb-modeswitch package from within your package manager ((Please explain more.), or by opening a terminal (Applications>Accessories>Terminal) and entering:” (I did this but after i have entered the code it says "[sudo] password for dan:, but when i try to enter it there is no text coming up??)

I do already have the dongle working, it was really easy to do, I want to be able to use the program “3connect”(It lets me check how much data i have used and send texts) on my ubuntu like i did on my windows one. on the windows one it would autorun when it was inserted, but on here it just sits there on the desktop??

The games are not windows games specificaly i dont think, they are pretty simple ones “Dream Day, wedding” (its for my gf lol) the games in the ubuntu software centre are not to my gf’s taste :frowning:

Im not sure about WINE (i dont know anything about it) but my desktop is really low spec, not good enough to run any “real” games lol.

thanks for your help!! :smiley:

If you already have the dongle working DO NOT install usb-modeswitch… it may mess things up.

Your password WAS being entered, but unlike Windows nothing is displayed back to screen, not even *****, just enter it and hit enter.

3 recommend you go to the “Check my Balance” page on My3 to view your usage figures, as AFAIK you can’t get 3Connect to run in Linux.

If these are games from places like “big fish” etc. … and when you download them they come with an .exe extension, they ARE Windows games (anything with an .exe extension is a Windows app), but I’ll see what I can find out about “Dream Day Wedding” and post back.

[EDIT]

Doesn’t look like Dream Day Wedding will run, even in WINE… I just had a quick go and though it installed, it refused to run. :frowning:

Well I ended up installing it, the usb modeswitch but i have restarted and everything seems ok. (it let me back here).

I am using the “check my balance” part of my3 but i like real time info (that only seems to update when you disconnect and reconnect) but i found using the “network tools” and changing the network device to “modem interface (ppp0)” that i can watch the two (transmitted and received bytes) and add the two to get the total usage in “real time” i checked this against the “check my balance” and they seem to match up.

Still missing the ability to send texts :frowning: (anyway around this?)

I never knew that .exe was windows only, the game does have .exe for the installer :frowning: (would WINE help me here?) what file type does linux/ubuntu use?

Thanks :slight_smile:

also my sound doesn’t work?? :-[

WINE may help, but don’t expect every windows app to run in it… most won’t… see the App database at WineHQ for a database of what works and how well.

and

and

Dunno about texts, I’ll see waht a can discover.

Linux installers… Hmmm, where do I start…

OK, the closest thing on a debian based distro (like Ubuntu) to a Windows .exe binary installer, would be a .deb package, but there are many others and other ways of intstalling software… best thing I can suggest is read this and then ask about anything you don’t understand

http://linuxforums.org.uk/general-help-advice/installing-add-on-etc-help/msg39722/#msg39722

OK, sound…

Can you open a terminal and enter:

sudo lshw -C multimedia

(hit enter and password when asked)

and post back the output, same with:

cat /proc/asound/card0/codec#* | grep Codec

Remember Linux commands ARE case sensitive… copy and paste if needed.

sudo lshw -C multimedia results :-

*-multimedia
description: Multimedia audio controller
product: 82801G (ICH7 Family) AC’97 Audio Controller
vendor: Intel Corporation
physical id: 1e.2
bus info: pci@0000:00:1e.2
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: driver=Intel ICH latency=0
resources: irq:23 ioport:ec00(size=256) ioport:e8c0(size=64) memory:feabfa00-feabfbff memory:feabf900-feabf9ff

cat /proc/asound/card0/codec#* | grep Codec Results: -

cat: /proc/asound/card0/codec#*: No such file or directory

thank you.

OK, try this:

First we’re going to add a PPA repository, so open a terminal and enter these 2 commands:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update

hit enter after each line, and your password when asked.

Now we’ll install the linux-alsa-driver-modules package

Still in the terminal enter:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)

After installing the linux-alsa-driver-modules package, your system needs to be rebooted.

[EDIT]

if sound still doesn’t work, can you post the output from:

cat /proc/asound/card0/codec#* | grep Codec

and

aplay -l

again.

sudo apt-get install linux-alsa-driver-modules-$(uname -r) done everything to this point, will reboot now and keep my fingers crossed.
where else other then the ubuntu software center can i get games for linux? my gf likes “hidden object games” thank you for all your help. also the default homepage in firefox does not load up (is this normal?) it is Ubuntu Start Page

Erm… she may be out of luck, I searched for hidden object games, and couldn’t find anything.

Look here:
http://www.gamingonlinux.info/
and
http://www.happypenguin.org/

And no that’s not normal… Firefox should have NO probems with web pages, but one at a time, lets sort sound first… then we’ll work that out.

i now have sound ;D. thanks!!

I got WINE 1.2 tried to get the game to work but it installed but wouldn’t work then when i went to uninstall the game it said it had but the .exe was still on the desktop, i removed wine but its still there. in applications there is just a wine folder there now with programs then dream day wedding. :frowning:

you can either re-install WINE, and just remove the DDW icon from the menu, or delete the hidden .wine folder, and remove the Whole wine menu ite.

Which od you wanna do… I’d keep WINE if I were you

I will re-install wine (do i have to download it again?), how do i remove it from the menu? i deleted the exe of the desktop but it has come back.

You shouldn’t have downloaded it in the first place, you should have got it from your package manager.

I think i did, i got it through the software centre. its ok i just searched in there and it is re-installing now.

Do you ever check your PM’s ?

check “My Messages” top of page.

lsmod results : -

Module Size Used by
ppp_async 6778 1
crc_ccitt 1351 1 ppp_async
nls_utf8 1069 1
isofs 30022 1
ipt_MASQUERADE 1419 1
xt_state 1014 1
ipt_REJECT 2004 2
xt_tcpudp 1927 4
iptable_filter 1302 1
nf_nat_h323 5121 0
nf_conntrack_h323 46894 1 nf_nat_h323
nf_nat_pptp 1996 0
nf_conntrack_pptp 4681 1 nf_nat_pptp
nf_conntrack_proto_gre 3901 1 nf_conntrack_pptp
nf_nat_proto_gre 1271 1 nf_nat_pptp
nf_nat_tftp 728 0
nf_conntrack_tftp 2905 1 nf_nat_tftp
nf_nat_sip 5574 0
nf_conntrack_sip 18703 1 nf_nat_sip
nf_nat_irc 1168 0
nf_conntrack_irc 3348 1 nf_nat_irc
nf_nat_ftp 1398 0
nf_conntrack_ftp 5361 1 nf_nat_ftp
iptable_nat 3752 1
nf_nat 16289 9 ipt_MASQUERADE,nf_nat_h323,nf_nat_pptp,nf_nat_proto_gre,nf_nat_tftp,nf_nat_sip,nf_nat_irc,nf_nat_ftp,iptable_nat
nf_conntrack_ipv4 10783 4 iptable_nat,nf_nat
nf_conntrack 63258 18 ipt_MASQUERADE,xt_state,nf_nat_h323,nf_conntrack_h323,nf_nat_pptp,nf_conntrack_pptp,nf_conntrack_proto_gre,nf_nat_tftp,nf_conntrack_tftp,nf_nat_sip,nf_conntrack_sip,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,iptable_nat,nf_nat,nf_conntrack_ipv4
nf_defrag_ipv4 1117 1 nf_conntrack_ipv4
ip_tables 10460 2 iptable_filter,iptable_nat
x_tables 15921 7 ipt_MASQUERADE,xt_state,ipt_REJECT,xt_tcpudp,iptable_filter,iptable_nat,ip_tables
binfmt_misc 6599 1
i915 295435 4
drm_kms_helper 30200 1 i915
drm 168060 4 i915,drm_kms_helper
snd_intel8x0 26004 2
snd_ac97_codec 100619 1 snd_intel8x0
i2c_algo_bit 5168 1 i915
ac97_bus 1014 1 snd_ac97_codec
snd_pcm 77418 3 snd_intel8x0,snd_ac97_codec
video 18712 1 i915
output 1883 1 video
snd_seq_midi 5164 0
snd_rawmidi 18510 1 snd_seq_midi
snd_seq_midi_event 5951 1 snd_seq_midi
snd_seq 51277 2 snd_seq_midi,snd_seq_midi_event
intel_agp 26566 2 i915
snd_timer 19053 2 snd_pcm,snd_seq
snd_seq_device 6034 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 57181 12 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_seq_midi,snd_rawmidi,snd_seq_midi_event,snd_seq,snd_timer,snd_seq_device
option 13453 2
led_class 2633 0
soundcore 880 1 snd
snd_page_alloc 7184 2 snd_intel8x0,snd_pcm
usb_wwan 9953 1 option
ppdev 5556 0
psmouse 59033 0
joydev 8767 0
agpgart 32011 2 drm,intel_agp
dcdbas 5402 0
usbserial 33357 7 option,usb_wwan
parport_pc 26058 1
serio_raw 4022 0
lp 7342 0
parport 31492 3 ppdev,parport_pc,lp
usbhid 36882 0
hid 67742 1 usbhid
tg3 123310 0
usb_storage 40204 1

Can you install these 2 packages… pavucontrol and gnome-alsamixer by running this:

sudo apt-get install pavucontrol gnome-alsamixer

Then… still in the terminal, enter:

pavucontrol

When the Volume control opens, go to the “Playback” tab, and put the Volume up to around 70% or above.

Close the Volume control

Now go to Applications>Sound & Video>GNOME ALSA Mixer and see if anything in there makes a difference to your audio.