Ubuntu V11.10 problems

I started Linux with Ubuntu V 11.04 and liked it very much. When the Update Manager offered V11.10 I accepted despite many problems with the installation due, probably, to a poor broadband connection.
I found V11.10 rather slow to respond - e.g. ALT+TAB took about 1sec to tab between applications and I could easily out-type LibreOffice writer.
Now LibreOffice has become ultra slow and the spreadsheet locked me out while it auto-saved repeatedly. Manual saving was refused. FireFox is now at a snail-pace (except for this typing) and I have to wait many seconds for the scroll to catch up.
I am at my wits’ end and long for V11.04 - can I go back? Any solutions?
(As a general comment: I preferred the Classic View of V11.04. This V11.10 is beginning to feel like a move to Microsoft bloatedness.)

Keith :frowning:

Is there not an option called Gnome (Classic) at the Login screen by default in 11.10 ? (if not, install gnome-session-fallback)… at the login screen click the little cog icon by where you enter your password.

Erm … sorry to say it, but NO there is no easy downgrade path that I’m aware of, which is why it’s usually a good idea to wait a couple of months before upgrading, then you can read how it went for others.

Thanks, Mark - I think!
I shall just have to hope that future updates fix the problem.
As for the classic view: it is not among the options, so how do I install the gnome-session-fallback?

Thanks as usual for your help.

Open a terminal and enter:

sudo apt-get install gnome-session-fallback

hit enter, and your password when asked.

Be Aware - You won’t see anything echoed to screen when you type in your password, not even ******, but it is going in … just type your password and hit enter.

Then log off (or reboot) and the Gnome (Classic) option should be there when you click the cog :slight_smile: … don’t know if it will help with your problem though.

Gnome (Classic) in 11.10 is not exactly the same as it was in 11.04 … it’s Gnome 3 acting like Gnome 2.x

Ah - that command style rings a bell - thank you.
Other problem: I shall just have to work slower until the upgrades catch up with the faults.


OK, I give in! Would you tell me where I can find the terminal link?
I have tried System Settings and everything in Dash Home (inc. System and Accessories) to no avail.
Sorry to be a nuisance.


Well that’s one way of looking at things :wink: … a kind of cross your fingers and hope for the best approach :slight_smile:

Either …

hit Ctrl+Alt+T … a terminal should open.


Click the “Dash” (top by default with the ubuntu symbol on it) icon on the Launcher bar (left of screen), then enter terminal into the search box … then click the terminal displayed icon.Dash

You can also display ALL installed apps by entering Dash, clicking More Apps then clicking Installed See (n) more results
(where (n) is a number)
Click the writing (in Dash>More Apps I’ve highlighted in red).

You’re a gent, as usual.


No worries … has it speeded things up any ?

No; it’s as slow as ever. I’ve checked the Ubuntu Forum, but no-one else is reporting a similar problem, which is worrying in its own way.
System Monitor does not show any CPU or memory hogging, there is no disc activity and no internet activity, so I’m stumped. I can’t even resize this window.
If you think of anything, feel free to contact me.


How does it run from a LiveCD, or LiveUSB ? … ie. NOT as an upgrade.

Just trying to work out if your PC just doesn’t like 11.10, or if something went wrong in the upgrade.

Well - this is bizarre.
First off: I don’t a V11.10 disc so can’t try that one, but … although there was no evidence of a virus at work (no internet or disc activity) the general slowness and serious problems with LibreOffice (esp. spreadsheet) prompted me to look at XP (which I haven’t used since Ubuntu) in the other partition (which I do access via Ubuntu).
It had clearly been messed about with as the resolution had changed and the desktop icons had been realigned.
So I updated everything (took all day!) and ran scans with AVG and SpyBot - both giving clean bills of health.
Rebooted into Ubuntu. Everything works fine (including the spreadsheet) except for the LinuxForums.org.uk page! (All other URLs that I have tried are fine.) The vertical scroll and general navigation still have delays of several seconds. So it looks like I had two problems simultaneously:

  1. Something in the other partition (caused by who-knows-what?) affecting Ubuntu. (Fixed, I hope, but I’ll keep you posted.)
  2. a problem with the LinuxForum site. Server problem?
    My ultimate solution (funds permitting) will be to have an Ubuntu-dedicated PC, but I would be interested to hear you views on my problem with this site.

(added later) With several Firefox tabs in use, with any tab displayed, selecting other applications from menus or ALT-TAB is fine. With the LinuxForums tab displayed, selecting other applications is very slow
Best regards as usual,

Keith which version of Firefox are you using? Firefox not to long ago released Firefox 8, so if you haven’t upgraded I’d suggest you should, it’s far faster than previous versions.

Unless you’ve got a third party program on your windows partition to read the EXTx filesystem, I don’t see how Windows could’ve cause anything.

The site and forums are both working perfectly so, it’s just your machine. Have you check the system monitor to see if anything is eating at your resources? I know that since early this month, people have been having performance issues with LibreOffice so you aren’t the only one. I think this was caused by an update, but I don’t have it so I couldn’t comment on that.

Ah! Firefox V7.01 I shall update and let you know…
…Apparently, since Firefox came with the Ubuntu package it should update automatically. The Mozilla/Firefox site says:
"Note: If you use your Linux distribution’s packaged version of Firefox, you will need to wait for an updated package to be released to its package repository. "
Sure enough, the Edit/Preferences/Advanced menu item does not display an option to update Firefox; only the Add-ons and Search Engines options.
So it looks like I’ll have to wait until V8 appears in the repository.

@ BkS
If the Windows partition is set to automount … a screwed Windows file system could theoretically affect Linux performance, as it continually tries to make sense of the screwed Windows file system.

Solution … run chkdsk from within Windows.

@ Keith
There is nothing at all wrong with this site … have you tried clearing the Firefox cache ? … in case there is a corrupt local copy in the cache.

@Mark: Ah, I wasn’t sure since Windows can’t read EXT filesystems.

@Keith: Try running the update manager, to see if the update is there yet. or you could try running from a terminal:

sudo apt-get update

@ BkS

You’re right, without third party software, Windows won’t be able to access an EXT filesystem … but I think he means that something on the Windows side may be slowing Linux … and Linux CAN see (and attempt to read) the Windows drive/partition :slight_smile:

Curiouser and curiouser!
Your posts appeared in an Email. Clicking on the link opened another tab in Firefox with your new posts which happen to be on a new page [2].
The page was slow as usual.
I updated as suggested via a terminal (very little to update as I usually check every time I log on) and all is well !!

Re clearing the Firefox cache: do you mean Clear Recent History? Couldn’t find anything marked “cache”.
Anyway - Many thanks to you both for your great help. As usual! :slight_smile:


Yes … in Firefox, go to Edit > Preferences > Privacy, then select “Clear recent history” … in the next window, put a tick in “Cache” … set the time range to “Everything” … and click “OK”.

Wait a few minutes till it’s done … then close Firefox and reopen it … now try this forum.