Ubuntu V11.10 stuck at the dual-boot display - Solved - Finally!

It turns out that I have to order the Argos KB, which will take days. I have found a nice Cherry USB/PS2 KB with many rave reviews, and Cherry has a very good name.
PC Systems & Components | OcUK Much more expensive, but probably a wise choice. Delivery tomorrow.

Yep: the wireless KB and its adapter were on the same channel (choice of 2) but the lights don’t show.
Windows 95 KB: the lights flash on when plugging it in, but caps/num lock operation doesn’t show any lights. I would expect the caps lock light to work if power is available even if it’s not communicating with the PC.

Stay tuned for tomorrow’s exciting installment. ::slight_smile:

May I suggest looking for drivers? XD

Could be that your batteries are duff for the keyboard… ::slight_smile:

Sorry: I don’t understand what you mean by “looking for drivers. XD”
The wireless KB batteries are fine, and the other KB is wired.
I have had difficulty in the past with keyboards - it turned out that it preferred Microsoft KBs, so I tried two today without success.

PS/2 wireless keyboards rarely need drivers (unless for added functionality, like multimedia keys).

@ Keith

What I meant by “lights” was … normally PS/2 wireless mice and keyboards have lights on the receiver (the bit that plugs into the PC) which flash when they receive a signal from the keyboard (or mouse) … ie. lights will flash on the receiver when a key is pressed on the keyboard to indicate the receiver is getting the signal.

Are there any such lights on the PS/2 wireless receiver ? … and are they flashing when you hold a key on the keyboard ?

[EDIT]

Those lights are independent of the OS (and the PC, except for power), so if they aren’t flashing the keyboard/reciever is broken, they aren’t associated with each other, or the receiver isn’t getting power from the PS/2 port.

Mark, I did understand you correctly: The receiver lights do not show any activity when the keyboard is used - for example the caps lock light on the receiver does not respond to the the use of the caps lock key.
However I have just realised that I left some documents on top of the KB overnight and the batteries are probably discharged now. What a twit ! I shall fit new ones tomorrow, but by then I shall have my new USB-PS/2 k/board to try.
I shall report back on the morrow.
Sorry to be such an idiot!

Hey, I’ve done dafter things … like binned a laptop, then suddenly realised it just needed the BIOS recovering … too late, bins had been emptied ::slight_smile:

I must have been half asleep that day … ho hum !!! :o

[EDIT]

Before anyone asks … YES I stripped it of usable parts first … but still felt a right plonker.

I’m supposed to know better.

Thank you for sharing that with us! It makes me feel so much better.

Was that sarcasm … as in … “christ, and I’m asking this idiot for help” ?

or

as in … “now I don’t feel so bad” ?

:wink:

Mark - how could you doubt me? I really appreciate your assistance and could not possibly be a Linux user without your generous help.

Summary of the problem

  • I gave away my usual PS/2 keyboard & mouse with a system that I built for a friend, knowing that I could use her wireless k/b & non-wireless mouse (which I had given her earlier) on my own PC.
    On my PC the wireless k/b did not function, although the mouse did.
    In desperation I rebooted the PC by pressing the main “On” button on the PC (yes, I know!).
    This had the effect of stopping the auto boot function of Ubuntu, and it froze at the dual-boot screen awaiting input from me.

Fist attempts at a solution

  • I had an unused, Windows 95(!) k/b in stock so tried that: the lights flashed when plugging it into the PS/2 socket, but operating the Caps/Num Lock keys failed to show any lights.
    Panic!
    Begged help from this Forum.
    Mark advised borrowing a known-functioning keyboard: my local, friendly computer shop provided two – with a null result.
    Ordered a new k/b.

The results

  • Found that the wireless k/b batteries were flat due to me leaving some documents on it!
    In the meantime, I tried resetting the BIOS by removing the battery for a few hours.
    Retried the wired k/b which now worked on some keys, at which point the new k/b arrived.
    Tried the new k/b via both the USB and PS/2 sockets – null result, but the partial success with the old k/b after rebooting the BIOS prompted me to use the on-screen k/b to log in and “register” the k/b with the system via “settings/keyboards”.
    Successful registration of the new k/b while using the USB plug but not the PS/2.
    (Note the BIOS requested a reset of the date, which I did, but I could not access other pages. Perhaps it will now that the k/b is recognised.)

Conclusions

  • Never switch off using the hardware button!
    Always check your batteries, including the BIOS battery.
    Rebooting the BIOS might be a useful trick as long as most of the keyboard functions are recognised.
    If you intend to change your keyboard – be careful!
    Remember to thank your Forum mentor – Thanks, Mark!

Heh … I was just pulling your leg :wink:


I’m still a little bothered that the PS/2 keyboard port appears to be dead, but at least you’re up and running again.

Do the lights come on on the keyboard if you boot with the keyboard plugged into the PS/2 port ? … don’t worry about it if you don’t want to mess with it whilst it’s working.

Be aware (unlike USB keyboards) a PS/2 keyboard will only be recognised if it is plugged in BEFORE turning on the PC … ie. you cannot hot-plug a PS/2 keyboard.

Earlier this evening I booted up in PS/2 mode and was able to use the arrow keys to select the right option; at the login screen I was able to enter my password and log in; but then the k/b failed to respond.
I shut down as I had to go out.
About three hours later, I booted up in PS/2 mode again, this time successfully and I was able to use the keyboard in all applications.
Within a few minutes, the k/b stopped responding (not even Caps Lock lights) and I had to shut down.
I am now in USB mode which seems to be stable.

There is something very wrong with the PS/2 mode.
In practice, it’s not a problem as long as the USB mode continues to function, but it would be nice to fix it if possible.

Sounds like there is a bad connection between either the keyboard and the PS/2 port … or the PS/2 port and the motherboard.

is the keyboard plug going in far enough ? … does it seem like a snug fit ?

No, it it feels a rather loose fit. I tried holding it in but that made no difference.
Isn’t it amazing how so many coincidences happen together?!
I shall open up the PC tomorrow and check the electrical continuity all the way.

My new Cherry k/b is a pleasure to use - well worth the extra money.

Have you just built this system ? … the reason I ask is, years ago I built a system and the PS/2 port was behaving similarly … I took the motherboard out of the case to see if the back of the motherboard was touching any part of the case … couldn’t see anything, so I put it back together … everything worked … still don’t know what it was, but it never gave me any problems after that.

One of those “weird or what” moments :slight_smile:

No: the system is as I received it, except for adding memory and installing Linux.
It does seem odd that the problem arose only when changing the k/b. Anyway, I’ll take it apart and see what happens.

You’re right, it does seem odd … I would have suggested that maybe you’d broke a pin off the old KB and it was still in the motherboards PS/2 port … but then the KB you gave your mate would be unlikely to work in his PC.

Very odd.

Anyway, good luck in tracking down the issue.

The PS/2 socket is fully shrouded so I can’t check the connections, and I’m not taking the mother board out to scrape the varnish off the solder connections!
When booting up this a.m. with the k/b in USB mode, the k/b did not respond until the the PC had auto booted into the log-in screen. It’s been OK since. Ah, me!
Perhaps I should consider buying a new(er) PC. One day.
For now, though, I think this problem is “solved”, and my new Cherry keyboard is really good to use.

Update and final solution!

The issue of the k/b not responding until after the dual-boot had started automatically became serious after I foolishly decided to abort my use of the PC by pressing the PC stop button. Upon starting the PC later, the dual-boot screen sat awaiting my input and would not time out – and the k/b was still being ignored. Time to panic!

The problem must have been a Linux one as the USB k/b was recognised by the BIOS. Using this facility and F2, I found that there is a “Legacy USB” facility that was disabled by default. Re-enabling it brought the k/b to life at all stages of the boot process.

I hope this helps anyone with a similar problem.

I still don’t see this as a “Linux” issue … “Legacy USB” makes the keyboard send signals to the OS as if it were a PS/2 keyboard … otherwise you’d have to wait till the USB K/B drivers get loaded by the OS.

The PS/2 side of your problem still sounds like a hardware issue, as it was working with your old K/B.

The USB K/B problem is normal behaviour for some motherboards.

But whatever it is/was … I’m glad you’ve solved your problem :slight_smile: