Unable to change permission of a drive or it's contents

I have been using Ktorrent and had a specific folder where .torrent files and partial downloads and complete downloads are stored, each in their own folder. That was until 2 days ago when Ktorrent was failing to save the data.

I have discovered that somehow, the permissions have changed. I know it’s not me as I have had no reason to change any permissions. I have tried to change permissions back to me but I get an error report.


This is a screenshot of the drives, drive EXT-01 will not let me change permissions.


I’ve also been looking into changing permission via the terminal but I can’t seem to find the correct way to do it.

(p.s. Can anyone recommend a decent FREE file sharing site with decent size pictures)

Sorry Mark. I followed your instructions and this is the smallest I can get.

image hosting site:
tutorial on how to use, here:

Can’t give you a command to change permissions until we know where the folder is ?

I don’t get given that information when using Dolphin to change permission, just the dialog box informing me I am unable ‘Could not change permissions for /…A8930469CF69B99230E070E61F02A36FB.’

Is all I get.

what’s the way to do it via terminal?
It’s path is ‘/media/EXT-01/’

Assuming your username is “pooky”…

To make that directory read/write/execute by everyone:

sudo chmod 777 /media/EXT-01

then to take ownership of the contents (recursively):

sudo chown -R pooky:pooky /media/EXT-01

I get this result
pooky2483@Kubuntu-1404-LTS-PhenomII:/media/EXT-01$ sudo chmod 777 /media/EXT-01/
[sudo] password for pooky2483:
chmod: changing permissions of ‘/media/EXT-01/’: Read-only file system

Okay that disk/partition probably has file system errors so has been remounted read only.

What’s the output from:


Okay for large images (from imgur) on this forum make it like:


which will limit the width to 700 here, but make the image a clickable link to the image hosted by imgur … just in case you need to view it full size.

I’ve fixed the ones in your first post :wink:


/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sdc1 on /media/INT-01 type ext4 (rw,nosuid,nodev)
/dev/sdb1 on /media/INT-02 type ext4 (rw,nosuid,nodev)
/dev/sdd1 on /media/EXT-01 type ext4 (rw,nosuid,nodev)
/dev/sde1 on /media/EXT-04 type ext4 (rw,nosuid,nodev)
/dev/sdf1 on /media/EXT-05 type ext4 (rw,nosuid,nodev)
/dev/sdg1 on /media/EXT-06 type ext4 (rw,nosuid,nodev)
/dev/sdi1 on /media/EXT-02 type ext4 (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)

You’ll notice EXT-03 is not there, that’s because the power supply is duff.
Thanks for the Imgur image info, I’ll have a look at it :slight_smile:

Try running:

sudo umount /media/EXT-01

then as long as that command finishes without error:

sudo fsck /dev/sdd1

then reboot and see if it’s writeable

sudo umount /media/EXT-01

Came up with
umount: /media/EXT-01: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8 ) or fuser(1)) * Space added after the 8 as it produces a smiley

Somethings strange as, if I (pooky2483) can’t write to it, what IS?

Have you tried simply rebooting ?

Is the torrent app still attempting to write to it ?

This might tell you what’s keeping the device busy

sudo lsof | grep EXT-01

or maybe

sudo lsof | grep sdd1

It was TOR. I’m just going to stop TOR and go back to previous commands you posted.
Ktorrent is not running as it was failing to rite to I stopped it.

I’ll come back with the results in a min…

Looks like it’s sorted, I’m currently changing permission of EXT-01.
Thanks Mark :slight_smile:

You’re welcome :slight_smile:

I left Ktorrent running last night and the drive permission problem is back, unable to write, also root is unable to delete (after opening Dolphin as root - sudo dolphin).

sudo fsck /dev/sdd1

[spoiler]fsck from util-linux 2.20.1
e2fsck 1.42.9 (4-Feb-2014)
EXT-01: recovering journal
EXT-01 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Deleted inode 204210178 has zero dtime. Fix? yes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences: -(816873480–816874140)
Fix? yes
Free blocks count wrong for group #24929 (31422, counted=32083).
Fix? yes
Free blocks count wrong (637802043, counted=644722240).
Fix? yes
Inode bitmap differences: -204210178
Fix? yes
Free inodes count wrong for group #24928 (8156, counted=8157).
Fix? yes
Free inodes count wrong (236204456, counted=236205494).
Fix? yes

EXT-01: 125514/236331008 files (0.7% non-contiguous), 300576960/945299200 blocks[/spoiler]

I bet the drive’s failing :frowning:

Not necessarily.

I hope not but just in case, I’m clearing the contents onto other drives.

Never hurts to have backups if the stuff is important to you, right :slight_smile:

What’s the easiest & cheapest backup system as I have a total of 30TB external storage.

LOL … are you after s 30TB backup solution on the cheap ;D
(depending on your definition of “cheap”, that’s unlikely to happen)

Or are you just looking for a software backup solution that can utilise your 30TB storage for the backups ? … if so, what do you want to backup ?