Unable to connect new Novatech nspire 1621 laptop to internet [SOLVED]

Hello and Happy Christmas!

I have just bought a new Novatech N 1621 laptop with no OS. I have installed Mint 17 Mate 64-bit from a CD (same cd I used for the successful installation on this old laptop). I can’t get the computer to find the wireless connection from my ‘Plusnet’ router. I have the unconnected symbol showing on the bar on the bottom right hand corner of the screen but no amount of clicking on it brings any results. This computer detected the wireless signal as soon as installation was completed.

I have tried looking at the content of the driver CD supplied but Mint ont open any of the files :cry: Please, can anyone help?1 The sales blurb says that the N1621 is supplied with an Intel Dual Band Wireless - AC 7265. I am not computer savvy so a simple explanation would be much appreciated!!

Hi,
I bought the Novatech N1543 (I think) some time ago without the OS. I now run Peppermint 6 on this machine without issue (except when Virgin plays up) and it is through the good advice of this forum that all is well.
Look up my threads and you should get a rough idea what to do. Otherwise wait for Mark, I am sure he will be along pretty soon.

take care
Don W
PS Merry Christmas everyone ;D

@ahead, is there a reason you are using 17 and not 17.3? Sometimes there are bug fixes in newer releases and without the ability to update 17 you will not get them.

There is a bug report on this so wait for some help, should be fixable but I could not be sure of the answer I found so won’t post my findings. Mark is genius, he should be able to help. Another operating system might be the answer, or even the 17.3 Mate, but I can’t be sure with the info I found.

@ahead, usually plugging in the ethernet cable first will then let the wireless signal through. Don`t know why, but that worked for me a while ago.

Thanks for your replies, I can connect via the hard wire but it has not opened up the wi-fi. What I find annoying is the manual and the CD in general just have a sweeping assumption that I am going to install MS products, Win 10 in particular! This means that the driver installation disc may be useless for linux.

Another thing I have noticed is that most of the function buttons don’t work i.e. screen brightness and sound volume and there is no mention of a wireless button, F8 on my lovely MSI which unfortunately now is falling to bits.

Yes the Disk might be useless for linux as I don’t even see that specific driver at the Intel Site.

Please run this in the terminal (Copy Paste so there are no mistakes) and post the outcome of inxi -Fxz so that when help comes along this will get them started.
For some of these commands you will need to enter your Password, enter it, (but it will not show as you type) then just hit Enter.

Also, while connected via Ethernet get your self setup with a Firewall run sudo ufw enable in Terminal.

Then run sudo apt-get update && sudo apt-get upgrade to update your system. Or some just use the Update Manager, you will see the little Update “Shield” in the lower Panel to the right. It will have a Blue Exclamation Mark if there are Updates available, you will need to enter your password again and accept.

Then you could try the Wireless again. I would find out where the On button is.

Thanks NC, I have reinstalled from the disc and have updated to the latest but when I check the driver manager the box is empty! The update manager says that the computer is now totally up to date. Trouble is I don’t know what to look for regarding wifi drivers.

I shall try your commands in Terminal tomorrow and shall keep you posted. As I said before most of the Fn buttons are not working. There is no wireless on/off switch rather I have to make sure the comp is not in aeroplane mode, which it isn’t.

As the disc containing the various drivers seems to be only readable via Windows, it seems rather pointless Novatech selling a machine with no OS when in reality the only OS which seems to be compatible is an MS based one. Very annoying, i love Linux and all I want is a computer the does the job - I don’t know how they work consequently I don’t have the knowledge to sort out the dark secrets of software application, there surely must be a market for a straight forward system. Why is it so complicated? I would have thought that anyone buying a laptop would possibly, just possibly, want to connect it up to the internet wirelessly without having to sit a degree in advanced computer science.

Anyway, thanks for your replies and help, I’m afraid I’m no further forward - Novatech can have their laptop back with the season’s compliments! I shall have a go at fixing this old MSI - I really don’t want to go back to Mr Gates’ monopoly, no really!! :cry:

From Mint, can you open a terminal and post the output from these commands

lspci -vnn | grep -i net

and

rfkill list

and

iwlist scan

and

iwconfig

Hello Mark - Thanks for your offer to help, this is what I get in Terminal.
Regards.

graham@graham ~ $ lspci -vnn | grep -i net
01:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
graham@graham ~ $ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
graham@graham ~ $ iwlist scan
eth0 Interface doesn’t support scanning.

lo Interface doesn’t support scanning.

graham@graham ~ $ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

Which kernel is Mint using … what’s the output from:

uname -a

[EDIT]

Can you also post the output from:

dpkg -l | grep linux-firmware

For my reference:

Hello Mark:

graham@graham ~ $ uname -a
Linux graham 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
graham@graham ~ $ dpkg -l | grep linux-firmware
ii linux-firmware 1.127 all Firmware for Linux kernel drivers

Try downloading this and installing it:
http://cz.archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.127.19_all.deb

If you’re not sure how, connect via an ethernet cable, then open a terminal and run these commands in sequence

mkdir ~/firmware-updates

then

cd ~/firmware-updates

then

wget http://cz.archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.127.19_all.deb

then

sudo dpkg -i linux-firmware_1.127.19_all.deb

now reboot, and see if you’re able to get a wireless connection

That’s great Mark, now connected! However, I now have one more issue, the driver installation disc is only supported by Windows. I have just spoken to Novatech I told them that the reason I bought this machine with no OS was to avoid using Windows. Their tech guy says that he doesn’t know how to install compatible drivers to Clevo as used on this computer by way of Linux. At the moment most, not all, of the Fn buttons don’t work i.e. the screen brightness and so called ‘airplane’ functions are inoperative.

The drivers he says are needed are Clevo model W950JN. Is there a way round this, do you think?

Regards.

Can anyone help, please?

I’m so grateful to Mark for sorting out my connection problem but I’m still needing advice as to how to get the driver installation disc to work on Linux so that I can use the inoperative function keys, as itemised in my previous post, above. If the disc is useless is there another way to get the various Fn keys to respond?

Novatech were no help at all, they just said that they ‘only recognise Windows’ :frowning:

That driver disk is useless in Linux … it’ll only contain Windows drivers.

Really this topic should have been marked (SOLVED), and then a new topic with a descriptive title opened about the function keys.

Thank you - Advice taken.