Unable to mount Linux pendrive distribution

Mark,
Once again your knowllege astounds me.
I can not praise enough your patience and the speed of your responses to my questions.
This is quite a remarkable forum for newbies like me.
I will again take a look at all your suggestions and report back.
Fingers crossed.

I have tried setting the nodmraid option… as suggested.
The boot up screen had the words UBUNTU 11.04 ( No Graphic)
The Desktop looked a little different, without the applications indicated down the left hand side of the screen.
However the boot completed, successfully.
I await instructions on how to do an install using the nodomraid option.
This shouldn’t affect my windows 7 boot? Should it?

OK… now (hopefully) we’re getting somewhare :slight_smile:

I’m pretty sure that means there IS some RAID metadata on the drive, so we have 2 options -

  1. Remove the metadata

  2. Install Ubunutu using the nodmraid option, then make the option permanent.

But just to be sure the hard drive IS being detected properly WITH the nodmraid option… Can you boot back to Ubuntu using the nodmraid option … then open a terminal, and enter:

sudo fdisk -l

hit enter, then post the output back here.
(just for clarity, that’s SUDO FDISK -L but it MUST be all lower case)

FYI, you won’t get the left hand dock bar unless/until you have 3D capable drivers for your graphics card installed, or you install the unity-2d package… we’ll tackle that (if necessary) once we get 11.04 installed properly :wink:

11.04’s Unity interface uses compiz as the window manager, so requires 3D capable graphics drivers and card, if they aren’t present and enabled it defaults back to the “classic” GNOME 2.xx desktop, but will change to Unity when 3D graphics drivers are installed and available… or you install Unity 2D which doesn’t use compiz but rather a tweaked version of the metacity windows manager.

Send the output from the above command, and we’ll take it from there…

I also want you to boot 5 or 6 times using the nodmraid option, and check the output from the above command is the same each time.

As Requested:

Disk identifier: 0xb0000000

Device Boot Start End Blocks Id System
/dev/sda1 1 9 72261 de Dell Utility
/dev/sda2 10 1315 10485760 7 HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 1315 52075 407731200 7 HPFS/NTFS
/dev/sda4 52075 60802 70096896 83 Linux

Disk /dev/sdf: 139 MB, 139829760 bytes
255 heads, 63 sectors/track, 17 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x24246569

Device Boot Start End Blocks Id System
/dev/sdf1 1 3 16033+ c W95 FAT32 (LBA)
Partition 1 has different physical/logical beginnings (non-Linux?):
phys=(783, 254, 63) logical=(0, 161, 21)
Partition 1 has different physical/logical endings:
phys=(783, 254, 63) logical=(2, 160, 20)
ubuntu@ubuntu:~$

Just to clarify:

I used the nodmraid option and there was a dock bar.
I followed the nomodeset option as per the above link, this time there was no dock.
No boot issues using either option.
I will boot another six times while you check the above information.
I have saved a copy so can check that it remains constant.

Six straight boots - no issues
The output from the sudo fdisk - l command - identical

Am I getting confused here ? … Does it boot to a working desktop from your LiveUSB stick WITHOUT the nodmraid option ?

[EDIT]

I need these questions anwering before we go any further.

  1. Is the SATA mode in the system BIOS set to RAID, or IDE ? <— This is IMPORTANT

  2. Can boot the LiveUSB without the nodmraid option set ?

and if the answer to 2 is YES -
3) Boot without the nodmraid option set, and send the output from:

sudo fdisk -l

Sorry Mark if I am confusing you.

From the LiveCD:

  1. If I boot without the nodmraid option the computer boots about 40% of the time to a useable desktop. 60% of the time it hangs half way through the boot.
  2. If I do use the nodmraid option the computer has booted to a useable desktop on every occassion that I have attempted to do so.

When I get home tonight I will check the Bios for the RAID/IDE setting and the output in terminal (sudo etc.)
Sorry Again.

You’ll have to forgive me if I seem to be making you jump through hoops, but I’m just trying to be overly cautious so as not to harm your Win7 installation.

can you also boot to the LiveCD (preferrably with AND without the nodmraid option), and send the output from:

sudo dmraid -n

so I can see if there is any RAID metadata present on the hard drive.

[EDIT]

Is this a LiveCD (CDROM) or a LiveUSB (USB stick) … because if it’s a CDROM I’m a bit baffled why “sudo fdisk -l” is reporting that you have 2 hard dives
sda
and
sdf

and why sdf is only 139MB ???

Okay,
I am currently booting using a CD Rom LiveCD (Not the Pen drive I started with)
Looking at the BIOS the: SATA MODE is IDE

Using the standard boot from the disc (NOT nodmraid option) the terminal response was:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb0000000

Device Boot Start End Blocks Id System
/dev/sda1 1 9 72261 de Dell Utility
/dev/sda2 10 1315 10485760 7 HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 1315 52075 407731200 7 HPFS/NTFS
/dev/sda4 52075 60802 70096896 83 Linux

Disk /dev/sdf: 139 MB, 139829760 bytes
255 heads, 63 sectors/track, 17 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x24246569

Device Boot Start End Blocks Id System
/dev/sdf1 1 3 16033+ c W95 FAT32 (LBA)
Partition 1 has different physical/logical beginnings (non-Linux?):
phys=(783, 254, 63) logical=(0, 161, 21)
Partition 1 has different physical/logical endings:
phys=(783, 254, 63) logical=(2, 160, 20)

ubuntu@ubuntu:~$ sudo dmraid -n
no raid disks

Using the nodmraid option as you have requested.
again:
ubuntu@ubuntu:~$ sudo dmraid -n
no raid disks

So no RAID DISKS
HOPE THIS HELPS!

OK, I have no idea why the nodmraid option is helping because I expected either the BIOS to be set to RAID, or the hard drive to be marked as part of a RAID array… but who cares, it DOES help :wink:

Bit of info…

The LiveCD image has dmraid installed in case there are any RAID volumes defined… if it detects any RAID volumes it will install the drmraid package during a hard drive installation.

The good news is that it shouldn’t install dmraid when no RAID volumes are detected… so chances are the drmraid package will NOT get installed during the Ubuntu installation.


OK, I guess it’s time to try an install WITH the nodmraid option set…but during the install you need to set the mountpoint of sda4 to /
So…

Boot to the LiveCD, and select “Install Ubuntu”

When you get to this screen:
(Click picture to enlarge)
[smg id=1231 type=preview]

Select “Something else”

When you get to this screen:
(Click picture to enlarge)
[smg id=1241 type=preview]

Make sure the /dev/sda4 line has / in the “Mountpoint” column, and its “Type” is “ext4

If it IS ext4, but the mountpoint is empty, try clicking the “Change” button, and see if it will allow you to change the mountpoint to /

Then carry on with the Install.

If it won’t let you change the mountpoint, let me know and we’ll go from there.

If it installs properly, but fails to boot after you are told to reboot… let me know, and I’ll tell you how to set the nodmraid option now (it’s different from the LiveCD), and make it permanent.

Great - However I notice the graphic shows: /dev/sda6 swap
I have not setup a swap partition?
I press install now and get a warning about no swap and possible install issues because of it.
Do I proceed without swap or can you instruct me how to set up a swap partition?
My personal preference is to have a swap partition due to the size of the partition I have available?
Is this something to do with extended partitions, reference your earlier post?
I feel that I am expecting too much from you as you have already been very helpful.
Linux does however seems to be my computing future if we (you) can overcome my current issues.
Thanks again for your patience.

OK, boot to the LiveCD (with nodmraid set)…

When you get to this screen:
(Click picture to enlarge)
[smg id=1231 type=preview]

Select “Something else”.

When you get to this screen
(Click picture to enlarge)
[smg id=1261 type=preview]

Click on the /dev/sda4 line to highlight it, and click “Delete
(Click picture to enlarge)
[smg id=1271 type=preview]

Highlight the “free space” line, and select “Add
(Click picture to enlarge)
[smg id=1281 type=preview]

Now you need to create a “Logical” partition, but you need to subtract twice the size of your installed RAM to leave room for the swap partition we’ll create in a minute.

Lets say you have 2GB of RAM, so you want a 4GB swap partition… you’ll need to subtract 4000 from the figure displayed in the “New partition size in megabytes” field… so you want the settings as:

Type for new partition = Logical
New partition size in megabytes = <the figure already displayed, minus 4000>
Location for new partition = Beginning
Use as = Ext4 journaling file system
Mountpoint = /

Then click OK
(Click picture to enlarge)
[smg id=1301 type=preview]

Click on the “free space” again, and select “Add” again
(Click picture to enlarge)
[smg id=1311 type=preview]

And use these settings for the swap partition

Type for new partition = <won’t be asked, as there is no room for a primary partition so it assumes you want logical>
New partition size in megabytes =
Location for new partition = Beginning
Use as = swap area
Mountpoint = <will be greyed, and blank>

Then click OK
(Click picture to enlarge)
[smg id=1321 type=preview]

Check to see that the -
/dev/sda5 partition is Type = ext4, Mountpoint = /
and
/dev/sda6 partition is Type = swap

Also, make sure there is a tick in the “Format” box for /dev/sda5 (but ONLY sda5)
(Click picture to enlarge)
[smg id=1341 type=preview]

And finally, click “Install Now

If you have any questions, the time to ask is before you attempt this :wink:

Howzatt ??

Let me know how you get on.

YOU ARE THE MAN!
Thank you very much the install happened flawlessly.
One question, Do I “To summarize… you want to lock the version of grub-pc and grub-common” as previous.
Before I update?
Thanks Again :smiley:
KVB

No need, that applies to WUBI installs ONLY :slight_smile: … Update to your hearts content.

Just one thing!
Unable to boot to windows 7?

Are you not offered Windows 7 at boot time ?

The bottom option is windows 7 boot loader.
When i chose this option the computer just reloads the option screen and does not go to the windows loader.

OK, download this file, and put in your “Home” folder:
http://dl.dropbox.com/u/11876059/boot_info.sh

then open a terminal and run:

sudo bash ~/boot_info.sh

You should then find a file called RESULTS.txt in your home folder… can you post its contents here.

when you post them, be SURE to surround them with

 tags to maintain the formatting.

Since update of Ubuntu - unable to boot Ubuntu or Windows 7
Had to use LiveCD to post this response.
Will look at RESULTS.txt as suggested.
Sorry. but I now feel quite deflated?
Will use LiveCD to keep an eye on this forum

Why do you need to use the LiveCD ??

Can’t you boot Ubuntu ??

[EDIT]

What happens when you try to boot Ubuntu ?

Hi Mark,
When trying to boot Ubuntu as before the computer just hangs. No matter how long I wait the computer does not get to the desktop.
I have to press the On/Off button for five seconds wait for it to turn off. Then repress to start to computer.
I have to insert the live disk to get to any desktop now that I have updated Ubuntu.
Maybe a full format of my hard drive and a start from scratch will resolve my issues?