Unable to open .tar files on CentOS

Good afternoon,

I am trying to install WINE for centOS… I have installed the perquisites (I think, I am very new to Linux in general)

The guide then said :-

#cd /usr/src
#wget url ending in /wine-1.8.tar.bz2
#tar xjf wine-1.8.tar.bz2 (which is where I get the error)

[root@localhost src]# tar xjf wine-1.8.tar.bz2
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error is not recoverable: exiting now

From the digging I saw the main reason for this error was not being in the directory of the target file but I am…

[root@localhost src]# pwd
/usr/src
[root@localhost src]# ls -l
total 12
drwxr-xr-x. 3 root root 4096 Dec 22 20:47 debug
drwxr-xr-x. 3 root root 4096 Dec 27 15:39 kernels
lrwxrwxrwx. 1 root root 34 Dec 27 15:11 vboxhost-5.0.12 → /usr/share/virtualbox/src/vboxhost
-rw-r–r–. 1 root root 51 Dec 27 15:41 wine-1.8.tar.bz2

Anyone with any suggests on what the cause of this may be? Something as simple as missing a program to open the file type etc?!

Thanks!

maybe the wget didn’t complete correctly … try:

cd /usr/src
rm -v wine-1.8.tar.bz2
wget http://dl.winehq.org/wine/source/1.8/wine-1.8.tar.bz2
tar xjf wine-1.8.tar.bz2

if you still get the same error, try decompressing it with bzip2 and piping the output to tar:

bzip2 -d wine-1.8.tar.bz2 | tar vxf wine-1.8.tar