UNINSTALLED FIREFOX

Hi
Can anyone help with my problem, in error I deleted firefox from my acer aspire 1 now when I switch my computer on all I get is a blank screen, no desktop icons, nothing just a little search bar that does’nt let me do anything. The reason I deleted it was that my internet icon was’nt working so I read on another website to do this and now I have ruined my computer. Any advice or help would be greatly appreciated.

Does anything appear if you hit these 2 keys at the same time… Alt+F2 ?

You might want to take a look at this posting:
http://linuxforums.org.uk/netbooks/messed-up-firefox-4-installation-on-an-acer-aspire-one/msg47821/#msg47821

Ignore the bit above the EDIT, that part doesn’t apply to you.

That is an “active” topic, so whether you want to wait till the instructions have been tested before trying them is up to you… they should be safe, as you are only installing/reinstalling packages from the official repo’s, but you attempt them at your own risk.

There are links to Acer Aspire One Recovery DVD images and instructions on their use further up that topic too… it would be a good idea to get those first, and check they work, before trying the other instructions.

[EDIT]

Further Info…

See this posting first:
http://linuxforums.org.uk/netbooks/messed-up-firefox-4-installation-on-an-acer-aspire-one/msg47881/?topicseen#new

If that gets you back up and running… DO NOT uninstall Firefox 2 again… follow these instructions to install Firefox 4:
http://linuxforums.org.uk/netbooks/install-firefox-4-on-an-acer-aspire-one-running-linpus-lite-linux/


Nearly forgot to mention… there are 2 possible ways for you to open a terminal to enter that command.

  1. Hit Alt+F2, in the resulting window enter terminal and click run.

if you are unable to do this because of the missing packages… try this -

  1. Use the Search Bar to search for terminal and run it from there.

Can you please let me know if this works, so I can pass the info on to others that may have the same issue… Thanks.

hi mark
my friend has my computer at the moment I will try what you recommend and let you know how I get on thanks fo replying so quickly, hope what you recommends works.

There are 3 of you in the same boat now… seems likely there will be more.

Hi Mark
Nothing happens when I use Alt + F2, and tried to follow link instructions but still no joy. When you say type terminal/run where am I actually typing these words, I am a real novice at this.

Thanks
Lorraine

I’m afraid I have some bad news for you… there doesn’t seem to be any way to fix Linpus Lite once Firefox 2 has been uninstalled… you may want to read this topic to see why:
http://linuxforums.org.uk/netbooks/messed-up-firefox-4-installation-on-an-acer-aspire-one/

in particular, check out the last few postings on that topic.

The good news… there are however instructions on how to open a terminal, and other applications, including how to recover your documents, and links to the recovery DVD imaages and how to use it, which should put your AA1 back to how it came out of the factory.

[EDIT]

Since you posted last, I’m afraid we’ve discovered the command mentioned earlier doesn’t work.

If there’s anything you don’t understand, or if you have any questions… just ask.

Hi Mark
What is RPM, my computer does not have a cd drive therefore how do I restore back to factory settings, cant use backup/restore disc.

Thanks
Lorraine

Managed to re-install 6 files, however couldnt re-install ame, smanager and java-1.7.0icetead-plugin and nautilus manager is not runing.

Thanks Lorraine

First of all, how did you get the xfdesktop and xfdesktop-acer packages reinstalled ??

The above is an important question, so please answer it if you can.


RPM = Redhat Package Management system.

See this posting for instructions on how to put the recovery DVD onto a USB memory stick (or an SD card), then boot from it to run the reinstallation:
http://linuxforums.org.uk/netbooks/messed-up-firefox-4-installation-on-an-acer-aspire-one/msg47701/#msg47701
There’s even a video :wink: … but it will require access to another PC.

Links to the RecoveryDVD images are in the same post… but if you still have the DVD that came with the AA1, use that rather than download the one(s) from the link.


That’s my point… they CANNOT be reinstalled, because they don’t exist in the repositories, and CANNOT be built by what IS available in the repos.

Also… the 6 packages you just reinstalled… they are now the wrong versions :o

nautilus won’t be running because it isn’t even (and never was) part of Linpus Lite :o

Here’s the problem

  1. Uninstalling Firefox-2 from Linpus Lite as used on the AA1 also removes 8 files required to run your desktop.

  2. Linpus Lite doesn’t have its own software repositories, but instead uses the Fedora 8 repos, but it also has a lot of custom packages which are needed to reinstall the desktop.

BUT

  1. The custom packages AREN’T in the Fedora repositories… they are available online however.

BUT

  1. The online RPM’s aren’t RPM’s at all (so can’t be directly installed)… they’re SRC.RPM’s (.src.rpm’s need to be “built” into installable .rpm’s)

  2. Linpus Lite doesn’t contain the software to build the src.rpm’s into installable .rpm’s

and lastly, and this is the show stopper…

  1. You can’t install the packages required to build the src.rpm’s… because the Fedora 8 repo’s don’t contain new enough versions of the required packages and/or the dependencies.

So it looks like half of the system binaries were originally built using a different environment (FC9 maybe ?)

What happened when you reinstalled those packages was Linpus went online and downloaded the packages from the only source available to it, which was the Fedora 8 repositories… the software that it COULD find in the Fedora repos (some of it) was the wrong version (ie NOT the Linpus customised package versions required), and the software it COULDN’T install, well that’s because that software isn’t even IN the Fedora repos.

Does that make sense now ?

IMHO, you’re wasting your time looking for a fix… Acer/Linpus screwed up “big time” with this.

Hi Mark
So is that my computer on the scrapheap, can I not even convert it to windows or something else - havent got a clue .

NO… you can reinstall Linpus Lite… see here for the image download links:
http://linuxforums.org.uk/netbooks/messed-up-firefox-4-installation-on-an-acer-aspire-one/msg47701/#msg47701#

Just download the ISO image to a another PC, burn it to a DVD, and follow the instructions in the video to put it on a USB stick for installation onto the AA1)

That will put it back to how it came out of the factory. (you will loose any files you have on it though, so if there’s anything on there you CAN’T afford to loose, you will need to back them up first… maybe with Linux LiveUSB)

Or

you could install a different Linux distribution, like Ubuntu, or Mint, or Jolicloud etc.

Or

Yes you could even install Windows XP, but you’d have to ask elsewhere for how to do that, and it isn’t easy… and if your AA1 is an SSD model, there won’t be much room left for applications etc. and it will be slower, and cost you more, and be susceptible to viruses/malware… the list of reasons NOT to install Windows goes on, and on…

But the choice is yours… the AA1 is NOT broken :slight_smile: … do NOT scrap it, it just needs a reinstall.