Update Manager not refreshing in Mint 16 Mate

Hi guys,

I’m getting the message “Error in checkAPT.py, could not refresh the list of packages” when my Update Manager attempts to refresh. Been like that for a few days now. Any suggestions?

Followed the instructions given in another thread here (below) but still not updating, same error report.

sudo apt-get clean
sudo mv -v /var/lib/apt/lists /var/lib/apt/lists.broken
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get update

Does it by any chance mention medibuntu in the list of packages? If so then you need to remove any entires with medibuntu from your sources list as that package is discontinued.

Open a terminal and post any errors reported from runniing:

sudo apt-get update

Dave, nothing about medibuntu, no. Cheers anyway.

Thanks Mark. I get:

Err http://ppa.launchpad.net saucy/main Sources                                
  404  Not Found
Err http://ppa.launchpad.net saucy/main i386 Packages                          
  404  Not Found

Also, at the end (similar):

W: Failed to fetch http://ppa.launchpad.net/ralf.hersel/rhersel-ppa/ubuntu/dists/saucy/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ralf.hersel/rhersel-ppa/ubuntu/dists/saucy/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

What’s the output from:

ls -a /etc/apt/sources.list.d

It’s okay, Mark, I disabled the “saucy” references in the Package Manager and now the Update Manager works fine. I read somewhere that the “saucy” repositories aren’t needed for Ubuntu/Mint. I wonder where they came from? :o

At some point you’ve added this PPA
https://launchpad.net/~ralf.hersel/+archive/rhersel-ppa

that was the one causing you problems, as it has no packages for “saucy”

All you needed to do was disable/remove that PPA