Updating my Dell Inspiron Mini Netbook

I’ve a little netbook that has Mint on it and a very small SSD. It does work but can’t take any more updates and is a bit slow to boot up and load up web pages. I think it must need more memory and perhaps RAM too. Obviously the SSD is too small ( in an old post Mark had said that it was working to its limit)- but I dunno if I could get a bigger, compatible SSD. Didn’t seem to find one when I looked on a computer update site. I might then have to go for an HD but hope that wouldn’t make it slower. How can I find my system specs to post them here so you nice guys would kindly give me advice on what would be the best for the inspiron mini?

It’s a useful little machine as I can use my scanner and Maxtor portable HD on it which I can’t do on my Chromebook ( which is my main laptop). Also I could buy an external CD/DVD drive and plug that into it too if I needed to create boot CDs in the future.

System specs:

inxi -Fz

Hard drive (or SSD) info:-

If it’s an SATA device (on /dev/sda):

sudo hdparm -I /dev/sda

Thanks Mark, I will switch it on later and give you the results.

Netbook has lost all my passwords and chromebook saves em, so forgot my forum p/w- sent two requests to have new log in emailed to me but had nothing

Had to email this to myself and paste via Chromebook.

karij@karij-Inspiron-1011 ~ $ inxi -Fz
System: Host: karij-Inspiron-1011 Kernel: 3.2.0-23-generic i686 (32 bit) Desktop: N/A Distro: Linux Mint 13 Maya
Machine: System: Dell (portable) product: Inspiron 1011 version: A06
Mobo: Dell model: CN0Y53 version: A06 Bios: Dell version: A06 date: 07/29/2009
CPU: Single core Intel Atom CPU N270 (-HT-) cache: 512 KB flags: (nx sse sse2 sse3 ssse3)
Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version: 1.4 Mesa 8.0.4
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.24
Network: Card-1: Broadcom BCM4312 802.11b/g LP-PHY driver: wl
IF: wlan0 state: up mac:
Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
IF: eth0 state: down mac:
Drives: HDD Total Size: 8.0GB (58.1% used) 1: /dev/sda SAMSUNG_SSD_UM41 8.0GB
Partition: ID: / size: 6.5G used: 4.4G (71%) fs: ext4 ID: swap-1 size: 1.06GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 136 Uptime: 19 min Memory: 269.8/992.5MB Client: Shell inxi: 1.7.33
karij@karij-Inspiron-1011 ~ $

device, with non-removable media
Model Number: SAMSUNG SSD UM410 Series 2.5" 8GB
Serial Number: DCA0M00940SE940A3673
Firmware Revision: VAM12D1Q
Standards:
Used: ATA/ATAPI-7 T13 1532D revision 1
Supported: 7 6 5 4
Configuration:
Logical max current
cylinders 15525 15525
heads 16 16
sectors/track 63 63

CHS current addressable sectors: 15649200
LBA user addressable sectors: 15649200
LBA48 user addressable sectors: 15649200
Logical/Physical Sector size: 512 bytes
device size with M = 10241024: 7641 MBytes
device size with M = 1000
1000: 8012 MBytes (8 GB)
cache/buffer size = unknown
Nominal Media Rotation Rate: Solid State Device
Capabilities:
LBA, IORDY(can be disabled)
Standby timer values: spec’d by Standard, no device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Recommended acoustic management value: 128, current value: 0
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* SMART feature set
Security Mode feature set
* Power Management feature set
* Write cache
* Look-ahead
* Host Protected Area feature set
* WRITE_BUFFER command
* READ_BUFFER command
* NOP cmd
* DOWNLOAD_MICROCODE
SET_MAX security extension
Automatic Acoustic Management feature set
* 48-bit Address feature set
* Device Configuration Overlay feature set
* Mandatory FLUSH_CACHE
* FLUSH_CACHE_EXT
* SMART error logging
* SMART self-test
* General Purpose Logging feature set
* WRITE_{DMA|MULTIPLE}_FUA_EXT
* 64-bit World wide name
* WRITE_UNCORRECTABLE_EXT command
* Segmented DOWNLOAD_MICROCODE
* Gen1 signaling speed (1.5Gb/s)
* Gen2 signaling speed (3.0Gb/s)
* Host-initiated interface power management
* Phy event counters
Device-initiated interface power management
* Software settings preservation
Security:
Master password revision code = 65534
supported
not enabled
not locked
frozen
not expired: security count
supported: enhanced erase
6min for SECURITY ERASE UNIT. 6min for ENHANCED SECURITY ERASE UNIT.
Logical Unit WWN Device Identifier: 50000f0056414431
NAA : 5
IEEE OUI : 0000f0
Unique ID : 056414431
Checksum: correct
karij@karij-Inspiron-1011 ~ $

I will have to create a new log in so I can log in on netbook too.It doesn’t remember one p/w!

Well pretty much any 2.5" SATA SSD should fit and work

and you can upgrade the RAM to 2GB

Both can be found here (amongst many other places)


When you say the Inspiron isn’t remembering your passwords … do you mean just the web browser ?

Well that is good to know. Thanks Mark. Will be awhile before I can afford to get it a new SSD, but maybe I could get the extra RAM in the meantime and have Peppermint 6 added on it for now?

Yeah, Firefox’s memory is worse than mine on the Inspiron Mini at the moment lol.

Oh I wanted to mention- I love Tux Race game I have on it (Mint)- it’s funny and cute but on the now dead Dell laptop which had Peppermint 6 there didn’t seem to be that game but a new Tux game but when I tried to get it from the package manager the laptop crashed and it would not download. I want to keep my Tux game!

In Firefox, go to

Edit > Preferences > Security (tab)

and make sure “Remember site logins” is ticked.


Which version of Mint were you using ?

Hello Mark this is Melissa, sorry I could not log in with my usual account as the charger for my chromebook is broken and I have requested a pass word link to make a new password about 20 times but no link was emailed to me. I don’t know what version of Mint I haver sorry. Forgfive my bads typingf but this screen is so tiny I can hadrly see the words. I have tried to update firefox but it has now stopped the flash and so I cannot watch any vids on yout tube and also I tried to install chrome browser but that doesn’t wortkj eithewr. please can you help me?