Upgrading from 11.04 to 11.10 on Dell D505 - Solved

My Dell D505 has V11.04 installed.
I tried to install V11.10 from a disk but it turns out that the display/driver is not adequate. I tried the Dell website and forums for suitable upgrades but found no joy.
Unfortunately; now that a few files have been transferred from the V11.10 disk to the laptop it keeps downloading files for V11.10 but can’t install them, of course.
How can I stop this? Apart form buying a modern laptop!

You’ll need to explain what “it keeps downloading files for V11.10 but can’t install them” … do you mean the update manager ?

If you mean “is there a way to back out of an upgrade ?” … not easily :frowning:

I’d be more interested in knowing more about this, “it turns out that the display/driver is not adequate” … what told you that, and when.

What graphics card do you have ?

EXACT error messages are always helpful :slight_smile:

You are right: exact messages would be more helpful.
I shall spend some time writing it up carefully and come back to you.
I’m not doing too well today, am I?

Heh … see my last reply here:
http://linuxforums.org.uk/index.php?topic=9911.msg71125#msg71125
:wink:

Dell D505 V11.10 upgrade problem (Italics indicate computer response)

History: V10.40 installed and working. Loaded V11.10 disc to upgrade.
System began to install then stopped after installing a few files. There was a message saying that the upgrade could not proceed because the video driver was inadequate (I didn’t copy the precise wording), but it did say that it couldn’t download the following packages:
rsyslog (209kB)
fakeroot (79kB)
patch (84kB)
After that there were always files that would not install, so:

26/2/12 Started Update Manager:
“New Ubuntu release ‘V11.10’ is available.
35 updates have been selected. The updates have already been downloaded, but not installed.”

Clicked “Install Updates”
“Failed to download package files – Check your internet connection” (which was OK).

Bright idea!..

keith@keith-Latitude-D505:~$ sudo apt-get upgrade
[i][sudo] password for keith:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages have been kept back:
python-glade2
The following packages will be upgraded:
evince evince-common fakeroot firefox firefox-globalmenu
firefox-gnome-support firefox-locale-en libcurl3-gnutls libevdocument3
libevview3 libicu44 libpng12-0 libssl0.9.8 libusbmuxd1
linux-headers-2.6.38-13 linux-headers-2.6.38-13-generic
linux-image-2.6.38-13-generic linux-libc-dev openssl patch
python-launchpadlib python-software-properties rsyslog software-center
software-properties-gtk thunderbird thunderbird-globalmenu update-manager
update-manager-core usbmuxd x11-common xorg xserver-xorg
xserver-xorg-input-all xserver-xorg-video-all
35 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/87.8 MB of archives.
After this operation, 1,520 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Media Change: Please insert the disc labelled
‘Ubuntu 11.10 Oneiric Ocelot - Release i386 (20111012)’
in the drive ‘/media/cdrom/’ and press enter

Err cdrom://Ubuntu 11.10 Oneiric Ocelot - Release i386 (20111012)/ oneiric/main patch i386 2.6.1-2
Unable to stat the mount point /media/cdrom/ - stat (2: No such file or directory)
Failed to fetch cdrom:[Ubuntu 11.10 Oneiric Ocelot - Release i386 (20111012)]/pool/main/p/patch/patch_2.6.1-2_i386.deb Unable to stat the mount point /media/cdrom/ - stat (2: No such file or directory)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? [/i]

Keith@keith-Latitude-D505:~$ sudo apt-get --fix-missing upgrade
Which worked!

Tried to load V11.10 from the disc again.
The system did not attempt to load - possibly because of earlier previous attempt.

Started Wubi.:
Archive Manager reports:
[i]“An error occurred while loading the archive.
Archive: /media/Ubuntu 11.10 i386/wubi.exe
[/media/Ubuntu 11.10 i386/wubi.exe]
End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive.
zipinfo: cannot find zipfile directory in one of
/media/Ubuntu 11.10 i386/wubi.exe or
/media/Ubuntu 11.10 i386/wubi.exe.zip,
and cannot find
/media/Ubuntu 11.10 i386/wubi.exe.ZIP, period. “

Tried upgrading via the web:
Apply a diff file to an original patch (size 84kB)
CD/DVD ‘Ubuntu 11.10_Oneiric Ocelot_-Release i386 (20111012)’ is required.
Please insert the above CD/DVD into the drive ‘media/cdrom’ to install the software packages from it. [/i]
Did that - ~OK
Invitation to upgrade to 11.10 – accepted via web download @ 29kB/sec!

Your graphics hardware may not be fully supported in Ubuntu 11.10
The support in Ubuntu 11.10 for your Intel graphics hardware is limited and you may encounter problems after the upgrade. Do you want to continue with the upgrade?

This was the message that I failed to report to you the first time.
Declined pending your advice.

What graphics card do you have :

Send the output from:

sudo lshw -C display

and

lspci -vnn | grep VGA

lshw -C display
WARNING: you should run this program as super-user.
*-display:0
description: VGA compatible controller
product: 82852/855GM Integrated Graphics Device
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:11 memory:f0000000-f7ffffff memory:faf80000-faffffff ioport:c000(size=8)
*-display:1 UNCLAIMED
description: Display controller
product: 82852/855GM Integrated Graphics Device
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0
resources: memory:e8000000-efffffff memory:faf00000-faf7ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

lspci -vnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])

A quick search seems to suggest the i915 driver DOES work in 11.10 … I’m guessing that message is displayed to let you know that Unity 3D won’t work with the i915 driver, but Unity 2D should be installed and work as it’s the default “fallback” graphics mode for 11.10.

As usual some people suggest a fresh install worked where an upgrade didn’t.

If I were you, I’d backup anything you can’t afford to loose (just in case) … then carry on with the upgrade … but at the end of the day it’s your call.

Thank you, Mark. Since I don’t use the Unity desktop, I shan’t feel left out.
I’ll try the upgrade now (BT permitting) and let you know how it goes.
The laptop is for playing with and I have nothing to lose.

In 11.10 the old Gnome 2.x desktop you are used to isn’t installed by default (hence the message), so the “fallback” graphics mode is Unity 2D … it IS however possible to install the gnome-session-falback package which will give you an interface very similar to Gnome 2.x (think of it as Gnome 3 emulating the Gnome 2.x interface).

Unity 2D (installed by default) and Gnome Session Fallback (not installed by default) should both work with the i915 driver.

See here:
http://www.liberiangeek.net/2011/08/return-to-ubuntu-classic-desktop-in-ubuntu-11-10/

I remembered the gnome-fallback command from my PC upgrade and had made a note of it!
I had to abandon upgrading via the disc and do it via the web. It worked fine - and took more than 6hrs!
Many thanks for your help - as usual.

No worries :slight_smile:

Yeh, a fresh install is usually quicker, though more work … problem with an upgrade is how p*ssed off you feel when it fails after 6 hours and you end up having to do a fresh install anyway :o

Glad it went well for you though.