Upgrading to 64bit Mint

Hi All. I’ve decided to have a go at upgrading my machine from 32bit to 64 bit (currently Mint 17 32bit, going to Mint 18 64bit).

I currently have installed a 160Gb HDD with Mint 17 on it and a 40Gb slave HDD that is blank (i.e. unallocated space). In preparation, I’ve downloaded the Mint 18 iso and burned it to disk. This boots ok and works as expected so I expect the install to be the same.

My plan is to install Mint 18 on the 40Gb HDD, move everything over to it from the 160Gb HDD then, if all goes well, wipe the 160Gb HDD and do a fresh install of Mint 18 on that. (The current data only takes up a fraction of the available space on the 160Gb HDD so I hope will not be an issue moving it to a smaller drive). If all goes well I’ll move everything back again.

Q Is this method feasible or appropriate? (My fear is losing the data and messing up the settings of 2 users (self and wife - and I really don’t want to risk the wrath of Khan!!) Or would it be better/easier to create a partition and move the data only over? If I could preserve the settings also it would save a lot of work.

Q Can the whole drive be cloned/copied and moved over? I think there is scope to shrink the partition on the 160Gb drive to make it ‘appear’ smaller than 40Gb but I daren’t try that without help!!

I’m not fussed about Mint 18 either - it’s just the latest incarnation - if a straight change to Mint 17 64bit is better then that would be ok too.

Thanks in advance for your thoughts/advice/opinions etc :wink:

Rich

Hi Rich,

Don`t know if this will be of help but here we go.

I back up my system with FSArchiver to a hard drive and a usb drive, belt and braces approach.

I have also just come across Aptik which is supposed to be a back up and restore of packages and software.

http://www.teejeetech.in/2014/01/introducing-aptik.html

I havent tried Aptik as a restoration as yet, but I have used the back up part and that seems to have gone OK. FSArchiver I use on a regular basis and it works like a charm. Mainly used after trying out different packages that dont work or I feel that isn`t right for me. Also used after a large(ish) update.

Anyway, that`s a couple of my thoughts, good luck.

If you’re worried about installing on the wrong drive and loosing data, why not

a) format the 40GB with a single data partition

b) Copy your user files (docs, piics, etc.) to it.

c) Once you’re sure they’re there and safe … shut down and remove that drive entirely (putting it aside for now).

d) Install Mint 18 64bit allowing the installer to wipe the 160GB drive and “replace” Mint 17.

e) once installed, shut down.

f) reattach the 40GB drive, and copy the user files back to the 160GB drive.

g) decide what you want to do with the 40GB … here’s a suggestion:
https://forum.peppermintos.com/index.php/topic,1835.0.html

Hi - and thanks for the replies. I’ve had a couple of issues that you may be able to help with?

Briefly - I’ve removed the 40GB drive as there were problems trying to install Mint 18 to it. So, my next thought is to dual-boot Mint 17 and 18 on the same (160GB) drive. I prefer to try out a full install of 18 on a HDD firstly a) to see if it works and b) to see if there are any performance advantages. I know from the live session of 18 that it will install ok alongside 17 by shrinking the drive and it says no personal data will be affected BUT I need to backup 17 first, just in case.

In preparation, I cloned the entire disk image of 17 (via Clonezilla) on to a 500GB USB 2 external HDD (Seagate GoFlex) as a backup for 17. All seems ok with the operation.

Issue 1 - When I plug in the Seagate, it doesn’t mount (it did mount ok before, when it was a blank drive). Is it supposed to mount? Disk manager sees it and shows the partitions and labels etc. I assume that, if I need to reinstall/repair 17 from that drive, I would use Clonezilla to reverse the process?

Issue 2 (coincidence?) - for some reason, after cloning, when I fire up 17 the wired internet connection wouldn’t work, ditto wireless when I plugged in a dongle. I checked the connection details and all seemed ok there. I re-booted the router. (Other devices, phones etc work ok). I re-booted the computer and the connection worked for about 30 seconds, then dropped. I rebooted again and this lasted several minutes. Is it possible that cloning the disk has altered something in the Network Manager? (I realise this topic may need a separate post)

Thanks in advance

Rich

  1. The best way to test a backup would be to try booting from it.

  2. NO, cloning a drive should not change anything on the source drive.

Thanks Mark - I’ll try booting my laptop from the backup - my main computer will only boot from HDD or CD/DVD unfortunately.

Can you advise please re the internet connection? I had to reboot again to get it to fire up for this session. At present it is running but may drop out at any time. I suspect it’s Mint’s Network Manager at fault as it’s the same with wired and wireless connections. Is there a work-round/ reinstall or alternative Manager that might stabilise it?

Thanks again

Rich

What’s the output from:

sudo lshw -C network

and

ifconfig

and

iwconfig

and

iwlist scan

and

rfkill list

and

sudo lspci -vnn | grep -i net

As requested

*-network
description: Ethernet interface
product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 3
bus info: pci@0000:02:03.0
logical name: eth0
version: 10
serial: 00:15:58:c1:7c:f4
size: 100Mbit/s
capacity: 100Mbit/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.0.2 latency=32 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
resources: irq:16 ioport:ee00(size=256) memory:fddff000-fddff0ff

Just a thought here - would this device work if I install Mint 18 64 bits on this computer?

ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:58:c1:7c:f4
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::215:58ff:fec1:7cf4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:43296 errors:8 dropped:38 overruns:5 frame:0
TX packets:29592 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44949068 (44.9 MB) TX bytes:3122872 (3.1 MB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:2062 errors:0 dropped:0 overruns:0 frame:0
TX packets:2062 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:205254 (205.2 KB) TX bytes:205254 (205.2 KB)

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

richard@richard-Ei-306 ~ $ rfkill list
richard@richard-Ei-306 ~ $ Nothing returned

sudo lspci -vnn | grep -i net
02:03.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)

The 32bit network width has nothing to do with the CPU/Memory bus architecture.

Why am I seeing no wireless hardware ?

There is no on board wireless on this desktop. It’s a vintage XP machine that I converted to Linux about 5 years ago and still sings along merrily - until now that is! It sits, literally, 3 feet from the router so a cable connection is fine. I do have a wireless dongle that does work well with it but I only use that, very rarely, for testing. It was the cable connection that kept dropping (and then the dongle when I tried that) but as of now seems to have settled down. It was definitely something amiss with this m/c as our phones and other laptops connect through the same router and they were fine.

I’m thinking this might be 2 separate problems.

a) maybe the cable itself, or the port it’s plugged into (PC or router).
and
b) a separate wireless issue, maybe the drivers.

Do you still need to troubleshoot this ? … and if so, which first ?

Hi Mark - this issue seems to have cured itself ??? so can be shelved for now, and thank you.

Going back to the main topic -

I installed Mint 18 alongside 17 as a dual-boot as per the instructions on the install disk. This seemed to go ok until I restarted and got a ‘no partition’ error. I found your instructions for re-installing Grub (May 2014) and that worked ok. Grub ‘sees’ both M17 and M18. M17 boots ok and a quick check shows all appears intact. M18, however doesn’t boot - it’s the old ‘black screen’ problem again which IIRC is to do with the NVidia graphics. There is a signal to the monitor, the green light is on, but nothing on the screen itself. I’ve tried a few methods to sort it (nomodeset, no splash etc) but no joy!

There’s no M18 ‘Recovery’ option in the Grub list - just an ‘Advanced Settings’ one so I can’t find a way to get to a proper edit screen.

GParted (from the live session disk) shows the drive divided into 2 equal parts with 17 on the 1st one and 18 on the 2nd. But 18 only lists 2 partitions and I’m wondering if it has actually installed fully? I used the slider to shrink the space and then let the installer ‘get on with it’ rather than manually partition it - it’s worked fine that way before.

Any advice would be great!

Cheers

Rich

You tried nomodeset on the Mint 18 kernel boot line ?

From Mint 17, what’s the output from:

sudo fdisk -l

and

sudo blkid

and the contents of

gedit /boot/grub/grub.cfg

If Mint 17 uses some other text editor than gedit, you’ll need to adjust that last command accordingly.

richard@richard-Ei-306 ~ $ sudo fdisk -l
[sudo] password for richard:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001ba51

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 980991 489472 83 Linux
/dev/sda2 983038 312580095 155798529 5 Extended
/dev/sda5 983040 152638097 75827529 83 Linux
/dev/sda6 304693248 312580095 3943424 82 Linux swap / Solaris
/dev/sda7 152639488 304689151 76024832 83 Linux

Partition table entries are not in disk order
richard@richard-Ei-306 ~ $

richard@richard-Ei-306 ~ $ sudo blkid
/dev/sda1: UUID=“bd41cb59-1633-4957-8b92-e85530ad0662” TYPE=“ext4”
/dev/sda5: UUID=“fd7a3f3e-5d95-48cb-ab1b-0a7415cfd185” TYPE=“ext4”
/dev/sda6: UUID=“eed0839a-eded-443d-91b6-f1c239008fe0” TYPE=“swap”
/dev/sda7: UUID=“1d962daa-7189-4b02-876d-238a8e6cc474” TYPE=“ext4”
richard@richard-Ei-306 ~ $

gedit /boot/grub/grub.cfg - nothing returned in the config file, page is blank

(this appeared in terminal though - ** (gedit:3366): WARNING **: Could not write gedit state file: Failed to create file ‘/home/richard/.gnome2/gedit/gedit-2.O2LG4Y’: Permission denied)

I tried the same command but with ‘sudo’ before it but with the same result.

gedit /boot/grub/grub.cfg - nothing returned in the config file, page is blank

Well that makes no sense :-\

What happens if you run:

sudo update-grub

then

gedit /boot/grub/grub.cfg

is it still blank ?

Ha! That’s better!

sudo update-grub found M18 ok then -

gedit /boot/grub/grub.cfg returns

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  fd7a3f3e-5d95-48cb-ab1b-0a7415cfd185
else
  search --no-floppy --fs-uuid --set=root fd7a3f3e-5d95-48cb-ab1b-0a7415cfd185
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_GB
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=10
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=10
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="$1"
	if [ "$1" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Linux Mint 18.1 Serena (18.1) (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-1d962daa-7189-4b02-876d-238a8e6cc474' {
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  1d962daa-7189-4b02-876d-238a8e6cc474
	else
	  search --no-floppy --fs-uuid --set=root 1d962daa-7189-4b02-876d-238a8e6cc474
	fi
	linux /boot/vmlinuz-4.4.0-53-generic root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro quiet splash $vt_handoff
	initrd /boot/initrd.img-4.4.0-53-generic
}
submenu 'Advanced options for Linux Mint 18.1 Serena (18.1) (on /dev/sda7)' $menuentry_id_option 'osprober-gnulinux-advanced-1d962daa-7189-4b02-876d-238a8e6cc474' {
	menuentry 'Linux Mint 18.1 Cinnamon 64-bit (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.4.0-53-generic--1d962daa-7189-4b02-876d-238a8e6cc474' {
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos7'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  1d962daa-7189-4b02-876d-238a8e6cc474
		else
		  search --no-floppy --fs-uuid --set=root 1d962daa-7189-4b02-876d-238a8e6cc474
		fi
		linux /boot/vmlinuz-4.4.0-53-generic root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro quiet splash $vt_handoff
		initrd /boot/initrd.img-4.4.0-53-generic
	}
	menuentry 'Linux Mint 18.1 Cinnamon 64-bit, with Linux 4.4.0-53-generic (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.4.0-53-generic--1d962daa-7189-4b02-876d-238a8e6cc474' {
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos7'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  1d962daa-7189-4b02-876d-238a8e6cc474
		else
		  search --no-floppy --fs-uuid --set=root 1d962daa-7189-4b02-876d-238a8e6cc474
		fi
		linux /boot/vmlinuz-4.4.0-53-generic root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro quiet splash $vt_handoff
		initrd /boot/initrd.img-4.4.0-53-generic
	}
	menuentry 'Linux Mint 18.1 Cinnamon 64-bit, with Linux 4.4.0-53-generic (upstart) (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.4.0-53-generic--1d962daa-7189-4b02-876d-238a8e6cc474' {
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos7'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  1d962daa-7189-4b02-876d-238a8e6cc474
		else
		  search --no-floppy --fs-uuid --set=root 1d962daa-7189-4b02-876d-238a8e6cc474
		fi
		linux /boot/vmlinuz-4.4.0-53-generic root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro quiet splash $vt_handoff init=/sbin/upstart
		initrd /boot/initrd.img-4.4.0-53-generic
	}
	menuentry 'Linux Mint 18.1 Cinnamon 64-bit, with Linux 4.4.0-53-generic (recovery mode) (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.4.0-53-generic-root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro recovery nomodeset-1d962daa-7189-4b02-876d-238a8e6cc474' {
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos7'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  1d962daa-7189-4b02-876d-238a8e6cc474
		else
		  search --no-floppy --fs-uuid --set=root 1d962daa-7189-4b02-876d-238a8e6cc474
		fi
		linux /boot/vmlinuz-4.4.0-53-generic root=UUID=1d962daa-7189-4b02-876d-238a8e6cc474 ro recovery nomodeset
		initrd /boot/initrd.img-4.4.0-53-generic
	}
}

set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Note:
The entry highlighted in red does not appear in the Grub menu list when booting. There is nothing shown after the ‘Advanced Options’ entry.
When attempting to boot M18, there is literally a blank screen - not even a flashing cursor.

Rich

I take it Mint 17 is listed in the GRUB menu ?

Yes, as first option and boots normally as before.

Well as Mint 17 isn’t in that grub.cfg at all I’m guessing it’s now using GRUB from Mint 18 … which may make fixing a little more awkward.

Do you know how to add the “nomodeset” option to the Mint 18 kernel boot line (for a single boot) ?


And (from Mint 17) can you post the output from:

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

richard@richard-Ei-306 ~ $ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
BIOS
richard@richard-Ei-306 ~ $ - no output returned from this command

I’ve never attempted a dual-boot before, I’ve always used 2 separate drives to prevent screw-ups! ;D For this one, I simply shrank the M17 drive to a 50/50 split and let the installer do it’s thing on the 2nd part. I thought that I read somewhere that on a dual-boot it’s the 2nd instance of Grub that is used - or have I imagined that?

I can easily do a re-install of M18 if you think that would be best? My thoughts are to manually partition the second half first in preparation but I would need guidance with it - I’ve no experience of this on a drive with an OS already on it.

Thanks again for your time.

Rich