USB Keyboard & Mouse not working following kernel update

Hello,

I updated the kernel on my Linux machine to linux-image-2.6.39-bpo.2-686-pae. After the installation a couple of things changed:

  1. I was prompted to select the screen resolution I would like to use which did not happen before. My USB keyboard worked to select the option at this point.
  2. When the system finished loading the keyboard and mouse (both USB) do not work at all. I tried unplugging them and plugging them into other USB ports but they don’t work.

I used a portable version of Linux on a USB key and booted from that and it works fine.

Does anyone have a suggestion as to how to return to the previous stable version of Linux or how to get the keyboard and mouse to work?

Many thanks,

Christian

Hi and welcome to the forum :slight_smile:

Which Linux distribution and version ?

Have you ANY means of entering commands, eg. an PS/2 ketboard/mouse maybe ?

Is the earlier (working) kernel still installed ?

Can you still boot the earlier kernel from the GRUB boot menu ?