USB stick won't format (Solved)

I get this message when I try to erase the USB stick before making it a bootable Peppermint 6 stick

org.freedesktop.DBus.Python.gi._glib.GError: Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/dbus/service.py”, line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
File “/usr/share/usb-creator/usb-creator-helper”, line 239, in Format
block.call_format_sync(‘vfat’, GLib.Variant(‘a{sv}’, {‘label’: GLib.Variant(‘s’, ‘’)}), None)
gi._glib.GError: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object

Anyone know what is going on ?

Alternatively, have you tried to DD it onto the USB stick? No need to separately format.

Thanks for that, will have a go.

How are you trying to format the stick (which app/command) ?

and where is that error message being displayed ?

Hi Mark,
I was trying to make a boot disk with Startup Disc Creator and had chosen the erase disk option before starting.
This tried for almost 20 minutes with nothing happening so I stopped the programme and tried another USB stick.
There was a problem with this as well so I right clicked on them and chose Format and got the error messages.

Have you tried formatting them with the USB Stick Formatter in Peppermint 6 ?
menu > System Tools > USB Stick Formatter

If that doesn’t work, probably the easiest bet would be to install GParted and use it to rewrite the partition table, and create a new partition.

Let me know if the USB Stick Formatter doesn’t work, and we’ll go from there.

Thanks Mark,
All is safely done :wink:
I have a pen drive with Peppermint 6 on it, what is needed in case anything goes wrong.
I also have a pen drive with what looks like another setup on it, I will stik it in this machine and find out what it is later.
Thanks again for all your help.

take care
Don W