Using LCD TV as a monitor

OK, first thing first … let’s find out which graphics drivers you’re currently using … what’s the output from:

sudo lshw -C display

Thanks auto adjust on TV does not work.

There you go…

*-display
description: VGA compatible controller
product: GT218 [GeForce 210]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:16 memory:fd000000-fdffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:dc80(size=128) memory:fea00000-fea7ffff

What happens if you run:

sudo apt-get install nvidia-current nvidia-settings

then

sudo nvidia-xconfig

The second command gave this.

WARNING: Unable to locate/open X configuration file.

New X configuration file written to ‘/etc/X11/xorg.conf’

Then re-did the two commands and got this on the second one.

Using X configuration file: “/etc/X11/xorg.conf”.
Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.backup’
New X configuration file written to ‘/etc/X11/xorg.conf’

Now (after rebooting) what’s the output from:

sudo lshw -C display

?

BTW. Mint is auto detecting as a 32" display…it isn’t! I can’t unselect auto detect either.

Also this is a dual boot machine with Vista on. When I installed drivers I had the same problem but Vista driver disk installed a program allowing me to manually pull the edges in to create a perfect screen fit.

Below is the output.

*-display
description: VGA compatible controller
product: GT218 [GeForce 210]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:16 memory:fd000000-fdffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:dc80(size=128) memory:fea00000-fea7ffff

Is there nothing like that in “Nvidia Settings” (which should be in your menu somewhere ?

is HDMI the only input the TV has ? … no VGA or DVI ?

Yes it has vga Mark. That was the reason for the post. It is not very sharp. So I have bought a HDMI out card. I took the advive on this post and bought a Nvidia card.

and is there no setting in ndvdia settings that’s allow you to adjust the screen size ?

if not, try VGA with the new card … it may offer better resolutions.

if neither, we’ll look into adding a resolution … preferably the TV’s native resolution, so ti migh help to mention its make/model :wink:

No. Nvidia does not have a program for Linux, Mint just uses the driver. VGA cable would not work with card. I have adjusted the television to ‘Pixel to pixel setting’ and set the resolution to 1920 x 1080 on Display preferences. It’s OK now and I can get by but the font is a little small.

The TV is a Logik 22" LCD. Although Mint keeps reading as 32" in auto detect! And I can’t change it. >:(

What happens if you run:

nvidia-settings

First see my last posting … nvidia-settings might have what you need … if not, see below


If 1920 x 1080 fits the screen, you could try changing the DPI setting to make the fonts larger

Create a file in your home folder called .Xresources

gedit ~/.Xresources

and make it read:

Xft.dpi: 125
Xft.antialias: true
Xft.rgba: rgb
Xft.hinting: true
Xft.hintstyle: hintslight

SAVE the file.

Log off/on to test.

Changing the number 125 should change the font size … (96 is default).

Deleting that file and logging off/on will bring you back to defaults.


If this is Peppermint, you can change the icon size in File Manager > Edit > Preferences > Display

and panel size by right-clicking the panel, selecting Panel Settings > Geometry > Size

Hi Mark.

The Nvidia settings offered very little and unfortunately after following your instructions the font size hasn’t changed.

Mint 16, but may switch back to peppermint when 5 comes out.

What’s the contents of your

gedit /etc/X11/xorg.conf

?

Are you sure they didn’t change, just not by much ? … did you try a higher number, I dunno say 200.

Remember if anything goes wrong, booting from a LiveCD/LiveUSB then removing that file from your home folder will fix things … so feel free to experiment with that number in .Xresources

Working away for a couple of days will try when I get back.

I did try 200 and 250 and wasn’t any differnt Mark.

Here are the contents.

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 304.88 (buildmeister@swio-display-x86-rhel47-06) Wed Mar 27 15:32:58 PDT 2013

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
EndSubSection
EndSection

Re-visited the VGA option and took out graphics card to see why it would not work. The connector was not fully pressed into socket. it now works OK. I’ll wait and see what happens when I install PM5 in a few weeks.

Thanks for your help. :slight_smile:

Is there no DPI adjustment in nvidia-settings ?

Yes there are DPI settings in there Mark. All seems OK now (cross fingers). :slight_smile:

When I install PM5 soon I assume that there should be no problems.

Thanks
Adam

Well I hope not :slight_smile: