using pokerstars

man trying to use stuff on wine is complicated to me, even when i seem to follow the instuctions none of them work, so i clicky here and there managed to install it another way then they did and i cant run it now. tried there commands doesnt work so now im stuck. any help would be great.

from wine hq the only info i got was this, i dunno what it means and copypasting the ‘solution’ doesnt work. says setcap command not found.

See this: Bug #636278 “ptrace and pokerstars” : Bugs : Wine

In short:

Maverick introduced security feature which no longer allows programs to attach to processes. It can be disabled by:

sudo setcap cap_sys_ptrace=eip /usr/bin/wineserver

The setcap is in package libcap2-bin

libcap2-bin isn’t installed by default (which is why you’re getting the error with the setcap command), but I just downloaded and installed pokerstars on a Maverick system and it seems to run perfectly (at least in wine1.2) without the need for libcap2-bin or the setcap command.

  1. Download pokerstars from here:
    http://www.pokerstars.com/PokerStarsInstall.exe

  2. Place it in your home directory.

  3. Open a terminal and type:

chmod +x PokerStarsInstall.exe

and hit enter. (this makes the installer executable)… remember Linux commands ARE case sensitive.

  1. Stiil in the terminal type:
wine PokerStarsInstall.exe

and hit enter.

Pokerstars should now install and leave you with an icon on your desktop and in the menus at Applications>Wine>Programs>PokerStars>PokerStars

If at any stage you get an error, let us know exactly what it was and when it happened… or if the app doesn’t work properly, tell us which bit… the more info you provide the better :slight_smile:

i already seem to have the icon on my desktop and under the wine > programs. but if i try to load it i get error contact pokerstars support. maybe i need to find this libcap? ill try to update my os see if that helps aswel.

i re downloaded the pokerstars.exe with your link. not sure where my home directory is but i moved it from my download folder by right clicking move to home folder, then tried to exucute the command in terminal says it can not find.

put it in Places>Home Folder

But I’m thinking you may be better off completely removing WINE and reinstalling the wine1.2 version (including deleting the hidden .wine directory in your home directory)… then starting from scratch

be aware - deleting the hidden .wine directory will remove all installed windows apps too.

I’m a noob too Fulla this is what I did to get Pokerstars to work with Linux Mint Julia. You were so close to getting it working.

First open terminal and add the wine-ppa by typing (or copy and paste) the following and pressing enter,

ppa:ubuntu-wine/ppa

Mark Greaves was correct in that libcap2-bin is not installed by default, so go to your package manager and install libcap2-bin.

Then in terminal, type (or copy and paste),

sudo setcap =eip /usr/bin/wineserver

Enter your password and press enter. Then install Pokerstars with Wine. I used right click and selected “Open with Wine Windows Program Loader” and Bob’s your uncle.

I hope this helps.

Hi SydneyWizard and welcome to the forum.

In the end the issue was solved by removing WINE1.3 and reverting to WINE1.2 which didn’t need the installation of libcap2-bin or the setcap command to install/run Pokerstars.

So it appears to be a WINE1.3 issue rather than an Ubuntu 10.10 (Maverick) issue.