Using SSH to connect to server

I’m currently trying to get the hang of using SSH. I’ll be using it a lot once the NAS is running on the network, but I’m having problems just using SSH to connect to other laptops within the home network.

I’ve installed openssh-server on my lappy, and I’m trying to connect to my brothers/mums laptop.

My static local IP is: 192.168.0.2
My brothers/mums’ static local IP is: 192.168.0.3

I made an account on the other box, and the username is bally.

Whenever I run:

ssh -l bally karen-laptop.local

I get the return:

bally@bally-laptop $ ssh -l bally karen-laptop.local ssh: connect to host karen-laptop.local port 22: Connection refused

Is it a case of having to port forward, port 22 on my router or is something playing up?

Forwarded port 22 in the routers firewall. Has to be the firewall rules for the laptops.

EDIT: Added port 22 to both boxes. Still not connecting. :frowning:

Ran:

sudo ufw allow 22

EDIT 2: Doesn’t work when firewall is disabled either.

Surely the SSH server needs to be on your mothers PC, and you’d need to configure it to allow connections from your laptops IP address.

And I’d install hotssh on your laptop if I were you, then use that to connect to the SSH server on your moms PC.

Right I’ll give that a go.

P.S. Gnome-shell, why you so sexy? :frowning: Using Openbox by itself is pretty awesome.