Using two monitors (nVidia 6200 Turbocache)

How do I set up my system so I can use both monitors, separate things on each.
I’ve installed my monitor using the correct driver (I think)

http://img36.imageshack.us/img36/8363/nvidiadrivers01.th.jpg

http://img17.imageshack.us/img17/6926/nvidiadrivers02a.th.jpg

When I reboot, I do not get any boot options (well, not visible), e.g. Normal boot or Safe boot as the screen is displayed as black and white lines with flashing bits where the writing is supposed to be (like it’s crashed).

When I connect both monitors, only the one connected via the standard VGA connector is visible, the DVI one cuts put.
I don’t get a choice of monitors in Display settings either when both monitors are connected

http://img84.imageshack.us/img84/7430/displaysettings.th.jpg
This is my Samsung Widescreen Monitor (DVI)

How do I fix it so that I can use both monitors at the same time.

Go into nvidia-settings. or if your using Unity just type nvidia, and click on Nvidia X server settings.

You’ll then be able to configure your monitors by clicking the X Server Display Configuration tab. :slight_smile:

Don’t use Xinerama as the bugs haven’t been fixed yet. You’ll be able to find the bugs here:

http://linuxforums.org.uk/index.php?topic=1532.msg8972#msg8972

I have mines set-up like this at the moment using a Nvidia 9500GS M.

I’ve got a problem, No monitors!

http://img525.imageshack.us/img525/3000/xserverdisplayconfigura.th.jpg

http://img268.imageshack.us/img268/9273/xscreen0.th.jpg

http://img59.imageshack.us/img59/9273/gpu0.th.jpg

Somethings up for that to happen?

What iis displayed if you run:

gedit /etc/X11/xorg.conf

Does the same thing happen if you start the nvidia-settings from the command line as root ?

sudo nvidia-settings

and any particular reason you’re using the 173 drivers and not the driver tagged as (version current) [Recommended] ?

@Mark - You may remember I had some trouble setting up multiple monitors on my Nvidia card.

@Pete - See this posting: http://linuxforums.org.uk/index.php?topic=9041.msg62341#msg62341

Your monitors should be detected after the first 3 steps.

Yeh, that’s where I was heading … but from what I’m reading this particular error message may be specific to the 173 drivers.

As for my memory, anyone reading that would think you thought I was 50 and going senile or something. :wink:

Well, yes, I was using that one as I remember seeing the number 173 as the driver when I had cough XP installed :slight_smile:
The result of

sudo nvidia-settings

Section “Screen”
Identifier “Default Screen”
DefaultDepth 24
EndSection

Section “Module”
Load “glx”
EndSection

Section “Device”
Identifier “Default Device”
Option “NoLogo” “True”
EndSection

The result of

sudo nvidia-settings

The same result as previous screenshots

I’ve installed the current driver now and I get these …

http://img810.imageshack.us/img810/3000/xserverdisplayconfigura.th.jpg

http://img705.imageshack.us/img705/1952/gpu001.th.jpg

http://img717.imageshack.us/img717/1213/xscreen001.th.jpg

I will attempt to connect the ‘other’ VGA monitor and expect it to take over display as primary, when I want my DVI to be primary.

[EDIT]
I’ve connected both monitors and changed some settings so that my Samsung displays too, the VGA (ASUS) is selected as primary by the system, but I want the Samsung as primary
When I reboot with both connected now, they both start up ok but after entering my password it comes up with an error telling me the ‘taskbar’ (sorry, Windows speak there) or something is not there and needs to restart???
How can I set it back to default?

Changing the primary monitor would probably be pretty easy … I’m guessing just a case of editing thhe /etc/X11/xorg.conf file and changing the monitor and screen numbers.

But the exact error for the “taskbar” would be helpful.

Will it boot if you change the desktop by clicking the cog icon at the login screen ?

if so, run:
gedit /etc/X11/xorg.conf
and post the contents

I managed to get it to boot in the other desktop and I run it and get

peter@Petes-ubuntu-pc:~$ gedit/etc/X11/xorg.conf
bash: gedit/etc/X11/xorg.conf: No such file or directory
peter@Petes-ubuntu-pc:~$

Also, the Samsung monitor had a white screen on bootup. When I moved the mouse over to it I can left click and create a ‘drag box’, when I right click it cleared the ‘white’ background goes and my ‘normal’ desktop appeared but without anything on it.
I am writing this on my ASUS using the VGA connector.

you missed the space after gedit

gedit /etc/X11/xorg.conf

not

peter@Petes-ubuntu-pc:~$ [b]gedit/etc/X11/xorg.conf[/b]

Also … you didn’t include the EXACT “taskbar” error in you last posting … it will be hard to diagnose without it.

gedit ;

[spoiler]# nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 280.13 (buildd@allspice) Thu Aug 11 20:54:45 UTC 2011

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder58) Sat Apr 16 22:49:04 PDT 2011

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” RightOf “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Ancor Communications Inc ASUS VB172”
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “Samsung SA300/SA350”
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 6200 TurboCache™”
Option “NoLogo” “True”
BusID “PCI:1:0:0”
Screen 0
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 6200 TurboCache™”
BusID “PCI:1:0:0”
Screen 1
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “TwinView” “0”
Option “TwinViewXineramaInfoOrder” “CRT-0”
Option “metamodes” “CRT: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “TwinView” “0”
Option “metamodes” “DFP: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection
[/spoiler]

I will post the error in a few minutes, I have to reboot to the other desktop (and hopefully the error will reappear)

[EDIT]
The error it comes up with is
HPLIP Status Service
No system tray detected
Unable to start. exiting

OK, bit of an educated guess here (as I don’t have twin monitors OR an nVidisa card), but see the bits that I’ve highlighted in bold in your xorg.conf:

Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 [b] Option "TwinView" "0"[/b] Option "TwinViewXinera maInfoOrder" "CRT-0" Option "metamodes" "CRT: nvidia-auto-select +0+0" SubSection "Display" Depth 24 EndSubSection EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “TwinView” “0”
Option “metamodes” “DFP: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

I’m pretty sure ONE of those should read:

[b] Option "TwinView" "1"[/b]

that one NOT being the primary monitor. (“0” being the primary)

in a worst case scenario … rename the xorg.conf file with:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

and run the “NVidia XServer Settings” GUI to generate a new xorg.conf

I cant see where to change the twinview and doesn’t that mean clone.
What I want is one desktop my main one and another one I want so I can drop something on that I can monitor. Separate things on each.

You may be right about clone … I don’t know for sure, and cannot test.

To change (if you want to try):

sudo cd -v /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

then

sudo gedit /etc/X11/xorg.conf

then change it in there … save … reboot.

But you may be better off either -

a) comparing xorg.conf entries with BkS
or
b) creating a new xorg.conf (from scratch) … with these drivers. (see last bit of my last posting … or those 3 commands that BkS mentioned)


When you see this error -

HPLIP Status Service
No system tray detected
Unable to start. exiting

Does it stop you from booting ? … or does the system boot to a working desktop, but display that message ?

What I’m thinking is, un-instal it completley and then reinstall so it’s clean. Then try again.
When I get the error it just puts up the error box and then gives me choice to reboot, it doesn’t do anything else.
I can no longer get on or use the Gnome desktop.

Ok Pete, I’m not sure if you will find this much help, but here is my Xorg.config you can compare it with yours to see where you’ve gone wrong.

Typically what I do is this.

Open NVIDIA X server settings > Click X Server Display Configuration tab > Click on screen0 which is the primary monitor > Select my resolution, leaving the refresh rate at auto > Select position and select left of > I then goto the tab beside it, and select the monitor I wish to be secondary, which is my Acer P193w > I then tick the box that says “Make this the primary display for the X screen” > Click save to X configuration file > Click apply and then quit.

You’ll find my xorg.config below.

http://dl.dropbox.com/u/37779798/xorg.conf

What I'm thinking is, un-instal it completley and then reinstall so it's clean. Then try again.

Well that’s one option … but deleting your xorg.conf or renaming it should get you back to defaults … though you’ll probably have to do this from a root console now …

Reboot, and immediately keep stabbing the Shift key till the GRUB menu is displayed.

Select (recovery mode) and hit enter to boot

When offered the option, select Drop to a root shell

at the # command line, enter:

mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.noboot

then

reboot

to reboot … then use the “NVidia XServer Settings” GUI to generate a new xorg.conf

If that doesn’t work … do the same thing to end up back at the root shell, then run:

nvidia-xconfig

then

reboot

to reboot.

If however this problem is being caused by the HPLIP tray applet, let me know.

I think we have different versions of the nVidia control panel as they look different;

http://img843.imageshack.us/img843/5932/nvidiaxserversettings.th.jpg

What I’ve done so far;
I’m using my Samsung as primary connected via DVI and my ASUS connected via VGA is secondary.
I hotplugged the ASUS in and told nVidia to detect it, which it did, making it secondary (1).
I then rebooted, after quitting out of the nVidia control panel (which it says quitting causes it to save the current config).
I get the login screen where I choose GNOME 3 (which is the desktop that I am using to sort out the monitors) which is leaving the other desktop unaffected
I then get the problem, as you mentioned, the HPLIP Status Service
No system tray detected
Unable to start, exiting
It just gives me the ‘OK’ to click on