Uuntu 10.10 upgrade

Ermm, bit of a beginner here, and this could be in the wrong section, if so I apologise…
Last night I upgraded from ubuntu 10.04 to 10.10. Very slow process, but all is working fine.
Apart from my wireless connection to my router.

The icon shows no connection, even though the settings for the connection are set in the table.
ssid and password fine.

So I assume ubuntu cannot detect my wireless device Although 10.04 worked fine.
Any suggestions as to where I should look please? :-[

Can you open a terminal and enter:

lspci | grep Ethernet



hit enter after each command, and post the results of both commands here.

Remember - Linux commands ARE case sensitive.

As copied.

tim@ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:d3:4b:7e:a9
inet addr: Bcast: Mask:
inet6 addr: fe80::216:d3ff:fe4b:7ea9/64 Scope:Link
RX packets:3506 errors:0 dropped:0 overruns:0 frame:0
TX packets:3244 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3375907 (3.3 MB) TX bytes:409008 (409.0 KB)
Interrupt:44 Base address:0x2000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

wlan0 Link encap:Ethernet HWaddr 00:16:cf:ad:d9:23
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Any guidance would be greatly appreciated, thanks.

You missed out the:

lspci | grep Ethernet


tim@ubuntu:~$ lspci | grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

Whoops, sorry about that. Having a blank start.

  1. Is the wireless card a USB stick ?

  2. Can you send the output from:


I’m trying to find out the chip your wireless card uses…

tim@ubuntu:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0402:5602 ALi Corp. M5602 Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Sorry, I should have made it clear at the start, the wireless is built in.
Laptop is Acer Aspire 7110.

For some reason it doesn’t seem to be picking up that the wireless adapter is present… is there a switch to turn wireless ON ?
(wireless must be switched ON before issuing these commands)

also can you try this command:

sudo lshw -C network

(remember Linux commands ARE case sensitive)


lspci -vvnn | grep 14e4

if the wireless card is listed, send the output, if it isn’t send the whole output from:

sudo lshw

meanwhile, I’ll see if there are any known issues with the 7110.

From what I can gather, the Aspire 7110 uses a Broadcom bcm43xx wireless chip, so try this…

Attach your Aspire 7110 to your router with an ethernet cable (so it has an active internet connection).

Issue this command:

sudo apt-get install b43-fwcutter

When done… go to System>Administration>Additional Drivers (in menu’s at top of screen)
and if there is a wireless driver listed… activate it (highlight it, click activate).

(if this doesn’t work, see the posting above)

Is it possible to install a newer version like 10.10 over 10.04 without wiping settings, programmes etc?


To upgrade an LTS release to a Normal release… eg. 10.04 to 10.10…

Got to System>Administration>Synaptic package manager

When Synaptic opens…

Go to Settings>Repositories>Updates (tab)

Change - Show new distribution releases:
Long term support releases only
Normal releases

click Close… then Reload

Close synaptic. (you MUST close synaptic)

open the Update manager (System>Administartion>Update Manager)

You should now have a button telling you there is a new release, and asking if you want to upgrade.


Hit Alt+F2

in the “Run Application” dialogue box, enter:
update-manager -d
click, Run

and follow the instructions.

Thanks Mark. Very useful info’.


Back up anything important first though :wink:

As with any OS upgrade, sometimes things go wrong.

Also, expect it to take quite a long time… longer than a normal install.

Yes a backup would be a good idea!

tim@ubuntu:~$ sudo lshw -C network
[sudo] password for tim:
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 01
serial: 00:16:d3:4b:7e:a9
size: 100MB/s
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip= latency=0 link=yes multicast=yes port=MII speed=100MB/s
resources: irq:300 ioport:2000(size=256) memory:c8000000-c8000fff memory:c0000000-c001ffff
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 5
bus info: pci@0000:0a:05.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=32
resources: irq:20 memory:d0004000-d0005fff
description: Wireless interface
physical id: 1
logical name: wlan0
serial: 00:16:cf:ad:d9:23
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.35-22-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
tim@ubuntu:~$ lspci -vvnn | grep 14e4
0a:05.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

Card seems to be listed, and the other point is if I reboot back to win xp, wireless works fine.

Regarding Toonmans querie about an upgrade from 10.04 to 10.10, Your are right, SLOW is the word, set it going and then go for a curry !

Just want to say I appreciate all the time you are giving to my problem Mark.

Yup, the installation of b43-fwcutter should do the trick for a BCM4318.

See previous posting for a “How To”:

and/or “Installing b43 drivers”
(half way down this page)


Just want to say I appreciate all the time you are giving to my problem Mark.

Here here, He’s been brilliant helping me too.


@zebedee - Also check to see you have the firmware-b43-installer package installed.

sudo apt-get install firmware-b43-installer

tim@ubuntu:~$ sudo apt-get install firmware-b43-installer
[sudo] password for tim:
Reading package lists… Done
Building dependency tree
Reading state information… Done
firmware-b43-installer is already the newest version.
The following packages were automatically installed and are no longer required:
kdesudo update-manager-kde
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Seriously considering reverting to 10.04 Or will I not be able to install older version over the newer one.
10.10 apperance is nicer, but 10.04 worked out of the box, however. wireless is a priority for me.
Am I being a bit defeatist, Is it possible?

Still looking into it, but in the meantime can you send the output from:


I take it you’ve tried deleting the wireless network settings, and re-adding a new one ?

Can you send the contents of your wireless configuration file… located at


obviously you need to change the SSID_OF_ROUTER bit

you can leave out the wep/wpa key if you want… just replace it with “x’s”

you’ll need to open this file as root… so:

[b]sudo gedit /etc/NetworkManager/system-connections/[/b]SSID_OF_ROUTER

also send the output from:

ls /etc/NetworkManager/system-connections