Virgin Media Dongle

I’ve been trying to get my Dongle to work with Ubuntu without much success. I’ve spoken to the “Virgin technical experts” who were completely useless. I’ve been corresponding with another guy on a different forum but unfortunately the stuff he is suggesting i try does absolutely nothing. For example CTRL+ALT+T is supposed to bring up the terminal screen…it doesn’t. He also suggested I type:

lsb_release -a; uname -a; lsusb; echo
insert the device, wait 10 seconds then run:
dmesg | tail -n 10; lsusb

Which again does nothing, just brings up errors.

I’ve followed the “wizard” for setting up a mobile broadband but that does nothing either…

Please can anyone tell me how to set he infernal thing up?

cheers

The guy you were talking to was trying to get information from you which would help in diagnosing the problem… he expected you to post back the results of those commands… they won’t fix the issue but they will tell him what version of Ubuntu you are using, the kernel version, what is connected to the USB ports, and show if any errors are being thrown up in dmesg when you connect the device… All useful information.

Erm… Ctrl+Alt+T should open the terminal in Ubuntu.

We would need the same information, because until we know what make/model the device is, and what OS/version you are trying to run it on, it would be impossible to give a definitive answer or even know if the device was being detected at all.

the output from the first command would also tell him/us if the device was still in ZeroCD mode (behaving like a CDROM) and needed modeswitching.

Whether you go back to the original forum, or continue to look for help here, we will need the output from those commands.

so open a terminal (Applications>Accessories>Terminal) and enter:

lsb_release -a; uname -a; lsusb; echo

hit enter, and post back the resulting output.

Just for clarity… there is no “I” in that command, they are all “L”'s… but must be lower case… Linux commands ARE case sensitive.

I managed to get the information which I have attached below. The reason it wouldn’t return an answer was because I was using : instead of ;

Does this help?

gary@ubuntu:~$ sudo bash
[sudo] password for gary:
root@ubuntu:~# lsb_release -a; uname -a;echo
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
Linux ubuntu 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

root@ubuntu:~# dmesg | tail -n 10; lsusb
[ 354.046965] ISOFS: changing to secondary root
[ 404.003832] Linking with BTHomeHub2-4ZR6: channel is 6
[ 407.076040] Linking with BTHomeHub2-4ZR6: channel is 6
[ 407.094299] Associated successfully
[ 407.094301] Using G rates
[ 407.149740] Linking with BTHomeHub2-4ZR6: channel is 6
[ 407.190338] Linking with BTHomeHub2-4ZR6: channel is 6
[ 407.208395] Associated successfully
[ 407.208399] Using G rates
[ 407.262634] Linking with BTHomeHub2-4ZR6: channel is 6
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 1bbb:f000 T & A Mobile Phones
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@ubuntu:~#

Your dongle is in ZeroCD mode and needs switching… Install the usb-modeswitch package from within Synaptic, or with this command:
(you will need an active internet connection, so connect to a router with an ethernet cable if needed)

sudo apt-get install usb-modeswitch

hit enter, then your password when asked.

then follow the instructions here:
http://linuxforums.org.uk/linux-tips-tricks/setting-up-a-3g-dongle-from-the-ubuntu-network-manager/msg22872/#msg22872
to set up your connection with network manager.

or

follow the instructions here:

to use wvdial instead.

I’m having the same problem. The TECH-guys@virgin are rubbish. We don’t support linux/Ubuntu. WHY NOT, it’s an operating system (which is going to kill windows dead). I spent about 90 mins on the phone in total, after speaking to countless numb-nuts and being transfered to the WRONG DEPARTMENT, the last guy I spoke to suggested I ‘GOOGLE IT’ .

sudo apt-get install usb-modeswitch

lsb_release -a; uname -a; lsusb; echojennybunny61@jenny-Prebsario-CQ56-Notebook-; echolsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux jenny-Prebsario-CQ56-Notebook-PC 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:58e0 Realtek Semiconductor Corp.
Bus 005 Device 002: ID 046d:c03d Logitech, Inc. M-BT96a Pilot Optical Mouse
Bus 001 Device 004: ID 1bbb:0017 T & A Mobile Phones

I’d guess I have the same result, the dongle needs tweaking.

1bbb:0017 … looks like it’s already switched.

What is the dongle make/model ?

How are you trying to connect ?

and what makes you think there is a problem ?

I followed the instructions on here, it connected. After I did a reboot, it wouldn’t connect.

I followed the instructions on here

Tells me nothing … which instructions ?

In NetworkManager, did you tick the “Connect Automatically” … if not, you will have to manually connect each time you want to connect.

How did you enter the mobile connection in NetworkManager ?

did you run:

nm-connection-editor

to access the mobile tab in NetworkManager.

You aren’t giving me any info other than “it doesn’t work” … which isn’t very helpful :slight_smile:

I haven’t got a mobile dongle I can test things with in 11.10, so you’re going to have to be as descriptive as possible, answer my questions, and let me know what you’ve already tried.

I followed the instructions from here;

No
…Hope that clears it up a bit…

the usb-modeswitch instructions are just for switching the dongle from zeroCD mode to USB modem mode … they have nothing to do with setting up the connection itself.

for that, run:

nm-connection-editor

then follow the instructions here:
http://linuxforums.org.uk/index.php?topic=3102.0

Nope… not working

Cant get this thing called wvdial sorted

And not sure on this
[Dialer Defaults]
Modem = /dev/ttyUSB4
ISDN = 0
Modem Type = Analog Modem
Baud = 460800
Init1 = ATX3
Init2 = AT&F Q0 V1 E0 S0=0 &C1 &D2 +FCLASS=0
Init3 = at+cgdcont=1,“IP”,“internet.wind”
Phone = *99#
Dial Attempts = 5
Stupid Mode = on
Dial Command = ATDT
Idle Seconds = 7200
Ask Passwords = 0
Password = “Wind” Virgin said this is blank
Username = “Wind” Virgin said this is blank
Carrier Check = on
New PPPD = 1
Auto DNS = on

Also, some stuff, not sure exactly wouldn’t install properly

Why are you messing with wvdial ?

Nope... not working

Erm … not very helpful

Also, some stuff, not sure exactly wouldn’t install properly

Again, not very helpful … are you expecting me to guess ? :wink:

What’s the output from:

ls -a /etc/NetworkManager/system-connections

Use NetworkManager to set up the connection (not wvdial) … and try these settings:

Virgin Mobile
APN: goto.virginmobile.uk
Username: user
Password:

Someone also mentioned disabling CHAP in PPP Settings > Configure Methods … I don’t know if this is necessary, so try with and without.

cos it says it in here [SOLVED] USB Internet Key X225S (1bbb:f000, 1bbb:0017) on Ubuntu 10.04

``` Also, some stuff, not sure exactly wouldn’t install properly ```

Again, not very helpful … are you expecting me to guess ? :wink:

What’s the output from:

ls -a /etc/NetworkManager/system-connections

peter@Petes-ubuntu-pc:~$ ls -a /etc/NetworkManager/system-connections
. … virginmedia5697462 Virgin Media Broadband
peter@Petes-ubuntu-pc:~$

How the heck do you expect me to know you’re using instructions from the Ubuntu forum ? :stuck_out_tongue:

Anywho …

run:

nm-connection-editor

Click the Mobile Broadband (tab) … if there are any connections listed, delete them.

Once the Mobile Broadband tab has no connections listed, click Add

Select your Device … click Continue

Select United Kingdom … click Continue

Select Virgin Mobile … click Continue

Select Default … so the APN is listed as vdata … click Continue … click Apply

Put a tick in Connect Automatically … click Save

Unplug the dongle … wait 10 seconds … plug the dongle back in, and give it a minute to connect.

Does it connect ?

If not, run:

nm-connection-editor

Go to Mobile Broadband tab … highlight the connection, and select Edit

try changing
Username: user
APN: goto.virginmobile.uk

Save … and try again.

if those don’t work … in the connection settings go to PPP Settings > Configure Methods and try unticking CHAP

Try different combinations of the above.

I think it’s ok, it looks like it takes about 5 mins to wake up and sort itself out. I couldnt see it in the network menu at the top to start with but it appears there after a while???

Sorry I’m not explaining it fully, a bit knackered. Had to take Jenny to casualty early hours this morning (03:30) and didn’t get back till about 07:30. went straight back to bed. Woke up with a bad headache.

Needed laptop sorting as it’s for Jenny when she’s out in the car with me, due to her panic attacks (NO… not cos I’m driving lol) and so she can talk to me online when she’s in hospital (due to her condition, she’s in quite a lot)

No worries :slight_smile:

due to her panic attacks (NO... not cos I'm driving lol)

ROFL ;D