where has .usr\share gone

Hi,
I am looking for the usr/share/inkscape/extensions file but can’t find the usr folder to get started what have I done wrong ??

Dunno because you’ve neither explained what you were doing … where you were doing it (terminal/file manager/etc.) … or what went wrong (for example, “when I browser there in the file manager that directory doesn’t exist”, or maybe “when I run ls usr/share/inkscape/extensions in a terminal it returns that the directory doesn’t exist”, etc.).

The title of this topic is confusing me even more … it has a “.” in it, and a "" backslash ???
( a directory with “.” at the beginning of its name would be hidden, and backslashes are not used it Linux paths)

If you mean you’re entering sometthing like

ls usr/share/inkscape/extensions

in a terminal and it’s saying it doesn’t exist … that would be because you missed out the leading “/” … it should read

ls /usr/share/inkscape/extensions

If it’s any other problem you’ll need to explain.

BTW, /usr/share/inkscape/extensions is a directory, not a file.

Thanks Mark for that quick reply.
I am indeed trying to add 2 extensions to Inkscape, one will let me export Gcode that I can use for the raster images and the other will let me export Gcode for the vector images.
I will carry on now and see what transpires.

take care
Don W

Mark,
I have tried to put files into the Inkscape/extensions directory without success.
I have the files in a .zip file and have extracted them {/home/don/My_Setups/jtp_extension/JTP_Laser_Tool_V1_4.zip} but I can’t move/copy/paste them at all.
When I get to the extensions folder the option to Paste is greyed out. Have I missed a step ??

You don’t have permission to write to that directory … open the file manager as root.

I can’t tell you the exact command or GUI procedure as you haven’t mentioned which Linux you are using.

If it’s Peppermint 7 (as in your signature), open the file manager and navigate to
/usr/share/inkscape
then right-click on the extensions folder and select “Open as root”.

Or just fire up the Nemo file manager as root already at that directory

gksudo nemo /usr/share/inkscape/extensions

Thanks for that Mark,
As ever you have came up with the goods.
I have run Inkscape and produced the Gcode for the first very simple project.
I can’t try it out as the Laser engraver is out of reach (at the bottom of the garden) :cry: but hopefully the weather will ease up soon.

take care
Don W