Which Linux

How did you install firefox ?

is it not in the menu at

menu> Internet > Firefox


You REALLY need to get out of the Windows habit of downloading software from the internet … the correct way to install software in Linux is through one of your package managers
Software Manager
Synaptic Package Manager
these will download and install software for you, all from a central repository that’s checked for malicious code.

Once we get Firefox installed properly, we can fix the hard coded top level menu item from Chromium to Firefox, but if Firefox was installed properly it should be in the “Internet” submenu.

And I really would like to stop being asked for a password constantly, I selected an option for auto login during install but it doesn’t appear to be working.

We can fix autologin easy enough, but I’d SERIOUSLY advise against trying to disable being asked for a password for administrative tasks, this is ONE of the primary reasons Linux is considered so secure (but NOT the only reason) … remove this line of defence, and you may as well be back in Windows.

To fix autologin, can you open a terminal and post the output from:


and the contents of:

gedit /etc/lightdm/lightdm.conf


Tried to get firefox through the package manager several times but every time I clicked install it just said to check the internet connection, which seemed OK. Finally got it with ‘sudo apt-get install firefox’
Also found ‘sudo apt-get purge chromium-browser’ which got rid of most of it but we still have a shortcut for it on the bottom section of the start menu.

Have never really had a problem with windows as an OS, have 8.1 on our desktop and happy with it (tried 10 but not impressed, Ms seems to be turning into control freaks along with apple, google etc.) so was just looking for an OS that might run better on this old laptop, don’t know if we have been lucky but never had any of the security problems with windows that you hear stories of, grand kids hate our PC as we only have plain text email and block loads of stuff in the browser, like twatter (that’s not a typo) and facebook (can’t put my version of that) etc., due to having such a poor connection, so perhaps that stops a lot of the nasties.
Does linux have anything like the windows ‘hosts’ file as I find that very good for stopping a lot of internet stuff.

gedit /etc/lightdm/lightdm.conf - 0pens another window and shows:

Linux does have a ‘hosts’ file at

Weird, your autologin setup looks correct … though I can’t say I’ve ever seen anyone use a single letter for a username

Are we actually talking about a login screen ? … ie. the same screen you get if you hit

menu > Logout > Logout


and (ignoring the top level menu item for the time being) is Firefox in the menu at

menu > Internet > Firefox


Never bothered with all the ‘users’ stuff in windows, there doesn’t seem much point with us so didn’t think it would matter much with linux, you could probably even guess the password from that, though I should have picked a key closer to the enter key.
Yes, get a password screen similar to: menu > Logout > Logout when I try to use some of the the things in ‘system tools’ or ‘preferences’ also get asked for one when I try to enter anything in the terminal.

do have this now:
menu > Internet > Firefox
but still have:
menu > chromium - or is this ‘top level’?

Okay, you will get asked for the password to do anything considered “administrative”, the reason for this is Linux clearly separates what is “owned” by a “user” and what is “owned” by the system … this means a “user” (and any processes being run by that user) can ONLY damage stuff in his own “Home” folder, and not damage the system as a whole.

As you can see it’s an integral part of Linux security, and shouldn’t be messed with … I mean once the system is set up as you want it, you shouldn’t be prompted for password just to “use” the system, only if you want to make system wide changes :wink:

When you boot, do you get asked for a password BEFORE you get to the desktop … ie. to log on to the desktop ?
(this is what the auto login is supposed to bypass)

The top level Chromium menu item is pre-configured into the menu itself (a limitation caused by the light-weight and simplistic nature of the LXDE menu).

It can be changed, by running:

gedit ~/.config/lxpanel/Peppermint/panels/panel

find the section that reads:

        item {

and change it to:-

        item {

SAVE the file and exit gedit.

Now restart the bottom panel with:

lxpanelctl restart

Please remember that Linux commands ARE case sensitive, so be sure to use capital letters where shown.

No, not asked for password on boot/start.
Many thanks for all your help with this, I will leave it alone now as I think it doing everything we wanted.

You’re most welcome :slight_smile: