Wi-Fi adapters [Solved]

what happens if you manually load the ath9k driver

sudo modprobe ath9k

did it spring to life ?

and can you post the output from:

uname -a

No. I can still see only the wired connection(s) on the motherboard, plus Network proxy.

Here’s the output:
mike@mike-ubuntu:~$ uname -a
Linux mike-ubuntu 3.13.0-88-generic #135-Ubuntu SMP Wed Jun 8 21:10:42 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

As an experiment, have you got a LiveCD/LiveUSB ?

If so, does it work on that ?

I’m running a live DVD now, Mark (the one I installed Ubuntu from).

Still see only the wired connections and network proxy…

The odd thing is, linux-hardware-guide.com says it’s been supported out of the box since 10.04, and if I remember correctly, someone on the Ebuyer website commented that it worked out of the box for him in Ubuntu. Plus, I’ve got a laptop running the same version which connects effortlessly, which seems to rule out the router and the installation…

It should just work ???

Any chance you could try it with a 16.04 (or Peppermint 7) LiveDVD/LiveUSB

is this a windows dual boot PC … it’d be nice to confirm it’s not the card itself.

Yes, dual-boot (see reply #17). XP starts the installation automatically, though I don’t proceed, since I don’t want XP to go online, for obvious reasons.

Haven’t got 16.04 or Peppermint 7. I can download one if necessary, but probably not tonight…

It wouldn’t hurt to give it a shot mike (16.04/Peppermint 7 I mean)

We need to somehow verify if the card actually works … even if that ends up being in XP, just for a second or two.

OK. I’ll try one of them - probably XP as that will be quicker and easier.

Not tonight though - work tomorrow…

Thanks Mark. Watch this space.


It failed in XP too. Although it ‘found new hardware’, when I tried to install the drivers it said the card could not be started.

After a bit of investigation, I tried re-seating the card, and now it works in XP and Ubuntu.

I would have sworn the card was seated correctly the first time, but apparently not…

Thanks again Mark. Much appreciated, as always.


No problem Mike, just glad you figured it out :slight_smile:


With a little help…

I was just assuming it worked in XP because I got the ‘found new hardware’ message. It was you who pointed out the need to verify it. Elementary oversight on my part. Credit where it’s due.