Wi-Fi doesn't work on Debian

Hi, I am Konrad , I am a new user of this forum.
I am from Poland, so my English isn’t good enough. So please be forgiving for me.

But nevertheless I have faced with small problem with wifi driver on Acer 5560 - Wifi doesn’t work.

I am running Debian 8.1 Jessie.
Last time I had linux mint, and wrote “sudo apt-get install --reinstall bcmwl-kernel-source” then “sudo modprobe wl” and I added module to /etc/modules
And those things solved my problem.

But not here on debian jessie.
I tried the same here in debian, but that doesn’t work. I have to mark that on debian there isn’t any GUI (only terminal) unlike in previous mint.
Yesterday I downloaded broadcom-sta and wifi still doesn’t work.
Maybe I am doing something wrong. Or I have to use ifconfig or something?

Please share your ideas.
Thanks in advance.
Conrad

Sent from my OV-V10 using Tapatalk

See here:
https://wiki.debian.org/wl

If you’re still stuck, post the contents of your
/etc/apt/sources.list
file here

Ok, I’ ll try it tomorrow, because I’m feeling sleepy right now :wink:
And I’ll tell about results.
BTW. How do you think about my English? :slight_smile:

Sent from my OV-V10 using Tapatalk

Your English is pretty good … I could probably tell it’s not your native language, but it’s perfectly understandable…

Beats the heck out of my Polish, that’s for sure :slight_smile:

[EDIT]

Are you saying you don’t have a desktop GUI at all on Debian ? … do you want one, or is this a server ?

You’ll still probably need to compile the wl driver, but yeah configuring the wireless connection will be different without networkmanager

I decided to use this laptop as server to learn administration.
I didn’t install GUI because I’d like to learn something.

In GUI, you know, “click click” and all it’s done, but in terminal I have to do all things myself by commands.

But never mind, I think module wifi is working properly because ‘dmesg | grep wl’ showed wlan0 broadcom wireless controlller…, and led light WiFi is lighting.

Now there’s a connect issue.
I typed ‘iwlist wlan0 scan’
Then ‘iwconfig wlan0 essid key’
But I suspect that command support only WEP encryption.
Meanwhile I’ ve got WPA2.

What should I do?

Sent from my OV-V10 using Tapatalk

So, you are running Debian as a headless server.
If you are new to linux then you could have gone with any distro with GUI , no need to run it hadless.
But you are here now, so just persevere with the command line. You could look for instructions on how to bring the interface up etc here.

Where can I upload some photos?
Because I noticed something wrong.
I 've tried wpa-supplicant but no results.
Maybe problem is caused by driver? As I mentioned , I’d like to show picture of dmesg and lspci.

Sent from my OV-V10 using Tapatalk

I’ve set up static ip in /etc/networks/interfaces and I turned off WPA, to exclude wifi settings.

And I checked ping to gateway and is Unreachable.
Maybe that driver isn’t proper?

Sent from my OV-V10 using Tapatalk

Hi kondziorek

Where can I upload some photos?

http://imgur.com/

Good luck

Graeme

Is your network listed if you run:

sudo iwlist scan

?

Yes, when I type ‘iwlist wlan0 scan’ , I get several network including mine.

Sent from my OV-V10 using Tapatalk

OK, you’re gonna want /etc/network/interfaces to read somethink like this:-

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
address 192.168.1.101
netmask 255.255.255.0
gateway 192.168.1.1
wpa-ssid <your_network_ssid>
wpa-psk <your_wpa2_passkey>
dns-nameservers 192.168.1.1 8.8.8.8

You can get <your_wpa2_passkey> by running

wpa_passphrase <ssid> <your_wpa2_key>

Then restart the wlan0 interface:

sudo ifdown wlan0 && sudo ifup wlan0

now see if you can ping your router

Why this code is so complicated?
My /etc/network/interfaces look exactly like that:

Sent from my OV-V10 using Tapatalk

You suggest me to paste that code into my /etc?

My /etc/network/interfaces look actually like that.
Now I’m on mobile phone but I remember what I typed:

auto lo eth0 wlan0

Iface eth0 inet dhcp
Allow-hotplug eth0

Iface wlan0 inet dhcp
Allow-hotplug wlan0

Sent from my OV-V10 using Tapatalk

NO, not exactly like that … you’ll need YOUR network settings not mine

you’ll also want YOUR ssid
and YOUR wpa_psk

But this code, that you sent looks weird.
Anyway , you propose to use static settings in /etc/network/interfaces?

Sent from my OV-V10 using Tapatalk

I thought you wanted a static IP ?

it would make administration easier.

I’d rather dhcp, but I can also use static. No problem for me.
I’ll edit my /etc… tomorrow and I’ll let you know about that.
BTW. How does network look like in big corporations?
They use dhcp, or static? Static is more stable, I think.

Sent from my OV-V10 using Tapatalk

I typed that content you sent, with my address,netmask etc.
And WiFi works, thank you so much. That command with wpa helped me.

Now,
-Is it possible to set eth0 as automatic?
I mean when I disable WiFi by keyboard button, eth0 will automatically switch on.

BTW I was thinking to switch into Debian 7.8.
There are many innovations and new things in Jessie.
I’m not advanced linux specialist yet, so it’s good idea to change to wheezy.
How do you think?

Sent from my OV-V10 using Tapatalk

Big corporations use domain controllers & all sorts of complicated stuff. Typically servers will be on static IPs to avoid any connection issues for users, but there will also be internal DNS servers to help the users out (IP addresses are not very memorable!).

Edit: If you’re going to switch, then go for Ubuntu Server 12.04, it’ll make your life much easier