wicd fix - could not connect to wicd's D-Bus interface

I tried installing wicd in Peppermint 4 this morning and it wouldn’t start … after a lot of Googling there seems to be a lot of it about :o

If after installing wicd you get prompted for a password with this message:-

Wicd needs to access your computer’s network cards

Then after entering your password you get an error stating:-

Could not connect to wicd’s D-Bus interface
(and it wants you to check the error log)

Try this …

Open a terminal and run:

sudo mv -v /etc/resolv.conf /etc/resolv.conf.backup


sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf


sudo rm -v /var/lib/wicd/resolv.conf.orig


sudo service wicd start

Now see if “Wicd Network Manager” will start from your menus.

The above should work for any Ubuntu based OS … dunno about others.

To undo -


sudo mv -v /etc/resolv.conf /etc/resolv.conf.broken


sudo mv -v /etc/resolv.conf.backup /etc/resolv.conf

Thank you so much! You fix worked perfectly and I was finally able to use wicd.

Hi ctooth16, and welcome to the forum :slight_smile:

You’re most welcome, and cheers for the feedback.

Hi all,

Linux Newbie as such, having just installed Linux Mint 13 on an old HP Compaq nc4400.

All working fine, except I’m “not allowed” to add the laptop onto the work domain, and so I cannot connect it to the LAN to gain an internet connection.

Therefore, I have downloaded the files as suggested in Post1, and have followed the commands. All seems ok, but the b43 driver is not appearing in the “Additional Drivers” window.

Need to get the wireless working! :stuck_out_tongue:

Hi RyanVN, and welcome to the forrum :slight_smile:

Is there any output from:

modinfo b43



I take it we’re talking about an after-market USB wireless adapter ? … as everything I can find online suggests the nc4400’s built in Wireless isn’t a Broadcom at all, but an Intel PRO/Wireless 3945ABG which doesn’t need the b43 driver, it needs the iwl3945 driver.

What makes you think it’s a Broadcom wireless adapter that needs the b43 driver ?

Just to say a big THANKS !!!
works fine

Hi catoune, and welcome to the forum…

You’re most welcome … thanks for taking the time to let us know it helped :slight_smile: