WiFi does not connect (SOLVED)

Hi Mark,
I am having a bit of bother lately getting the WiFi to connect (again).
The icon on the screen shows 100% connectivity, but when I try to log on to a site the screen says it can’t connect.
I tried on the Windows machine and everything is ok. When I come back to my Linux machine it is all working now.
I have printed off the instructions I received in an earlier thread and will follow them when this occurs again.
Hope you can understand what I am saying. I will return. :wink:

take care
Don W

So what you’re saying is:-

Linux is randomly dropping the wireless connection to the router ?
or
It doesn’t drop the connection to the router … but for a while Linux is unable to access the WEB even though networkmanager says the connection to the router is solid ?

Next time it happens, can you check if you’re able to ping the IP address of your router, and ping Google by IP address and hostname
ping -c 5 <ip.address.of.router>
eg.
ping -c 5 192.168.0.1
and

ping -c 5 216.58.210.35

and

ping -c 5 google.co.uk

Hi Mark,
I have been at this all morning and am now about to give up with frustration. :cry:
I have tried the suggestion to ping

ping -c 5 216.58.210.35
and I get ‘Network is unreachable’

and when I try

ping -c 5 google.co.uk
I get ‘unknown host google.co.uk

The ping of your routers local IP was probably the most important one … can you do that next time.

Do you know your routers local IP address ?

Hi Mark,
I have rebooted the Linux machine and have connected with the router via cable. :smiley:
I have an internet connection ok and I have pinged as suggested and I get this

don@ldwatson ~ $ ping -c 5 216.58.210.35
PING 216.58.210.35 (216.58.210.35) 56(84) bytes of data.
64 bytes from 216.58.210.35: icmp_seq=1 ttl=52 time=23.7 ms
64 bytes from 216.58.210.35: icmp_seq=2 ttl=52 time=23.3 ms
64 bytes from 216.58.210.35: icmp_seq=3 ttl=52 time=21.2 ms
64 bytes from 216.58.210.35: icmp_seq=4 ttl=52 time=24.1 ms
64 bytes from 216.58.210.35: icmp_seq=5 ttl=52 time=21.2 ms

— 216.58.210.35 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 21.208/22.754/24.133/1.272 ms
don@ldwatson ~ $ ping -c 5 google.co.uk
PING google.co.uk (216.58.210.35) 56(84) bytes of data.
64 bytes from lhr14s23-in-f3.1e100.net (216.58.210.35): icmp_seq=1 ttl=52 time=23.4 ms
64 bytes from lhr14s23-in-f3.1e100.net (216.58.210.35): icmp_seq=2 ttl=52 time=24.4 ms
64 bytes from lhr14s23-in-f3.1e100.net (216.58.210.35): icmp_seq=3 ttl=52 time=27.5 ms
64 bytes from lhr14s23-in-f3.1e100.net (216.58.210.35): icmp_seq=4 ttl=52 time=26.4 ms
64 bytes from lhr14s23-in-f3.1e100.net (216.58.210.35): icmp_seq=5 ttl=52 time=33.1 ms

google.co.uk ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 23.470/26.997/33.138/3.388 ms
don@ldwatson ~ $
Is this ok ?

Hi Mark,
I am just back and on the computer and the internet is working on the WiFi. ??
This is weird.

Don there’s no point in running the ping command whilst connected with an ethernet cable … that will tell me nothing about the wireless connection.

and

I need you (when wireless isn’t working, and without an ethernet connection)) to attempt to ping YOUR ROUTERS IP address, NOT 216.58.210.35

Do you know your routers IP address ? ← please answer this question

If you’re not sure of your routers IP address, whilst wireless is working please post the output from:

route -n

and/or

ip route show

Hi Mark,
Are these what I need
don@ldwatson ~ $ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0
192.168.0.0 0.0.0.0 255.255.255.0 U 9 0 0 wlan0
don@ldwatson ~ $

and
don@ldwatson ~ $ ip route show
default via 192.168.0.1 dev wlan0 proto static
192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.2 metric 9
don@ldwatson ~ $

Spot on :slight_smile:

Next time the wireless drops out, can you (without connecting an ethernet cable) run the following commands and copy their output to a text file

ping -c 5 192.168.0.1

and

ifconfig

and

iwconfig

and

sudo iwlist scan

and

rfkill list

and

sudo lshw -C network

once you’ve got the output saved in a text file … connect to the router with an ethernet cable and post the output back here.

Would be a good idea to copy the above commands to a text file on your desktop whilst networking is still working … so you have them ready to run the next time wireless drops out :wink:

Hi Mark,
The connection dropped this evening so I ran the commands you suggested.
I have copied and pasted to a text file can I paste it here ?

take care
Don W

Hi Mark,
How can I insert the text I copied to the Text Editor.
I can click on ‘Copy’ and when I click here the options to ‘Paste’ are greyed out.

I take it you highlighted all the text in the text editor … then clicked “Copy” whilst it was highlighted ?

You should be able to “Paste” here … when “Paste” is greyed out it normally means the clipboard is empty.

Try installing a clipboard manager such as clipit

sudo apt-get install clipit

then run clipit from the menu (or reboot) to load it.

IIRC before having a clipboard manager you need to keep both applications open (gedit and the browser) to be able to copy/paste between them.

Hi Mark,
don@ldwatson ~ $ ping -c 5 192.168.0.1
connect: Network is unreachable
don@ldwatson ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:f5:f3:67:bf
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:864 errors:0 dropped:0 overruns:0 frame:0
TX packets:864 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:67956 (67.9 KB) TX bytes:67956 (67.9 KB)

wlan0 Link encap:Ethernet HWaddr a4:db:30:c7:44:e8
inet6 addr: fe80::a6db:30ff:fec7:44e8/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:330 (330.0 B) TX bytes:288 (288.0 B)

don@ldwatson ~ $ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

don@ldwatson ~ $ sudo iwlist scan
sudo: unable to resolve host ldwatson
[sudo] password for don:
eth0 Interface doesn’t support scanning.

lo Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 7C:4C:A5:DD:2C:7D
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=14/70 Signal level=-96 dBm
Encryption key:on
ESSID:“SKY9380E”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000338a0e4ed3
Extra: Last beacon: 588ms ago
IE: Unknown: 0008534B593933383045
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 0B050400230000
IE: Unknown: 2D1AAC181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1606080400000000000000000000000000000000000000
IE: Unknown: 7F03000008
IE: Unknown: DD800050F204104A0001101044000102103B000103104700103709C9AA4B662229C82524204BF8879B1021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
IE: Unknown: DD090010180204000C0000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
Cell 02 - Address: 20:0C:C8:7D:08:18
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=50/70 Signal level=-60 dBm
Encryption key:on
ESSID:“VM185937-2G”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000006cff75f180
Extra: Last beacon: 848ms ago
IE: Unknown: 000B564D3138353933372D3247
IE: Unknown: 010882848B960C121824
IE: Unknown: 030101
IE: Unknown: 050400010000
IE: Unknown: 0706474220010D14
IE: Unknown: 2A0104
IE: Unknown: 32043048606C
IE: Unknown: 2D1AAD011BFFFF0000000000000000000000000000000406E6E70D00
IE: Unknown: 3D1601001100000000000000000000000000000000000000
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
IE: Unknown: DD0900037F01010000FF7F
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD220050F204104A00011010440001021057000101103C0001011049000600372A000120
Cell 03 - Address: 7C:4C:A5:33:2F:C1
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=12/70 Signal level=-98 dBm
Encryption key:on
ESSID:“SKY35CA0”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000aa855b6183
Extra: Last beacon: 2144ms ago
IE: Unknown: 0008534B593335434130
IE: Unknown: 010882848B962430486C
IE: Unknown: 03010B
IE: Unknown: 050400010000
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 2D1AEC181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D160B080000000000000000000000000000000000000000
IE: Unknown: DD180050F204104A00011010440001021049000600372A000120
IE: Unknown: DD090010180201F02C0000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

don@ldwatson ~ $ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
don@ldwatson ~ $ sudo lshw -C network
sudo: unable to resolve host ldwatson
*-network
description: Wireless interface
product: RTL8723AE PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 00
serial: a4:db:30:c7:44:e8
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8723ae driverversion=3.13.0-46-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:18 ioport:e000(size=256) memory:f7d00000-f7d03fff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0.2
bus info: pci@0000:03:00.2
logical name: eth0
version: 06
serial: 00:90:f5:f3:67:bf
size: 10Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8402-1_0.0.1 10/26/11 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:41 ioport:d000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
don@ldwatson ~ $
Is this what is needed. ??

OK try this
(disables both firmware link power saving and software link power saving)

Open a terminal and run:

sudo gedit /etc/modprobe.d/rtl8723ae.conf

when a BLANK file opens, add a single line that reads:-

options rtl8723ae fwlps=0 swlps=0

SAVE the file and exit gedit.

Now REBOOT to load the changes.

Hi Mark,
I have carried out the above instructions and rebooted.
Everything seems ok, will I give it a couple of days before marking solved ?

Fingers crossed :slight_smile:

Hi Mark,
Another successful login this morning :smiley:
I will mark this as solved

take care
Don W
PS Hope your back is better

Cool … thanks for marking the topic solved :slight_smile:

Sorry about this Mark, but it is playing up again.
Switched on this evening and there is no internet connection.
I have run the commands and got the following result.

don@ldwatson ~ $ ping -c 5 192.168.0.1
connect: Network is unreachable
don@ldwatson ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:f5:f3:67:bf
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:408 errors:0 dropped:0 overruns:0 frame:0
TX packets:408 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:32384 (32.3 KB) TX bytes:32384 (32.3 KB)

wlan0 Link encap:Ethernet HWaddr a4:db:30:c7:44:e8
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

don@ldwatson ~ $ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

don@ldwatson ~ $ sudo iwlist scan
sudo: unable to resolve host ldwatson
[sudo] password for don:
eth0 Interface doesn’t support scanning.

lo Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 7C:4C:A5:DD:2C:7D
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=16/70 Signal level=-94 dBm
Encryption key:on
ESSID:“SKY9380E”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000001320c028c
Extra: Last beacon: 4ms ago
IE: Unknown: 0008534B593933383045
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 0B050200300000
IE: Unknown: 2D1AAC181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1606081500000000000000000000000000000000000000
IE: Unknown: 7F03000008
IE: Unknown: DD800050F204104A0001101044000102103B000103104700103709C9AA4B662229C82524204BF8879B1021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
IE: Unknown: DD090010180202000C0000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
Cell 02 - Address: 00:00:00:00:00:00
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=44/70 Signal level=-66 dBm
Encryption key:on
ESSID:“VM185937-2G”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000012030f17745
Extra: Last beacon: 4ms ago
IE: Unknown: 000B564D3138353933372D3247
IE: Unknown: 010882848B960C121824
IE: Unknown: 030101
IE: Unknown: 0706474220010D14
IE: Unknown: 2A0104
IE: Unknown: 32043048606C
IE: Unknown: 2D1AAD011BFFFF0000000000000000000000000000000406E6E70D00
IE: Unknown: 331AAD011BFFFF0000000000000000000000000000000406E6E70D00
IE: Unknown: 3D1601001100000000000000000000000000000000000000
IE: Unknown: 341601001100000000000000000000000000000000000000
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
IE: Unknown: DD0900037F01010000FF7F
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD8A0050F204104A00011010440001021057000101103B000103104700109D1CC8C68D6A5315ACFC727103E2758A102100074E65746765617210230007564D444734383510240007564D44473438351042000D334257343432575831364442351054000800060050F204000110110007564D444734383510080002210C103C0001011049000600372A000120
Cell 03 - Address: 20:0C:C8:7D:08:18
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=40/70 Signal level=-70 dBm
Encryption key:on
ESSID:“VM185937-2G”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000012030f27181
Extra: Last beacon: 768ms ago
IE: Unknown: 000B564D3138353933372D3247
IE: Unknown: 010882848B960C121824
IE: Unknown: 030101
IE: Unknown: 050400010000
IE: Unknown: 0706474220010D14
IE: Unknown: 2A0104
IE: Unknown: 32043048606C
IE: Unknown: 2D1AAD011BFFFF0000000000000000000000000000000406E6E70D00
IE: Unknown: 3D1601001100000000000000000000000000000000000000
IE: Unknown: 4A0E14000A002C01C800140005001900
IE: Unknown: 7F0101
IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
IE: Unknown: DD0900037F01010000FF7F
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD220050F204104A00011010440001021057000101103C0001011049000600372A000120

don@ldwatson ~ $ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
don@ldwatson ~ $ sudo lshw -C network
sudo: unable to resolve host ldwatson
*-network
description: Wireless interface
product: RTL8723AE PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 00
serial: a4:db:30:c7:44:e8
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8723ae driverversion=3.13.0-46-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:18 ioport:e000(size=256) memory:f7d00000-f7d03fff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0.2
bus info: pci@0000:03:00.2
logical name: eth0
version: 06
serial: 00:90:f5:f3:67:bf
size: 10Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8402-1_0.0.1 10/26/11 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:41 ioport:d000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
don@ldwatson ~ $

Hi Mark,
It is now working again this morning ??