Wifi dropouts

Mark

I ran the commands but no wifi came up. I did notice the nano’s led indicator had gone out though. I disconnected the ethernet and tried to manually fire up wifi but still nothing, so did a reboot just in case. The nano reactivated and the wifi spinner came on but still no connection. It kept asking for the wifi password but re-entering the p/w made no difference. Network manager reports ‘WiFi Networks Disconnected’ but the ‘Enable WiFi’ box is ticked.

I reconnected the ethernet to post this.

Rich

What’s the output from:

sudo lshw -C network

and

iwlist scanning

and

lsmod | grep 8192

and

lsmod | grep rtl

and

ls ~/ | grep 8192

OK, that’s weird … the original driver now seems to be working

So what happens if you click the networkmanager icon (by the clock) … do you get a list of available wireless networks including YOUR network ?

If you click YOUR network and select connect … does it ask for your wireless password ?

Be aware, it MAY first ask for authorisation … in which case it wants your LINUX password … THEN it’ll ask for your wireless key

I’m wondering if the Network Manager might be playing up? Now and then, when I click on it in the system tray, it won’t open and
I have to go through System Tools to get to it.

OK, run whichever of these 2 commands that works:

cd ~/8192cu-driver/rtl8192cu-fixed-for-313

or

cd ~/8192cu-driver/rtl8192cu-fixes

Then run:

sudo make uninstall

then let me know if this command errors or not (I don’t need the output, just wanna know if it errors)

modinfo 8192cu

and can you post the contents of

gedit /etc/udev/rules.d/70-persistent-net.rules

Ok -

modinfo 8192cu returned ERROR: Module 8192cu not found

and

gedit /etc/udev/rules.d/70-persistent-net.rules returned

This file was automatically generated by the /lib/udev/write_net_rules

program, run by the persistent-net-generator.rules rules file.

You can modify it, as long as you keep each rule on a single

line, and change only the value of the NAME= key.

PCI device 0x14e4:0x170c (b44)

SUBSYSTEM==“net”, ACTION==“add”, DRIVERS==“?", ATTR{address}==“00:15:c5:b3:de:44”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="eth”, NAME=“eth0”

PCI device 0x8086:0x4222 (iwl3945)

SUBSYSTEM==“net”, ACTION==“add”, DRIVERS==“?", ATTR{address}==“00:18:de:aa:9b:10”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="wlan”, NAME=“wlan0”

USB device 0x:0x (rtl8192cu)

SUBSYSTEM==“net”, ACTION==“add”, DRIVERS==“?", ATTR{address}==“74:da:38:00:76:38”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="wlan”, NAME=“wlan1”

OK let’s clean up the old attempt, run:

sudo gedit /etc/udev/rules.d/70-persistent-net.rules

and remove the bottom 2 entries, so it now reads:

# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x14e4:0x170c (b44)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:15:c5:b3:de:44", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

SAVE the file and exit gedit.

Back in the terminal run:

rm -r ~/8192cu-driver

OK, now let’s install the new driver properly as a DKMS module

With an active (cabled) internet connection, open a terminal and run these commands in sequence:

sudo apt-get install linux-headers-generic build-essential dkms git

then:

mkdir ~/8192cu-dkms

then:

cd ~/8192cu-dkms

then:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

then:

sudo dkms add ./rtl8192cu-fixes

then:

sudo dkms install 8192cu/1.9

then:

sudo depmod -a

then:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

Then REBOOT

Is wireless working ?


ONLY FOR REFERENCE (don’t do this yet)

To UNDO

To remove the dkms module:

cd ~/8192cu-dkms

then:

sudo dkms uninstall 8192cu/1.9

then:

sudo dkms remove 8192cu/1.9 --all

then:

sudo depmod -a

then remove the blaclisting file with:

cd /etc/modprobe.d

then:

sudo rm -v blacklist-native-rtl8192.conf

then REBOOT

That’s great, Mark! Wireless has connected at full signal (close to the router) so I’ll test it for a few days in other locations to see if it’s stable.

Q Will these settings survive a reboot?
Q I now have a ‘new’ connection that has reverted to default DNS servers - I prefer to use OpenDNS - if I reset the addresses will that work ok?

Thanks so much for your efforts - hopefully I can now solve two probs in one go - heat and wifi :wink:

Rich

Yes to both questions.

And you’re most welcome :slight_smile:

Oops! Spoke too soon… :-[ Fell at the 1st hurdle!

I moved the lappy into the next room and the WiFi died immediately! Network manager said ‘out of range’. Brought it back near the router and it fired up, no problem. This tells me the nano works, but at what strength? The bumph on the box claims 3 x wireless coverage so the range shouldn’t be an issue. It also claims ‘Green Power Saving’ so I wonder if it is switching to that if idle for a while? (But then, it should resume full power, on demand?)

Is it possible to check the power from the command line?

Btw, connection info shows 72Mbps, about half it’s capability, if that helps?

Rich

What’s the output from:

iwconfig

and

modinfo 8192cu

Rich, can we come back to this tomorrow … I need to do a little research, we may be better off going back to the default driver but I need to do some checking first.

No worries! Take as long as you like - I’ve got a busy weekend ahead so no rush. Really appreciate your efforts on my behalf :wink:

OK, let’s try some other drivers … these are actually the latest drivers from Realtek, but I’ve had to patch them so they’ll compile against the 3.13 kernel following the patch(es) mentioned here:

and


OK, instructions…

Open a terminal and run these commands in sequence:

cd ~/8192cu-dkms

then:

sudo dkms uninstall 8192cu/1.9

then:

sudo dkms remove 8192cu/1.9 --all

then:

sudo depmod -a

then run this command:

modinfo 8192cu

Hopefully that will throw a “module not found” error:-

modinfo: ERROR: Module 8192cu not found.

Meaning we’ve been successful in removing the 8192cu dkms driver

If that’s what is returned, carry on below … if not, STOP NOW and let me know.

Now let’s install the pre-patched Realtek driver from my dropbox … run:

mkdir ~/patched-8192cu

then

cd ~/patched-8192cu

then

wget [url]https://dl.dropboxusercontent.com/u/11876059/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz[/url]

then

tar xvf rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz

then

cd ~/patched-8192cu/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13

then

make

then

sudo make install

Now REBOOT.

Once rebooted, test wireless, and post the output from:

lsmod | grep 8192

and

lsmod | grep rtl

Hi Mark - thanks for getting back to me.

The removal of the ‘8192cu dkms driver’ was successful so I continued. When I got to the command from ‘dropbox’, terminal returned this -

richard@richard-Latitude-D520:~/patched-8192cu$ wget https://dl.dropboxusercontent.com/u/11876059/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz
https://dl.dropboxusercontent.com/u/11876059/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz: Scheme missing.
richard@richard-Latitude-D520:~/patched-8192cu$

I copied/pasted directly so I don’t think I missed anything out and tried a 2nd time (from scratch) to be sure but had the same return.

Continuing with the next command in the sequence returned this -

richard@richard-Latitude-D520:~/patched-8192cu$ tar xvf rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz
tar: rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

richard@richard-Latitude-D520:~/patched-8192cu$

Have I slipped up somewhere?

Cheers

Rich

Hi Rich

It looks like you’ve missed commands out and merged others

you missed mkdir ~/patched-8192cu and merged ~/patched-8192cu with wget https://dl.dropboxusercontent.com/u/11876059/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz

Try again following Marks instructions one line at a time

Graeme

Hi Graeme

No, nothing missed or merged - I just posted the errors that came up. Running the ‘dropbox’ command somehow repeats itself then says ‘scheme missing’. Trying the following command returns as I’ve said. I’ve tried 3 times now with the same result.

Rich

Try using this line:

wget https://dl.dropboxusercontent.com/u/11876059/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911-patched-for-3.13.tar.gz

instead of what Mark written with extra html tags.