wifi dropped /on after CLI query,mintWifi.py file problem? [solved]

Which version of Mint is this? Are you running the latest kernel?
What is the output from:

uname -r

I’m wondering if this is some kind of bug in the kernel module

uname -r Returns :

Edit, sorry mint 16 64 bit cinnamon

Firstly … you may want to remove your WAN IP address from your posting above … it’s not relevant to this topic, and I gather virgin IP’s are kinda “sticky” … no point advertising your external IP :wink:

Secondly I don’t mean in the router … I mean in Mint’s NetworkManager.

Sorry bit of cross post answering confusion, I was also replying to sezo within that post.

Can you tell me again what info you wanted, as I mentioned above, and bear this in mind:

I can't get to the settings as my network manager's telling me I'm a hotspot on the laptop, so I have to turn that off to enable wireless, when I do that, it them says wireless out of range, even 4 feet away, and the 'settings' button to get into the IP4V/6 settings doesn't let me in any more

Sorry I may have overlooked that…

Are you able to delete the wireless connection in network manager … and create a new one ?

As in ‘forget network’ ? Tried that several times and it won’t seem to ‘forget’ my network - also this afternoon, for the crack, I created a ‘guest network’ on the router,
if I connect to this I can get to edit the settings ! If I switch back to the original network, I CAN’T and it goes back to telling me I’m a wirelsss hotspot !

Edit: the ‘new’ network gives me:

Default route
IPv4 automatic (DHCP)
IPv6 automatic


OK if it’s not going to play the game let’s get dirty, what’s the output from:

ls -a /etc/NetworkManager/system-connections

I have for you . . . . . .

dave@dave-ThinkPad-T61 ~ $ ls -a /etc/NetworkManager/system-connections
.   Auto unsecured-wireless-network  Surveillance-Camera-4
..  Hotspot                          Wired connection 1
dave@dave-ThinkPad-T61 ~ $ 

I like to keep the neighbours on their toes with my network names :wink:

I like to keep the neighbours on their toes with my network names

I had 3 years of free Neighbourly WiFi until the selfish people upgraded to BT. Soooooo selfish. :wink:

Let’s rename the system-connections directory, create a new empty one and see if networkmanager will then open.


sudo mv -v /etc/NetworkManager/system-connections /etc/NetworkManager/system-connections-old


sudo mkdir -v /etc/NetworkManager/system-connections

then REBOOT.

BE AWARE this will leave you with no network connections … but hopefully NetworkManager will now allow you to create a new one.

That’s done the trick 8)

I was prompted for a connection, put my pass in and I was away, as a precaution I copied the system-connections folder to the desktop and renamed it but I’ll delete it.
I can now get into the further settings and the IPv6 and IPv4 settings are ok and as per the earlier post, just rebooted again afterwards to be sure to be sure, and you’ll be relieved to know it all went to plan . . . .

I don’t know why or how this came about (and I hate not knowing!) but I’m having it that it was something to do with that hotspot 'cos that was stopping me getting into anything, would have been interesting to have just deleted that connection from within the old folder and seen what may have happened . . . . . . anyway, thank you very much for your assistance/persistence and I’ll mark the first post as solved. :slight_smile:

You’re welcome :slight_smile:

Yeah I did consider saying to just delete the “Hotspot” connection, but then figured “WTF, delete em all” :wink:

A man with a plan I like, why nuke a few when you can nuke em’ all :slight_smile:

Thanks to everyone for the input, I got there in the end !

The longer a thread becomes, the more “finesse” tends to go out the window :wink:

I’ve just updated my thread on the mint forums in the hope it may help someone else one day so I thought I’d put the little additions I’ve played with here since too:

As an experiment, I replaced my now working network manager file with the old one! Bingo, back to square 1 - deleting the offending (so i thought) hotpspot file and rebooting didn’t work as I thought it would, so I deleted each of the four in there one by one and nothing worked until I cleared the file for my original wireless connection, rebooted and had to set it up as a new connection - which then worked, so exactly the same positive result as doing the same thing by command line. I’d taken the liberty of copying the old -
/etc/NetworkManager/system-connections file to compare it with the new, and lo and behold, the differences were in the IPv4 and IPv6 settings, details below . . . .

/etc/NetworkManager/system-connections file, differences in bold that may be the offending articles to the best of my knowledge . . . . Hope it helps someone else.
I’m not sure what the 'seen BSSID’s ’ or ‘auth-alg=open’ are, but it may help somewhere down the line to explain it all . . . . .


id=Auto unsecured-wireless-network





id=Auto unsecured-wireless-network





Yeah … “shared” means it shares your connection to other computers … effectively becoming a wireless access point.

Bit of a bug that you couldn’t disable that behaviour in the GUI though :frowning: