Wine on Linpus Lite Moblin

Hi! :slight_smile:
I am a new with Linux because I’ve bought Acer Aspire One D255 and it’s a whole new world for me. I’ve read that I need to install WineHQ so I can install Windows programs in Linux. So, I have downloaded versions of WineHQ and tried to install in terminal but it didn’t work. I have read read me file and I’ve done everything it’s says and nothing… I’m tired and confused. :S
Please help.

Thank you! :slight_smile:

First of all, you need to stop downloading software (directly) from the interweb… that’s a bad Windows habit you’ll need to break… you need to install software through your package manager, which will download it and install it for you.

If you are connected to the internet, do the following:

  1. Go to Files->My Documents to open the File Manager and then go to File->Terminal.
  2. In the terminal type:
xfce-setting-show

and hit enter
3. Click somewhere on the Desktop to get to the Desktop Preferences, then go to Behaviour (tab)
4. Enable “Show desktop menu on right click
5. Right clicking on the desktop will now give you more options.
6. Click System-> Add/Remove Software
7. If asked, enter your password.

From this application you can install anything that is on the list. Search for wine, mark it for installation and click apply.

Another way is press alt+f2 and type:

sudo yum install wine

I’ve found that on some other forum. Didn’t work either. :confused:
I have add/remove software but I can find it on the other way. That way you’ve described doesn’t work here… And when I go to add/remove software and search for wine, he doesn’t find anything. I don’t have package manager either.
And there’s one more thing I don’t understand… why I don’t have access to a Desktop folder? Permission is denied.
I really like Linux and I don’t want to install Windows but it’s really confusing. :confused:

And… when I try to install (like I’ve read from read me file) it’s says like this:

checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking whether make sets $(MAKE)… yes
checking for gcc… no
checking for cc… no
checking for cl.exe… no
configure: error: in /home/user/Documents/wine-1.1.40': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details.

Configure failed, aborting install.

[EDIT]
Ignore this posting… it appears to apply to Linpus Lite, but not the “Moblin” edition.
[END EDIT]

What output do you get if you run

sudo yum install wine

from a terminal ?


Really my advice would be to get rid of Linpus Lite and install Ubuntu Netbook Edition instead… Linpus Lite is base on Fedora core 8, a very old version of Fedora so you will have quite a few problems with it (in particular, it still only has firefox 2 in the repos).

Have you run a system update? … maybe WINE will show up then, but it should be in the repositories, at least an old version.

I get:

Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package wine available.
Nothing to do

Hmm… very strange… have you run a system update, and is your system connected to the internet?

OK, I know nothing about the “Moblin” version of Linpus Lite, but this might help:
http://ftp.twaren.net/Linux/Linpus/update/releases.n/moblin-final/applications/

Use your package manager to search for wine-1.1.29-4.moblin.i586 or similar.

Or you could try downloading the .rpm package from the above link and installing it… but you attempt this “at your own risk”.

By the look of things (on the Linpus site), they no longer do a “Moblin” edition, but they do a “MeeGo” edition… maybe dropping them an email might get a response.

http://www.linpus.com/index.html
(Contact Us link at bottom of the page)


If anyone manages to get WINE installed on Linpus Lite Moblin, could you please post here and let people know how you did it… there doesn’t seem to be a tutorial for this (that I can find) on the interweb, and this page is starting to get a lot of hits so it looks like a lot of people are “in the same boat”.

[EDIT]
I’ve emailed Linpus requesting a solution… if I hear anything from them, I’ll let you know.
[END EDIT]