Wireless printing in Ubuntu V11.10 - Solved

I added an HP 7200 series printer without any problem just by plugging it in. I have now given the PC to a friend who has an Epson PX720WD printer. When plugging the USB cable into the PC, Ubuntu doesn’t respond. I tried System Settings/Printers but the add-printer “+” button was greyed out.
Any ideas?

If you are using 32bit Ubuntu, download this file:
http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/debian/dists/lsb3.2/main/binary-i386/epson-inkjet-printer-artisan-725-835-series_1.0.0-1lsb3.2_i386.deb
and doulbe-click it to install … when the Ubuntu Software Centre opens, click “Install”

once the driver is installed … try setting up the printer again … and be sure to click “unlock” in the printer setup, or the “+” will be greyed out.

If i"Add Printer" (+) is still greyed out, try starting it from the command line with:

sudo system-config-printer

If you’re using 64bit Ubuntu, use this file instead:
http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/debian/dists/lsb3.2/main/binary-amd64/epson-inkjet-printer-artisan-725-835-series_1.0.0-1lsb3.2_amd64.deb

Hopefully this will get the printer working (USB connection), but the scanner won’t, nor will wireless … if you need either of those, let me know.


Anther option would be (once you’ve installed the drivers from above) to set the printer up from the CUPS interface.

enter this address in your web browser (or click this link):
http://localhost:631/
hit enter.

Go to Administration>Find New Printers
or Administration>Add Printer

you will be asked for your username and password.

Many thanks for your quick reply, Mark.
I can’t access the Ubuntu Software Centre at present (everywhere else is OK) so will have to return to B’ham another day to finish the job.
Ultimately my friend will need to scan and print wirelessly (32 bit).
I shall report when the file is installed.

Regards,
Keith

You don’t need too access the Ubuntu Software Centre … that will automatically open when you double-click the downloaded driver … it’s the Ubuntu Software Centre that does the installing of the downloaded file.

I’ll type up instructions later to get the Scanner and wireless working … but let me know how you get on with getting the printer working through USB

Sorry for the confusion: the downloader failed (queried my internet connection) and neither could I download Thunderbird.
Anyway, the good news is that Ubuntu was working away quietly in the background as I had tried to find drivers when logged in as another user - and it found a driver for the PX710 printer which works well via USB.
I’m back to Oxford now and will be very grateful for your extra instructions - no rush.
Many thanks, as usual.
Keith

OK, to get the scanner working (including a wireless connection) …

Go to this page:
http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do

ignore the Model name drop down menu, and instead scroll down to the Form for download section.

in that section look for:

Artisan 725,Epson Stylus Photo PX720WD/TX720WD

and tick the box (circle).

scroll to the bottom of the page, and make the 2 dropdown menu’s read:

Distribution = Ubuntu
Distribution version = 11.10

Click Next.

Now from that page, download these 3 packages.

iscan-data_1.13.0-1_all.deb
and
iscan_2.28.1-3.ltdl7_i386.deb
and
iscan-network-nt_1.1.0-2_i386.deb

To install them, just double-click them, then when the Ubuntu Software Centre opens, Click Install… they MUST be installed in the order above, so install iscan-data_1.13.0-1_all.deb FIRST.

The scanner should now be working from a USB connection, but tto get it working wirelessly …

Now you need to get the IP address for your All-In-One.

This bit is for a different Epson printer, but it should be similar for the PX720WD… Go to Menu on the front of the printer, select “Setup,” then “Confirm Network Settings.”
Somewhere in there, the IP address of your printer/scanner should be listed.
If you want, you can print a status sheet from here by hitting the “Start” button… This will contain info like your IP address, Device ID, Workgroup, Port, etc.

Once you know the IP address for the All-In-One, open the /etc/sane.d/epkowa.conf file for editing:

sudo gedit /etc/sane.d/epkowa.conf

(check that it already contains a load of commented out (# at beginning of line) lines… if it’s empty, let me know).

Add a line at the bottom that reads:

net <[b]your[/b] Printer's IP address>

example -
net 192.168.1.12

SAVE the file, and try iscan now (may require a reboot).


It would be a good idea to give your Epson All-In-One a static IP, because if it ever gets assigned a different IP by the DHCP server, the scanner will stop working unless you edit epkowa.conf with its new address.

Many thanks for your advice, Mark. I am due back in B’ham on the 29th and will try your instructions then.
In the meantime, I have another problem (no surprise there!) that I shall post now.

Back to this at last, which will be useful for both my friend’s Epson PX720 and my HP7200.
Both computers are recent V11.10 installations I guess the lack of “sane.d” files is the same for both:
There is no /etc/sane.d/epkowa.conf file but there is a file: “epson2.conf” with contents:
[i]# USB
usb

For libusb support for unknown scanners use the following command

usb

e.g.:

usb 0x4b8 0x110

Network

net 192.168.1.123

net autodiscovery[/i]


The SANE website (SANE: Supported Devices) lists :
Stylus Photo PX700W (although my friend’s is PX720WD)
USB
Network 0x04b8 / 0x0846 (can we use this?)
Support = Good
network interface supported all-in-one overseas version of the EP-801A
Back-end = epson2 (1.0.124) (N.B. Epson2)
man page = sane-epson2


I’m getting better at sourcing information, it’s just that I don’t know what to do with it!

Did you install ALL of the 3 packages I mentioned in my last posting ? … as epkowa.conf is contained in the iscan_2.28.1-3.ltdl7_i386.deb package.

Assuming te epkowa package is specifically for the Epson printer (my HP is fine now): this printer is 65 miles away at my friends house, so I haven’t downloaded anything yet.
I shall be delivering the Asus laptop to her father tomorrow (29th) and will attack her wireless printer problem when I get there.
Shall you be available for assistance tomorrow? (a cheeky question, I know!)

Probably :slight_smile:

I have just downloaded the three packages and the epkowa.conf file has appeared - which is a good sign!
Checking the printer settings yields the following:

“Obtain IP Address: Auto
IP Address: None (0.0.0.0)
Subnet Mask: 255.255.255.0”

Hmm! Any ideas?

What is the (local) IP of his router ? … eg. 192.168.0.1

is DHCP enabled in the router ?

Have you entered the wireless key in the printer ?

is wireless disabled on the printer ?

I take it you’re trying to connect wirelessly ?

After many hours of dedicated work by Mark, the Epson PX720WD All-in-one wireless printer is working on the wireless network.
The route to success is too tortuous to relate, or for me to remember, but I can offer this advice to readers:

  • Before rushing to this Forum for help, make sure that you have read all the documentation for your printer. It’s on-line if you’ve lost it.
    If you have yet to buy a printer, The Ubuntu Community (Printers - Community Help Wiki) has much advice on printers usable (or not) under Linux, and has some user feedback.
  • In the case of the PX720, the manual assumes that you are not using Linux, and is in any case useless except for the most basic needs. So I rushed to this Forum for help!
  • The PX720 user-panel is not particularly informative and I recommend that before asking for help with any similar printer that the user becomes very familiar with the menu layout – this might have saved considerable time in my case.
  • If it becomes necessary to use the Chat facility of this Forum, do remember that there is a delay in transmission, and in the heat of despair messages soon become out of sync which can lead to confusion. Always wait for a reply before taking any action, and then report the results of your action.
  • If you have the time, I suggest that you make notes of the process of the fix so you can have a go yourself next time.
  • Remember that your mentor is giving his time for free, so please be patient – and grateful.

Thanks, Mark.

You’re most welcome :slight_smile:

I’m glad you fellas have been able to fix this issue. Just so I can get a rough idea. Which Wireless Printer would you recommend? (Mark) My mum is soon to be buying a printer, and we’ll need a laser printer for printing photos, business cards and things a like.

HP every time … just check the particular model is supported by hplip:
http://hplipopensource.com/hplip-web/supported_devices/index.html
:slight_smile:

There’s also a page of recommended HP printer models (don’t know how up-to-date though), here:
http://hplipopensource.com/hplip-web/recommended.html

A quick Google to check if anyone’s had issues with a particular model doesn’t hurt either :wink:

HP’s are dead easy to set up wirelessly, thanks to the HPLIP Toolbox … they pretty much “just work”.


Though most of the Epsons will also work, they can just be slightly “fiddlier” to get working.

I also hear that Samsung are now including Linux drivers in the box with some models.

I tend to take a liking to most of Samsung’s stuff, but printer wise HP’s have always been good to me in the past. If it is “true” that Samsung are including Linux drivers, I very well may just look into that.

Don’t take that as a FACT, just something I’ve heard … and I have no idea (if it’s true) how good the drivers are.

Check out this topic:
http://linuxforums.org.uk/index.php?topic=2122.0