wireless printing problem (solved)

Hello folks,

I’ve been printing wirelessly for some time now (laptop running Ubuntu 14.04LTS, HP Envy 4502).

Since yesterday, nothing. Every job I send to the printer ends up ‘held’. Releasing it doesn’t help (CUPS 1.7.2). I just get a series of messages that FF has blocked a redirection, and when I finish clicking ‘allow’ I’m back to ‘held’.

I’ve tried resetting the printer to factory defaults and starting again. I’ve gone through wireless setup on the printer (apparently successfully), I’ve tried Wi-Fi protected setup on the printer, which fails consistently. Still no prints. I’ve even tried banging my head on the desk, but that doesn’t work either. Cheaper than drinking though…

Anyone got any ideas please? The original setup went very smoothly, I seem to remember.

Have you set a static IP on the printer ?

Are you using the HPLIP Toolbox to configure your printer ?

Hello Mark,

As far as I remember, I just worked through the menu system on the printer, typed in our wifi network address, and it worked…

I think I used Wi-Fi protected setup, push button setup, then pressed the WPS button on the router for three seconds.


I’ve downloaded HPLIP TOOLBOX, but still no luck. Although Printer Queue Control indicates that the printer is the default, is started, and is accepting jobs, the status of print jobs goes from ‘printing’ to ‘on hold’ without anything printing.

Have you deleted ALL printers in “Printers”, then tried setting up the printer from scratch in HP Toolbox ?

You might also want to try that WPS setup routine again in case it’s just that your router has “forgotten” the printer.

Otherwise we may have to manually configure the printer with a static IP address.

I would be helpful if you could get your printer to tell you its current IP address ?

Hello Mark,

A quick look in ‘printers’ showed that no printers were installed. I went through the printer menus to find it’s IP address for you (, then I tried adding a printer using that as the host under ‘network printers’. It was found, and HPLIP was suggested as the default connection, which I accepted.

Job done! I’m printing again.

Thanks for the pointers. It was your request for the IP address which led me down that path…

Marking this solved now.

Great stuff Mike, glad you figured it out :slight_smile: