Wireless woes after Ubuntu 16 upgrade [SOLVED?]

I have just upgraded Ubuntu 14.04 to 16.04 on my Lenovo T500. It all went amazingly well, except for Teamviewer which is missing one file, and I installed gnome-fallback (or “flashback” as it is now called).

After a while I lost wireless contact so tried the usual things:

  1. rebooted the BT router (although my internet 'phone was still working)
    2. iwlist scan command showed signals available including my router

  2. Ethernet cable reinstated communications to the internet
    So must be a PC wireless problem. Removed the Ethernet cable.

  3. still no Wi-Fi connection

  4. Clicked the wireless icon in the top-right panel

  5. deselected “Enable Wi-Fi” then

  6. re-selected it again
    Wireless comms re-instated!

But the connection was lost again after closing the PC lid for a cup of tea.
Clicking the wireless icon showed “wireless disconnected” although both Network and wireless “enabled”.
iwlist scan showed no devices available.

Hmmm! A dying PC wireless receiver perhaps. Scrabbled around and found a USB wireless dongle thingy and plugged it in: connection re-instated! For a few minutes anyway. Although there is communication with the router (iwlist, etc) there is no connection to the internet.

Tried disabling then enabling Wi-Fi via the wireless icon and the connection is back - for now!

Is my PC’s receiver dying/dead or might the problem be related to the upgrade? Ethernet connection is always reliable. I would be grateful for advice, as usual.

Keith


Update 16:26 Reliable internet connection is now only possible via the Ethernet, and not at all using the PC's receiver. Connection via the USB dongle works only occasionally.

Can you post the output from:

sudo lshw -C network

and

lspci -vnn | grep -iA2 net

Hello Mark. Here are the outputs:

keith@T500:~$ sudo lshw -C network
[sudo] password for keith:
*-network
description: Ethernet interface
product: 82567LM Gigabit Network Connection
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 03
serial: 00:22:68:0a:4b:c2
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=1.8-3 latency=0 link=no multicast=yes port=twisted pair
resources: irq:28 memory:fc000000-fc01ffff memory:fc025000-fc025fff ioport:1840(size=32)
*-network
description: Wireless interface
product: Ultimate N WiFi Link 5300
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 00
serial: 00:21:6a:37:27:b0
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-34-generic firmware=8.83.5.1 build 33692 ip=192.168.1.70 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:31 memory:f4300000-f4301fff
keith@T500:~$

keith@T500:~$ lspci -vnn | grep -iA2 net
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03)
Subsystem: Lenovo 82567LM Gigabit Network Connection [17aa:20ee]
Flags: bus master, fast devsel, latency 0, IRQ 28
Memory at fc000000 (32-bit, non-prefetchable) [size=128K]

03:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4236]
Subsystem: Intel Corporation Ultimate N WiFi Link 5300 [8086:1011]
Physical Slot: 1-1
keith@T500:~$

Try running

sudo gedit /etc/modprobe.d/iwlwifi.conf

and adding this new line at the bottom.

options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8

SAVE the file and REBOOT.

Any problems, just remove the line, save, and reboot.

That worked a treat, Mark. I’ve had 40Mb/s wireless download speed for the last 5minutes, anyway, but I shall continue to monitor it.

Can you tell me what I have just done?

I notice that the second command indicates that the problem may be BT-related, and as the problem manifested itself only after upgrading to V16 is there an Ubuntu issue as well?

You’ve told the wireless driver (iwlwifi) to always load with certain parameters set

bt_coex_active=0
swcrypto=1
11n_disable=8

You can see what these parameters do by checking the “modinfo” for your driver

modinfo iwlwifi

That’s helpful.
Many thanks, Mark, as usual.

Keith

The BlueTooth coexist MAY be the problem, it may not , in fact probably not if it worked before unless there’s been a driver/firmware regression in 16.04
Personally I think it likely it was one of the other two parameters that probably fixed the issue, but it can’t huurt to leave all 3 parameters set unless they’re causing you problems elsewere such as bluetooth.

Funny you should mention Bluetooth.
The laptop always boots with Bluetooth enabled but it was only after switching Bluetooth off that I had these comms problems. I now have two Bluetooth icons in the top menu bar (without me adding an extra one). When I tried removing one of them I lost the whole bar (but I reloaded it).

Ah! I spoke too soon!
My wireless connection was down again this morning, despite iwlist showing communication with the router. I switched off Bluetooth, but without effect.
I tried commenting out the line added to iwlwifi.conf but wireless still didn’t work.

I modified the iwlwifi.conf file so that the new line reads:
options iwlwifi bt_coex_active=1 swcrypto=1 11n_disable=1
(I got the “11n_disable=1” idea from thinkpad - How to fix slow wireless on machines with Intel wireless cards? - Ask Ubuntu)

Wireless now works fine even with Bluetooth on (but for how long?). iwlist scan seemed to indicate that I am now using only 5.2GHz (and I know Bluetooth frequency-hops on 2.4GHz) but using sudo iwlist scan shows a lot more ESSIDs including mine on 2.4GHz as well - so I have no idea what change I have actually made that has got things working.

Anyway, I have wireless connectivity at present and shall report back on the long-term result.

Great stuff, hope it works out for ya :slight_smile:

Me too, Mark!
The instructions that you provided helped me to do better web searches, even if I didn’t understand much of them. But at least I found lots of things to try without breaking anything (unusual for me, I know).

Keith

Wireless comms failed again just now. Once more, the wireless dongle came to the rescue but iwlist showed no networks.
I edited /etc/modprobe.d/iwlwifi.conf to the values Mark suggested in Reply #3 and, voila!, I am up and running again.

Beats me. Unless it’s just coincidence.
One thing: after modifying the file and trying to reboot, the PC would not close down - the Ubuntu five dots just kept cycling - and I had to hard boot.

I am leaning towards buying a new wireless card. Any thoughts?

Thoughts on what … whether to buy one, or which one to buy ?

All your thoughts are always always worth reading, Mark!

Whether to buy one, first of all. Could card problems produce such symptoms? An unfair question, perhaps.

If you think the card could be contributing to my difficulties, then guidance on a suitable product would be welcome. I have browsed the web and found a huge range of prices and although it’s tempting to try a cheap one, experience tells me that might not be the best option.

Are we talking internal card or USB ?

if internal which socket type ?

If USB … is this a portable PC … I mean will a “nano” type adapter be better ?

I’m referring to the internal card - the permanent, installed device - the info is in my post # 2 and the PC is a Lenovo Thinkpad T500.

I haven’t had the card out yet, although I’ve found some web videos about how to do it. As for which socket type; the best I can do is get it out and photograph it, which I might have to do anyway to find out how many antenna connectors there are; apparently there are two types of card - with two or three connectors.

I’ve just extracted the card and attach a photo. I think the socket type is “Mini PCI Express” and Amazon have many sellers at not-too-expensive prices.
Upon re-assembling the PC I had to reset iwlwifi.conf to the previous set of options to get the wireless working again.

Does your PC have built in bluetooth ?

Yes it does, Mark. And, curiously, it has two Bluetooth icons in the top bar (classic view). One icon has two slider-buttons: Bluetooth on/off, and Visible on/off - and a link to Bluetooth settings. The other has a long menu of useful operations.