XBMC wont load (SOLVED)

Hi guys

I’m trying to get a PC working for my Grand-Daughter as her old one packed up, and I need XBMC however when I try to load it i only get a black screen and I have to reboot to get back to the desktop, if I lower the monitor resolution it will start to load up the XBMC screen but just locks partially loaded, I’m sure this a graphics card issue, but I don’t have another card I can try as it’s a pci express and I’m sure the onboard was an SIS chip which is worse

anyway here’s the display details

chloe@Linux3 ~ $ lshw -c display
WARNING: you should run this program as super-user.
  *-display               
       description: VGA compatible controller
       product: RV710/M92 [Mobility Radeon HD 4330/4350/4550]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:40 memory:d0000000-dfffffff memory:febf0000-febfffff ioport:e000(size=256) memory:febc0000-febdffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
chloe@Linux3 ~ $ 

Any help or advice would be much appreciated

Graeme

Have you tried to reset XBMC to defaults?
You could try to rename your .xbmc in your home directory. Then start it up. This should recreate the config files with their defaults.

If we’re talking Peppermint 5 … maybe try the later version from this PPA:

sudo add-apt-repository ppa:team-xbmc/ppa

then

sudo apt-get update

then

sudo apt-get dist-upgrade

then

mv -v ~/.xbmc ~/.xbmc-old

now try XBMC

To undo (and go back to the 14.04 default version):

sudo ppa-purge ppa:team-xbmc/ppa

Ok

@SeZp
I tried renaming the .xbmc folder but that made no difference

@Mark
I also tried following your instructions but it made no difference either

Graeme

as an experiment … what happens if you delete/rename your ~/.xbmc folder, set your resolution to 1024x768, then start XBMC

as an experiment .. what happens if you delete/rename your ~/.xbmc folder, set your resolution to 1024x768, then start XBMC

It’s just the same in as much as it partially loads up then freezes

Graeme

Yep, probably a graphics driver issue then.

Are there any other drivers being offered by “Additional Drivers” ?

Are there any other drivers being offered by "Additional Drivers" ?

No additional drivers offered

Graeme

Are there any other drivers I can try or any settings I can change to get this to work ?, it’s quite frustrating because it the graphics are fine in every other way

Graeme

Please ignore my last post I’ve found an Nvidia card and I’m trying that meantime

Graeme

Consider yourself ignored … D’oh! I responded didn’t I ::slight_smile:

Consider yourself ignored .. D'oh! I responded didn't I

Yeah well don’t make a habit of it (ignoring me that is) :slight_smile:

anyway just to finalize this thread, I found an nvidia geforce 7500 card and initially the resolution was still to too low although it opened into XBMC no problem so I installed the 304 proprietary, tested driver and it wouldn’t boot I tried nomodest & xforcevesa boot parameters still wouldn’t boot, so I reinstalled from scratch but needed the nomodeset boot parameter to get into the live session, once installed I installed the 304 proprietary and it was perfect, good resolution and opening XBMC no problem

So all’s well that ends well

Many thanks

Graeme

Am I to stop ignoring you yet ?

If so … Great stuff, glad you got it working.

If not, just imaging I’m talking to someone else :wink: