Xscreensaver

Hi Guys

This is probably a very simple that I should be able to work out but not managed to so far. I down loaded the Xscreen savers for Peppermint and they were working fine. I did some updates and now they dont work!! Please see attached which explains the problem. Can anyone help please? I have tried uninstall and reinstall to no avail

P.S. I like the screenshot with the Use Delay button - works a treat

Thankyou in advance

From what I can tell, it’s missing a “GLX” dependency for your main screen. :confused: I really am not all to familiar with Peppermint, but I did use Xscreensaver in Ubuntu. Have you checked it’s options panel?

This is an issue with the glx module for your server … probably not installed or not supported by your graphics card.

What does glxinfo tell you?

Cheers for coming back to me

I havent checked the Xscreensaver options menu as I havent seen it anywhere - any clues to where it might be?

The glxinfo pretty much says the same with no further clues. I have also just looked into the graphics card in case as this was working before but it comes up with:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

So I tried that and it comes up with:

nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section “Default Device” must have a Driver line.

sh: pkg-config: not found

ERROR: Unable to write to directory ‘/etc/X11’.

Could this be a clue? Its a lil beyond me!!

Thnks again

It is possible that you are not using the “nvidia” drivers,
hence the failure of the “nvidia-xconfig”
which is intended for the binary nvidia drivers
Please post the output from:

lsmod | egrep 'nv|nouv'

This should tell you which graphics driver module(s) are running

Could you open ‘Terminal’ and please post the output from:

sudo lshw -C display
ls -l /usr/bin/nvidia-xconfig
  • The options panel for Xscreensaver is in the system settings panel. (Varies on the version of distro).

Hi Guys

nouveau 621925 0
nvidia 9766978 0
ttm 65184 1 nouveau
drm_kms_helper 40971 1 nouveau
drm 184164 3 nouveau,ttm,drm_kms_helper
i2c_algo_bit 13184 1 nouveau
video 18951 1 nouveau
sata_nv 23176 2
will@Lil-Will ~ $

Again Im out of my depth here. Thanks

I completely removed the screen saver program and extras and re-installed and it seems to be only the ‘3D’ screensavers that aint working. When I think back they stopped working when I had the blue screen for a day or two after playing around with my screen resolution as it never fitted the monitor - thats sorted now???

I’ll test to see if I can recreate your situation, to find out what’s causing it but by the look of things, you need to install the nvidia drivers.

If you goto the app lens in Unity (if your using 11.04 or greater), and type additional drivers and select it you’ll bring up any additional drivers that need to be installed for your system.

If your on 10.10 or less goto System > Additional Drivers

If it comes it with nvidia drivers, install the one which says recommended as the 183 driver is very old and doesn’t support 3D.

Hi Bks

I have tried all three drivers - the old one, the recommended and the experimental. None of these drivers make any difference to the problem.

Could there a problem with a driver? Can we check the driver?

Thankyou

It looks like (in your original configuration) your display was using the “nouveau” driver
which is the free verson
Have you checked if your card [GeForce 6100 nForce 405] has 3D capabilities?
The settings for xscreenserver are:

xscreensaver-demo

Also could try:

glxgears

I did have the 3D screensavers working for a while. I will try the settings later when Im home, How do I check the card? Would buying a new graphics card to a better spec sort this out? or could that cause more problems as the mother board/hard drive is farily old/cheap aswell?

AMD Processor 2.60 GHz 32 bit Windows 7 SP1 1GB

Hmm… Seems your GFX card does support 3D acceleration, but there a ton of problems with it. It could very well be that you have 3D acceleration turn on, but there’s something going wrong between your card telling the motherboard, and the motherboard not reporting.

Could you post the output from:

glxinfo

Hi Guys

I have just tried the demo as below and it has decided to work!! Why would this make it work when going into Preferences - Screensaver - Preview or setting the s/s didnt work??

Maybe its one of them which the computer just needed turning on and off a few times???

Thankyou very much - Is there any chance that the problem might effect Google Sketchup when I get round to installing it?

You’ll only know when you install it, I couldn’t guarantee anything, but it’s highly doubtful.

Im back with this one again

Its decided not to work again

glxinfo says:

name of display: :0
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual or fbconfig

Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.

Also glxgears says:

Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t get an RGB, Double-buffered visual

and xscreensaver-demo

doesnt work this time

Is there any fix or is it more to do with the hard ware? I want to see if I (we) can fix this before trying Sketchup

Thanks again

Most likely the driver switched to another one and you lost opengl support.
You could try to remove/reinstall the drivers:

sudo apt-get purge xserver-xorg
sudo apt-get install xserver-xorg xserver-xorg-video-all
sudo reboot

Or just start with re-configure:

sudo dpkg-reconfigure xserver-xorg

Hi SeZo

Again no luck but possibly some more clues:

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED
xorg* xserver-xorg*
0 upgraded, 0 newly installed, 2 to remove and 14 not upgraded.
After this operation, 213 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database … 129485 files and directories currently installed.)
Removing xorg …
Removing xserver-xorg …
Purging configuration files for xserver-xorg …
will@Lil-Will ~ $ xscreensaver-demo
/usr/share/themes/Taqua/gtk-2.0/gtkrc:54: Clearlooks configuration option “sunkenmenu” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:55: Clearlooks configuration option “menuitemstyle” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:56: Clearlooks configuration option “listviewitemstyle” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:57: Clearlooks configuration option “progressbarstyle” is not supported and will be ignored.
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:22:58: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
glmatrix: root window’s visual 0x21 does not support the GLX extension.
will@Lil-Will ~ $ sudo dpkg-reconfigure xserver-xorg
Package `xserver-xorg’ is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: xserver-xorg is not installed.

Hi,

You appear to have missed step 2:

sudo apt-get install xserver-xorg xserver-xorg-video-all

then reboot

I have also tried Sketchup in hope that it is just the Xscreen saver but no luck see attached

Done:

sudo apt-get install xserver-xorg xserver-xorg-video-all
Reading package lists… Done
Building dependency tree
Reading state information… Done
xserver-xorg-video-all is already the newest version.
The following NEW packages will be installed
xserver-xorg
0 upgraded, 1 newly installed, 0 to remove and 14 not upgraded.
Need to get 0 B/13.4 kB of archives.
After this operation, 168 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package xserver-xorg.
(Reading database … 129475 files and directories currently installed.)
Unpacking xserver-xorg (from …/xserver-xorg_1%3a7.6+4ubuntu3.2_i386.deb) …
Setting up xserver-xorg (1:7.6+4ubuntu3.2) …
will@Lil-Will ~ $ xscreensaver-demo
/usr/share/themes/Taqua/gtk-2.0/gtkrc:54: Clearlooks configuration option “sunkenmenu” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:55: Clearlooks configuration option “menuitemstyle” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:56: Clearlooks configuration option “listviewitemstyle” is not supported and will be ignored.
/usr/share/themes/Taqua/gtk-2.0/gtkrc:57: Clearlooks configuration option “progressbarstyle” is not supported and will be ignored.
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
xscreensaver-demo: 21:30:30: Gtk-warning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
glmatrix: root window’s visual 0x21 does not support the GLX extension.