Xubuntu not asking for password on login [solved]

In an attempt to get gpodder to open on startup, I’ve been poking around in settings - specifically ‘Session and Startup’ and ‘Users and Groups’.

I haven’t managed to get gpodder to run at startup, but I have managed to stop Xubuntu from requiring my password on startup, despite the fact that under my user settings a password is ‘asked on startup’.

Anyone have any ideas please? I’m going round in diminishing circles…

TIA

I’ve found a solution to this problem now.

I edited /etc/lightdm/lightdm.conf and removed a line which said ‘autologin-user=m’.

That seems to have solved it, although I’m still baffled as to how I managed to create the problem in the first place!

M